summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-30 13:44:16 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-02 18:05:01 -0800
commit18971a81a298e87736e162823a40cfd9b0a999fb (patch)
tree6ff8d4f8b0b99e91eac453b76b5591b0d814292e /recipes-devtools
parent847b6f5d859a0b8bb1cb32e5a3236b1124494476 (diff)
downloadmeta-xilinx-18971a81a298e87736e162823a40cfd9b0a999fb.tar.gz
qemu-xilinx_2017.3.bb: Rewire QEMU recipe to adopt to Xilinx releases
Rewire so that we can update the Xilinx QEMU releases just like other recipes Acked-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-xilinx.inc47
-rw-r--r--recipes-devtools/qemu/qemu-xilinx_2017.3.bb46
2 files changed, 51 insertions, 42 deletions
diff --git a/recipes-devtools/qemu/qemu-xilinx.inc b/recipes-devtools/qemu/qemu-xilinx.inc
new file mode 100644
index 00000000..9b59ecce
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-xilinx.inc
@@ -0,0 +1,47 @@
1QEMU_TARGETS = "aarch64 arm microblaze microblazeel"
2
3require recipes-devtools/qemu/qemu.inc
4
5SUMMARY = "Xilinx's fork of a fast open source processor emulator"
6HOMEPAGE = "https://github.com/xilinx/qemu/"
7
8LIC_FILES_CHKSUM = " \
9 file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \
11 "
12
13PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
14BRANCH ?= ""
15REPO ?= "git://github.com/Xilinx/qemu.git;protocol=https"
16
17BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
18SRC_URI = "${REPO};${BRANCHARG}"
19
20S = "${WORKDIR}/git"
21
22# Disable KVM completely
23PACKAGECONFIG_remove = "kvm"
24
25# Enable libgcrypt
26PACKAGECONFIG_append = " gcrypt"
27
28DISABLE_STATIC_pn-${PN} = ""
29
30PTEST_ENABLED = ""
31
32# append a suffix dir, to allow multiple versions of QEMU to be installed
33EXTRA_OECONF_append = " \
34 --bindir=${bindir}/qemu-xilinx \
35 --libexecdir=${libexecdir}/qemu-xilinx \
36 "
37
38do_configure_prepend() {
39 # rewrite usage of 'libgcrypt-config' with 'pkg-config libgcrypt'
40 sed -r -i 's/libgcrypt-config(\s*--)/pkg-config libgcrypt\1/g' ${S}/configure
41}
42
43do_install_append() {
44 # Prevent QA warnings about installed ${localstatedir}/run
45 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
46}
47
diff --git a/recipes-devtools/qemu/qemu-xilinx_2017.3.bb b/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
index 624715da..f8a91d75 100644
--- a/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
+++ b/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
@@ -1,43 +1,5 @@
1QEMU_TARGETS = "aarch64 arm microblaze microblazeel" 1require qemu-xilinx.inc
2
3require recipes-devtools/qemu/qemu.inc
4
5SUMMARY = "Xilinx's fork of a fast open source processor emulator"
6HOMEPAGE = "https://github.com/xilinx/qemu/"
7
8LIC_FILES_CHKSUM = " \
9 file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \
11 "
12
13SRCREV = "8f8c89b18f6e4523099e41d81769fc534064b8de"
14SRC_URI = "git://github.com/Xilinx/qemu.git;protocol=https;nobranch=1"
15
16S = "${WORKDIR}/git"
17
18# Disable KVM completely
19PACKAGECONFIG_remove = "kvm"
20
21# Enable libgcrypt
22PACKAGECONFIG_append = " gcrypt"
23
24DISABLE_STATIC_pn-${PN} = ""
25
26PTEST_ENABLED = ""
27
28# append a suffix dir, to allow multiple versions of QEMU to be installed
29EXTRA_OECONF_append = " \
30 --bindir=${bindir}/qemu-xilinx \
31 --libexecdir=${libexecdir}/qemu-xilinx \
32 "
33
34do_configure_prepend() {
35 # rewrite usage of 'libgcrypt-config' with 'pkg-config libgcrypt'
36 sed -r -i 's/libgcrypt-config(\s*--)/pkg-config libgcrypt\1/g' ${S}/configure
37}
38
39do_install_append() {
40 # Prevent QA warnings about installed ${localstatedir}/run
41 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
42}
43 2
3XILINX_RELEASE_VERSION = "v2017.3"
4XILINX_QEMU_VERSION = "v2.8.1"
5SRCREV ?= "8f8c89b18f6e4523099e41d81769fc534064b8de"