summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-05-15 21:27:31 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-05-15 21:27:31 +1000
commit49da4cda12ab13f7f41ab440bffb9cdd83623f3a (patch)
tree789c945a699bdaa72bc6df81994d0f8fbd3c98eb /recipes-devtools
parent70e6e4ee845b8a7d9734755a5b74b902ce01dd2a (diff)
downloadmeta-xilinx-49da4cda12ab13f7f41ab440bffb9cdd83623f3a.tar.gz
qemu-xilinx-helper-native: Clean up preferred provider message
Due to this recipe being added there are two providers for qemu-helper-native, but by default one is never selected. This generates a message during the build that informs the user to select a provider. This is unnecessary as the only machines that care about setting the provider is currently zcu102-zynqmp due to its requirement for qemu-xilinx all other qemu machines should be using the qemu-helper-native recipe and non-qemu machines don't use the recipe. To prevent the message, only make the qemu-xilinx-helper-native recipe available when it is selected as the preferred provider otherwise skip it. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Acked-by: Alistair Francis <alistair.francis@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
index f04be960..f48a8d40 100644
--- a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ b/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
@@ -1,9 +1,14 @@
1 1
2python () {
3 if d.getVar("PREFERRED_PROVIDER_qemu-helper-native") != d.getVar("PN"):
4 raise bb.parse.SkipRecipe("Set qemu-helper-native provider to use this recipe")
5}
6
2def get_filespath_extra(d, subpath): 7def get_filespath_extra(d, subpath):
3 metaroot = next((p for p in d.getVar('BBPATH').split(':') if os.path.basename(p) == 'meta'), None) 8 metaroot = next((p for p in d.getVar('BBPATH').split(':') if os.path.basename(p) == 'meta'), None)
4 if metaroot: 9 if metaroot:
5 return os.path.join(metaroot, subpath) + ":" 10 return os.path.join(metaroot, subpath) + ":"
6 return "" 11 return ""
7 12
8# TODO: improve this, since it is very hacky that this recipe need to build tunctl. 13# TODO: improve this, since it is very hacky that this recipe need to build tunctl.
9# include the existing qemu-helper-native 14# include the existing qemu-helper-native