summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb')
-rw-r--r--recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
index f04be960..f48a8d40 100644
--- a/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ b/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
@@ -1,9 +1,14 @@
1 1
2python () {
3 if d.getVar("PREFERRED_PROVIDER_qemu-helper-native") != d.getVar("PN"):
4 raise bb.parse.SkipRecipe("Set qemu-helper-native provider to use this recipe")
5}
6
2def get_filespath_extra(d, subpath): 7def get_filespath_extra(d, subpath):
3 metaroot = next((p for p in d.getVar('BBPATH').split(':') if os.path.basename(p) == 'meta'), None) 8 metaroot = next((p for p in d.getVar('BBPATH').split(':') if os.path.basename(p) == 'meta'), None)
4 if metaroot: 9 if metaroot:
5 return os.path.join(metaroot, subpath) + ":" 10 return os.path.join(metaroot, subpath) + ":"
6 return "" 11 return ""
7 12
8# TODO: improve this, since it is very hacky that this recipe need to build tunctl. 13# TODO: improve this, since it is very hacky that this recipe need to build tunctl.
9# include the existing qemu-helper-native 14# include the existing qemu-helper-native