summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@xilinx.com>2013-04-29 12:05:19 +1000
committerSipke Vriend <sipke.vriend@xilinx.com>2013-04-29 12:05:19 +1000
commit7d09b3e7fac01abd5c54fe34bcf0b85b60d1e059 (patch)
tree2986d5fd6a73f1a5a3f58cbb275352c918b2f8ad /recipes-core
parenta48d3340657fed342b6294631dac3905663b4c1d (diff)
downloadmeta-xilinx-7d09b3e7fac01abd5c54fe34bcf0b85b60d1e059.tar.gz
Add creation of symlink uramdisk.image.gz which is default name for uboot ramdisk image.
Signed-off-by: Sipke Vriend <sipke.vriend@xilinx.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/core-image-minimal.bbappend2
-rw-r--r--recipes-core/images/rootfs-extra.inc16
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-minimal.bbappend b/recipes-core/images/core-image-minimal.bbappend
new file mode 100644
index 00000000..ebd015f1
--- /dev/null
+++ b/recipes-core/images/core-image-minimal.bbappend
@@ -0,0 +1,2 @@
1
2include rootfs-extra.inc \ No newline at end of file
diff --git a/recipes-core/images/rootfs-extra.inc b/recipes-core/images/rootfs-extra.inc
new file mode 100644
index 00000000..8919463b
--- /dev/null
+++ b/recipes-core/images/rootfs-extra.inc
@@ -0,0 +1,16 @@
1# File containing rootfs related tasks
2
3# Create links to match Xilinx uboot default names
4# Do this silently as they may not exist depending on configuration
5
6# When booting with sd card, Xilinx u-boot by default expects
7# the rootfs as a u-boot-mkimage wrapped file called uramdisk.image.gz,
8# so for convenience symlink the ext2.gz.u-boot file.
9# Confirm if all bsps need this?
10SRC_MKIMAGE_ROOTFS ?= "${IMAGE_NAME}.rootfs.ext2.gz.u-boot"
11SYMLINK_URAMDISK ?= "uramdisk.image.gz"
12do_rootfs_append() {
13 cd ${DEPLOY_DIR_IMAGE}
14 rm -f ${SYMLINK_URAMDISK}
15 ln -sf ${SRC_MKIMAGE_ROOTFS} ${SYMLINK_URAMDISK}
16}