summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/images/core-image-minimal.bbappend2
-rw-r--r--recipes-core/images/rootfs-extra.inc16
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-minimal.bbappend b/recipes-core/images/core-image-minimal.bbappend
new file mode 100644
index 00000000..ebd015f1
--- /dev/null
+++ b/recipes-core/images/core-image-minimal.bbappend
@@ -0,0 +1,2 @@
1
2include rootfs-extra.inc \ No newline at end of file
diff --git a/recipes-core/images/rootfs-extra.inc b/recipes-core/images/rootfs-extra.inc
new file mode 100644
index 00000000..8919463b
--- /dev/null
+++ b/recipes-core/images/rootfs-extra.inc
@@ -0,0 +1,16 @@
1# File containing rootfs related tasks
2
3# Create links to match Xilinx uboot default names
4# Do this silently as they may not exist depending on configuration
5
6# When booting with sd card, Xilinx u-boot by default expects
7# the rootfs as a u-boot-mkimage wrapped file called uramdisk.image.gz,
8# so for convenience symlink the ext2.gz.u-boot file.
9# Confirm if all bsps need this?
10SRC_MKIMAGE_ROOTFS ?= "${IMAGE_NAME}.rootfs.ext2.gz.u-boot"
11SYMLINK_URAMDISK ?= "uramdisk.image.gz"
12do_rootfs_append() {
13 cd ${DEPLOY_DIR_IMAGE}
14 rm -f ${SYMLINK_URAMDISK}
15 ln -sf ${SRC_MKIMAGE_ROOTFS} ${SYMLINK_URAMDISK}
16}