summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-applications
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-03-16 14:02:00 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:30:10 -0700
commitac0516ce7916796fbde8a20db8c179b77dc92bdc (patch)
tree00e54739768b100f129500eab217f26dce74d4d0 /meta-xilinx-standalone-experimental/recipes-applications
parent58c8191477d70802bf0a88180a0f731f8179731f (diff)
downloadmeta-xilinx-ac0516ce7916796fbde8a20db8c179b77dc92bdc.tar.gz
meta-xilinx-standalone-experimental: Adjust to match recent changes
Changes to meta-xilinx-standalone, as well as the embeddedsw require various changes to be made. This brings the implementation up to the current level. Note: various things do not yet compile! Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-applications')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb8
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-client/freertos-lwip-tcp-perf-client_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-server/freertos-lwip-tcp-perf-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-client/freertos-lwip-udp-perf-client_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-server/freertos-lwip-udp-perf-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/fsbl-zynqmp/fsbl_git.bb (renamed from meta-xilinx-standalone-experimental/recipes-applications/zynqmp-fsbl/zynqmp-fsbl_git.bb)13
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/hello-world/hello-world_git.bb6
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-echo-server/lwip-echo-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-server/lwip-tcp-perf-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-client/lwip-udp-perf-client_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-server/lwip-udp-perf-server_git.bb9
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/memory-tests/memory-tests_git.bb37
14 files changed, 110 insertions, 44 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
index 9b5bb110..fc10550d 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
@@ -1,12 +1,14 @@
1inherit esw deploy 1inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_hello_world/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_hello_world/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil xilstandalone xiltimer freertos10-xilinx device-tree" 5DEPENDS += "libxil xilstandalone freertos10-xilinx xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_install() { 14do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_git.bb
index ebfc85aa..0fce1541 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-echo-server/freertos-lwip-echo-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_echo_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_echo_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native freertos10-xilinx" 5DEPENDS += "libxil lwip xiltimer freertos10-xilinx"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-client/freertos-lwip-tcp-perf-client_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-client/freertos-lwip-tcp-perf-client_git.bb
index eb199d39..df6dab62 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-client/freertos-lwip-tcp-perf-client_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-client/freertos-lwip-tcp-perf-client_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_tcp_perf_client/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_tcp_perf_client/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native freertos10-xilinx" 5DEPENDS += "libxil lwip xiltimer freertos10-xilinx"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-server/freertos-lwip-tcp-perf-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-server/freertos-lwip-tcp-perf-server_git.bb
index c2282593..b325c01d 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-server/freertos-lwip-tcp-perf-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-tcp-perf-server/freertos-lwip-tcp-perf-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_tcp_perf_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_tcp_perf_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native freertos10-xilinx" 5DEPENDS += "libxil lwip xiltimer freertos10-xilinx"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-client/freertos-lwip-udp-perf-client_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-client/freertos-lwip-udp-perf-client_git.bb
index ccf8f09e..dcbca99e 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-client/freertos-lwip-udp-perf-client_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-client/freertos-lwip-udp-perf-client_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_udp_perf_client/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_udp_perf_client/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native freertos10-xilinx" 5DEPENDS += "libxil lwip xiltimer freertos10-xilinx"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-server/freertos-lwip-udp-perf-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-server/freertos-lwip-udp-perf-server_git.bb
index f2c9eaed..97bee6af 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-server/freertos-lwip-udp-perf-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/freertos-lwip-udp-perf-server/freertos-lwip-udp-perf-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_udp_perf_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/freertos_lwip_udp_perf_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native freertos10-xilinx" 5DEPENDS += "libxil lwip xiltimer freertos10-xilinx"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/zynqmp-fsbl/zynqmp-fsbl_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/fsbl-zynqmp/fsbl_git.bb
index a0d2d2b9..8c98ffe7 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/zynqmp-fsbl/zynqmp-fsbl_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/fsbl-zynqmp/fsbl_git.bb
@@ -1,17 +1,12 @@
1inherit esw deploy 1inherit esw deploy
2 2
3COMPATIBLE_MACHINE = ".*-zynqmp" 3COMPATIBLE_HOST = "aarch64.*-elf"
4COMPATIBLE_MACHINE = "none"
5COMPATIBLE_MACHINE_zynqmp = ".*"
4 6
5ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_fsbl/src" 7ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_fsbl/src"
6 8
7DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm device-tree" 9DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm"
8
9PSU_INIT = "${RECIPE_SYSROOT}/${includedir}/devicetree/psu_init*"
10
11do_configure_prepend() {
12 # Copy psu_init* files to fsbl source code
13 cp ${PSU_INIT} ${S}/${ESW_COMPONENT_SRC}
14}
15 10
16do_install() { 11do_install() {
17 install -d ${D}/${base_libdir}/firmware 12 install -d ${D}/${base_libdir}/firmware
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/hello-world/hello-world_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/hello-world/hello-world_git.bb
index c67fb5f5..ae99df0f 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/hello-world/hello-world_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/hello-world/hello-world_git.bb
@@ -2,13 +2,15 @@ inherit esw deploy
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/hello_world/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/hello_world/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil xiltimer device-tree" 5DEPENDS += "libxil xiltimer"
6 6
7inherit python3native 7inherit python3native
8 8
9do_configure_prepend() { 9do_configure_prepend() {
10 cd ${S} 10 cd ${S}
11 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 11 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
12 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
13 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
12} 14}
13 15
14do_install() { 16do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-echo-server/lwip-echo-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-echo-server/lwip-echo-server_git.bb
index e0d6f13c..86404751 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-echo-server/lwip-echo-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-echo-server/lwip-echo-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_echo_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_echo_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
index 6f0c9b4a..f33b5fd0 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_client/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_client/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-server/lwip-tcp-perf-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-server/lwip-tcp-perf-server_git.bb
index d9f990c4..4fc99181 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-server/lwip-tcp-perf-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-server/lwip-tcp-perf-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-client/lwip-udp-perf-client_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-client/lwip-udp-perf-client_git.bb
index fc89c13e..83e9abb0 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-client/lwip-udp-perf-client_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-client/lwip-udp-perf-client_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_udp_perf_client/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_udp_perf_client/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-server/lwip-udp-perf-server_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-server/lwip-udp-perf-server_git.bb
index 8b9114ac..5dde9610 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-server/lwip-udp-perf-server_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-udp-perf-server/lwip-udp-perf-server_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_udp_perf_server/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_udp_perf_server/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/memory-tests/memory-tests_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/memory-tests/memory-tests_git.bb
new file mode 100644
index 00000000..c2276653
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-applications/memory-tests/memory-tests_git.bb
@@ -0,0 +1,37 @@
1inherit esw deploy
2
3ESW_COMPONENT_SRC = "/lib/sw_apps/memory_tests/src/"
4
5DEPENDS += "libxil xiltimer"
6
7inherit python3native
8
9do_configure_prepend() {
10 cd ${S}
11 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} memtest
12 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
13 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
14}
15
16do_install() {
17 install -d ${D}/${base_libdir}/firmware
18 # Note that we have to make the ELF executable for it to be stripped
19 install -m 0755 ${B}/memory_test* ${D}/${base_libdir}/firmware
20}
21
22MEMORY_TESTS_BASE_NAME ?= "${BPN}-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
23MEMORY_TESTS_BASE_NAME[vardepsexclude] = "DATETIME"
24
25do_deploy() {
26
27 # We need to deploy the stripped elf, hence why not doing it from ${D}
28 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/memory_test.elf ${DEPLOYDIR}/${MEMORY_TESTS_BASE_NAME}.elf
29 ln -sf ${MEMORY_TESTS_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf
30 ${OBJCOPY} -O binary ${WORKDIR}/package/${base_libdir}/firmware/memory_test.elf ${WORKDIR}/package/${base_libdir}/firmware/memory_test.bin
31 install -m 0644 ${WORKDIR}/package/${base_libdir}/firmware/memory_test.bin ${DEPLOYDIR}/${MEMORY_TESTS_BASE_NAME}.bin
32 ln -sf ${MEMORY_TESTS_BASE_NAME}.bin ${DEPLOYDIR}/${BPN}-${MACHINE}.bin
33}
34
35addtask deploy before do_build after do_package
36
37FILES_${PN} = "${base_libdir}/firmware/memory_test*"