summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
index 6f0c9b4a..f33b5fd0 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/lwip-tcp-perf-client/lwip-tcp-perf-client_git.bb
@@ -2,17 +2,20 @@ inherit esw deploy python3native
2 2
3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_client/src/" 3ESW_COMPONENT_SRC = "/lib/sw_apps/lwip_tcp_perf_client/src/"
4 4
5DEPENDS += "dtc-native python3-dtc-native libxil lwip xiltimer device-tree python3-pyyaml-native" 5DEPENDS += "libxil lwip xiltimer"
6 6
7do_configure_prepend() { 7do_configure_prepend() {
8 cd ${S} 8 cd ${S}
9 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 9 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
10 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
11 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
10} 12}
11 13
12do_generate_app_data() { 14do_generate_app_data() {
13 # This script should also not rely on relative paths and such 15 # This script should also not rely on relative paths and such
14 cd ${S} 16 cd ${S}
15 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} 17 lopper.py ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S}
18 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 19}
17addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 20addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
18do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 21do_prepare_recipe_sysroot[rdeptask] = "do_unpack"