summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
authorrbramand <rahul.bramandlapalli@xilinx.com>2022-10-17 14:01:21 +0530
committerMark Hatle <mark.hatle@amd.com>2022-11-10 15:04:42 -0800
commitc17957271ce603fe68d228f171a947d268ef617e (patch)
treeacc04a988f019e5f69348d704e706ed4604109f7 /meta-xilinx-core
parentfda9064e99c1e5d367145039974a8b4666c78462 (diff)
downloadmeta-xilinx-c17957271ce603fe68d228f171a947d268ef617e.tar.gz
Add AIE support for 'versal-ai-edge' family of devices
Signed-off-by: rbramand <rbramand@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com> (cherry picked from commit 24761df81446f98e56291c9a3b8ad3b3939d7bb7) Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
index d4157d16..4d268c2e 100644
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
@@ -28,11 +28,21 @@ EXTRA_OECMAKE += " \
28 -DCMAKE_BUILD_TYPE=Release \ 28 -DCMAKE_BUILD_TYPE=Release \
29 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \ 29 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
30 " 30 "
31
32# For vck190 kind of devices
31PACKAGE_ARCH:versal-ai-core = "${SOC_VARIANT_ARCH}" 33PACKAGE_ARCH:versal-ai-core = "${SOC_VARIANT_ARCH}"
32EXTRA_OECMAKE:append:versal-ai-core = " -DXRT_AIE_BUILD=true" 34EXTRA_OECMAKE:append:versal-ai-core = " -DXRT_AIE_BUILD=true"
33TARGET_CXXFLAGS:append:versal-ai-core = " -DXRT_ENABLE_AIE" 35TARGET_CXXFLAGS:append:versal-ai-core = " -DXRT_ENABLE_AIE"
34DEPENDS:append:versal-ai-core = " libmetal-xlnx libxaiengine aiefal" 36DEPENDS:append:versal-ai-core = " libmetal-xlnx libxaiengine aiefal"
35RDEPENDS:${PN}:append:versal-ai-core = " libxaiengine aiefal" 37RDEPENDS:${PN}:append:versal-ai-core = " libxaiengine aiefal"
38
39# For vek280 kind of devices
40PACKAGE_ARCH:versal-ai-edge = "${SOC_VARIANT_ARCH}"
41EXTRA_OECMAKE:append:versal-ai-edge = " -DXRT_AIE_BUILD=true"
42TARGET_CXXFLAGS:append:versal-ai-edge = " -DXRT_ENABLE_AIE"
43DEPENDS:append:versal-ai-edge = " libmetal libxaiengine aiefal"
44RDEPENDS:${PN}:append:versal-ai-edge = " libxaiengine aiefal"
45
36EXTRA_OECMAKE:append:versal = " -DXRT_LIBDFX=true" 46EXTRA_OECMAKE:append:versal = " -DXRT_LIBDFX=true"
37EXTRA_OECMAKE:append:zynqmp = " -DXRT_LIBDFX=true" 47EXTRA_OECMAKE:append:zynqmp = " -DXRT_LIBDFX=true"
38DEPENDS:append:versal = " libdfx" 48DEPENDS:append:versal = " libdfx"