summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/conf
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-09-13 11:29:02 -0700
committerMark Hatle <mark.hatle@amd.com>2022-09-13 11:29:02 -0700
commit454ce5a32cf6052d630b1dc542a5289fcad11500 (patch)
tree9bfeada2851422f2324ed553ed8fbcfefc7ea382 /meta-xilinx-core/conf
parent22bdaf77674cf219e8ce899dac9263b63ea9f432 (diff)
parent93c211cefd1d7bf700d2642a9df53a085c2a9bf1 (diff)
downloadmeta-xilinx-454ce5a32cf6052d630b1dc542a5289fcad11500.tar.gz
Merge branch 'kirkstone-next'
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/conf')
-rw-r--r--meta-xilinx-core/conf/layer.conf15
-rw-r--r--meta-xilinx-core/conf/local.conf.sample4
-rw-r--r--meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc7
-rw-r--r--meta-xilinx-core/conf/machine/include/soc-versal.inc1
-rw-r--r--meta-xilinx-core/conf/machine/microblaze-generic.conf3
-rw-r--r--meta-xilinx-core/conf/machine/versal-generic.conf1
-rw-r--r--meta-xilinx-core/conf/machine/versal-net-generic.conf30
-rw-r--r--meta-xilinx-core/conf/machine/zynq-generic.conf3
-rw-r--r--meta-xilinx-core/conf/machine/zynqmp-generic.conf1
9 files changed, 59 insertions, 6 deletions
diff --git a/meta-xilinx-core/conf/layer.conf b/meta-xilinx-core/conf/layer.conf
index 5c27aa73..33dd732c 100644
--- a/meta-xilinx-core/conf/layer.conf
+++ b/meta-xilinx-core/conf/layer.conf
@@ -18,6 +18,8 @@ meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
18meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bbappend \ 18meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bbappend \
19virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/recipes-*/*/*.bb \ 19virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/recipes-*/*/*.bb \
20virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/recipes-*/*/*.bbappend \ 20virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/recipes-*/*/*.bbappend \
21xilinx-tools:${LAYERDIR}/dynamic-layers/meta-xilinx-tools/recipes-*/*/*.bb \
22xilinx-tools:${LAYERDIR}/dynamic-layers/meta-xilinx-tools/recipes-*/*/*.bbappend \
21" 23"
22 24
23LAYERDEPENDS_xilinx = "core" 25LAYERDEPENDS_xilinx = "core"
@@ -42,4 +44,15 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
42 *->xserver-xorg \ 44 *->xserver-xorg \
43" 45"
44 46
45XILINX_RELEASE_VERSION = "v2022.1" 47XILINX_RELEASE_VERSION ??= "v2022.2"
48
49BUILDCFG_VARS:append = " XILINX_RELEASE_VERSION"
50
51PREFERRED_VERSION_qemu-xilinx ?= "v6.1.0-xilinx-${XILINX_RELEASE_VERSION}%"
52PREFERRED_VERSION_qemu-xilinx-native ?= "v6.1.0-xilinx-${XILINX_RELEASE_VERSION}%"
53PREFERRED_VERSION_qemu-xilinx-system-native ?= "v6.1.0-xilinx-${XILINX_RELEASE_VERSION}%"
54PREFERRED_VERSION_qemu-devicetrees ?= "xilinx-${XILINX_RELEASE_VERSION}%"
55PREFERRED_VERSION_arm-trusted-firmware ?= "2.6-xilinx-${XILINX_RELEASE_VERSION}%"
56PREFERRED_VERSION_u-boot-xlnx ?= "v2021.01-xilinx-${XILINX_RELEASE_VERSION}%"
57PREFERRED_VERSION_pmu-rom-native ?= "${@d.getVar("XILINX_RELEASE_VERSION").replace('v','')}"
58PREFERRED_VERSION_linux-xlnx ?= "${@'5.15.19' if d.getVar("XILINX_RELEASE_VERSION") == 'v2022.1' else '5.15.36'}%"
diff --git a/meta-xilinx-core/conf/local.conf.sample b/meta-xilinx-core/conf/local.conf.sample
index a7173fb8..10134d53 100644
--- a/meta-xilinx-core/conf/local.conf.sample
+++ b/meta-xilinx-core/conf/local.conf.sample
@@ -206,11 +206,11 @@ BB_DISKMON_DIRS ??= "\
206#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \ 206#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
207#file://.* file:///some/local/dir/sstate/PATH" 207#file://.* file:///some/local/dir/sstate/PATH"
208 208
209XILINX_VER_MAIN = "2022.1" 209XILINX_RELEASE_VERSION = "v2022.2"
210 210
211# Uncomment below lines to provide path for custom xsct trim 211# Uncomment below lines to provide path for custom xsct trim
212# 212#
213#EXTERNAL_XSCT_TARBALL = "/proj/yocto/xsct-trim/2022.1_xsct_daily_latest" 213#EXTERNAL_XSCT_TARBALL = "/proj/yocto/xsct-trim/2022.2_xsct_daily_latest"
214#VALIDATE_XSCT_CHECKSUM = '0' 214#VALIDATE_XSCT_CHECKSUM = '0'
215 215
216# 216#
diff --git a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
index a0c5afeb..7d3d45f3 100644
--- a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
+++ b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
@@ -37,6 +37,13 @@ XSERVER ?= " \
37 ${XSERVER_EXT} \ 37 ${XSERVER_EXT} \
38 " 38 "
39 39
40# Automatically add WKS_FILE_DEPENDS based on the configuration
41WKS_FILE_DEPENDS:append = "${@bb.utils.contains('IMAGE_BOOT_FILES', 'boot.bin', ' xilinx-bootbin', '', d)}"
42WKS_FILE_DEPENDS:append = "${@bb.utils.contains('IMAGE_BOOT_FILES', 'system.dtb', ' virtual/dtb', '', d)}"
43WKS_FILE_DEPENDS:append = "${@bb.utils.contains('IMAGE_BOOT_FILES', 'boot.scr', ' u-boot-zynq-scr', '', d)}"
44WKS_FILE_DEPENDS:append = "${@bb.utils.contains('IMAGE_BOOT_FILES', 'uEnv.txt', ' u-boot-zynq-uenv', '', d)}"
45WKS_FILE_DEPENDS:append = "${@bb.utils.contains('IMAGE_BOOT_FILES', 'atf-uboot.ub', ' arm-trusted-firmware', '', d)}"
46
40IMAGE_BOOT_FILES ?= "${@get_default_image_boot_files(d)}" 47IMAGE_BOOT_FILES ?= "${@get_default_image_boot_files(d)}"
41 48
42def get_default_image_boot_files(d): 49def get_default_image_boot_files(d):
diff --git a/meta-xilinx-core/conf/machine/include/soc-versal.inc b/meta-xilinx-core/conf/machine/include/soc-versal.inc
index 40145963..dcf3796e 100644
--- a/meta-xilinx-core/conf/machine/include/soc-versal.inc
+++ b/meta-xilinx-core/conf/machine/include/soc-versal.inc
@@ -7,6 +7,7 @@ SOC_FAMILY ?= "versal"
7# "hbm" - Versal HMB Devices 7# "hbm" - Versal HMB Devices
8# "ai-core" - Versal AI-core Devices 8# "ai-core" - Versal AI-core Devices
9# "ai-edge" - Versal AI-Edge Devices 9# "ai-edge" - Versal AI-Edge Devices
10# "net" - Versal Net Devices
10 11
11SOC_VARIANT ?= "prime" 12SOC_VARIANT ?= "prime"
12 13
diff --git a/meta-xilinx-core/conf/machine/microblaze-generic.conf b/meta-xilinx-core/conf/machine/microblaze-generic.conf
index c0e41948..92412681 100644
--- a/meta-xilinx-core/conf/machine/microblaze-generic.conf
+++ b/meta-xilinx-core/conf/machine/microblaze-generic.conf
@@ -32,7 +32,7 @@ MACHINE_FEATURES = ""
32KERNEL_IMAGETYPE ?= "linux.bin.ub" 32KERNEL_IMAGETYPE ?= "linux.bin.ub"
33KERNEL_IMAGETYPES = "" 33KERNEL_IMAGETYPES = ""
34 34
35SERIAL_CONSOLES ?= "115200;ttyS0" 35SERIAL_CONSOLES ?= "115200;ttyUL0"
36 36
37MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 37MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
38 38
@@ -44,6 +44,7 @@ EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-nativ
44 44
45UBOOT_MACHINE ?= "microblaze-generic_defconfig" 45UBOOT_MACHINE ?= "microblaze-generic_defconfig"
46UBOOT_INITIAL_ENV = "" 46UBOOT_INITIAL_ENV = ""
47BOOTMODE ?= "generic.root"
47 48
48HDF_MACHINE = "kc705-microblazeel" 49HDF_MACHINE = "kc705-microblazeel"
49IMAGE_FSTYPES += "cpio.gz" 50IMAGE_FSTYPES += "cpio.gz"
diff --git a/meta-xilinx-core/conf/machine/versal-generic.conf b/meta-xilinx-core/conf/machine/versal-generic.conf
index b737f1d1..9b9ebf31 100644
--- a/meta-xilinx-core/conf/machine/versal-generic.conf
+++ b/meta-xilinx-core/conf/machine/versal-generic.conf
@@ -20,6 +20,7 @@ MACHINE_FEATURES += "rtc ext2 ext3 vfat usbhost"
20EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-native" 20EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-native"
21 21
22UBOOT_MACHINE ?= "xilinx_versal_virt_defconfig" 22UBOOT_MACHINE ?= "xilinx_versal_virt_defconfig"
23BOOTMODE ?= "generic.root"
23 24
24SERIAL_CONSOLES ?= "115200;ttyAMA0" 25SERIAL_CONSOLES ?= "115200;ttyAMA0"
25 26
diff --git a/meta-xilinx-core/conf/machine/versal-net-generic.conf b/meta-xilinx-core/conf/machine/versal-net-generic.conf
new file mode 100644
index 00000000..1941235a
--- /dev/null
+++ b/meta-xilinx-core/conf/machine/versal-net-generic.conf
@@ -0,0 +1,30 @@
1#@TYPE: Machine
2#@NAME: Versal Net Generic
3##@DESCRIPTION: Versal Net
4
5#### Preamble
6MACHINEOVERRIDES =. "${@['', 'versal-net-generic:']['versal-net-generic' != '${MACHINE}']}"
7#### Regular settings follow
8
9SOC_VARIANT = "net"
10
11# Must be set first, or versal-generic will set it
12UBOOT_MACHINE ?= "xilinx_versal_net_virt_defconfig"
13
14require conf/machine/versal-generic.conf
15
16#### REMOVE THE FOLLOWING WHEN BOOTGEN IS SYNCED
17# required for bootgen native/nativesdk
18MACHINEOVERRIDES:class-native = "versal-net"
19MACHINEOVERRIDES:class-nativesdk = "versal-net"
20#### REMOVE THE ABOVE
21
22HDF_MACHINE = "versal-net-generic"
23
24QEMU_HW_DTB_PS = "${QEMU_HW_DTB_PATH}/board-versal-net-psx-spp-1.4.dtb"
25QEMU_HW_DTB_PMC = "${QEMU_HW_DTB_PATH}/board-versal-pmx-virt.dtb"
26
27#### No additional settings should be after the Postamble
28#### Postamble
29PACKAGE_EXTRA_ARCHS:append = "${@['', ' versal_net_generic']['versal-net-generic' != "${MACHINE}"]}"
30
diff --git a/meta-xilinx-core/conf/machine/zynq-generic.conf b/meta-xilinx-core/conf/machine/zynq-generic.conf
index 3c30c362..e8ecfb34 100644
--- a/meta-xilinx-core/conf/machine/zynq-generic.conf
+++ b/meta-xilinx-core/conf/machine/zynq-generic.conf
@@ -20,6 +20,7 @@ MACHINE_FEATURES += "rtc ext2 ext3 vfat usbhost usbgadget"
20EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-native" 20EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-native"
21 21
22UBOOT_MACHINE ?= "xilinx_zynq_virt_defconfig" 22UBOOT_MACHINE ?= "xilinx_zynq_virt_defconfig"
23BOOTMODE ?= "generic.root"
23 24
24SERIAL_CONSOLES ?= "115200;ttyPS0" 25SERIAL_CONSOLES ?= "115200;ttyPS0"
25 26
@@ -39,8 +40,6 @@ WKS_FILES ?= "sdimage-bootpart.wks"
39QB_MEM = "-m 1024" 40QB_MEM = "-m 1024"
40QB_NETWORK_DEVICE = "-net nic,netdev=net0,macaddr=@MAC@" 41QB_NETWORK_DEVICE = "-net nic,netdev=net0,macaddr=@MAC@"
41 42
42QB_KERNEL_CMDLINE = "none"
43
44QB_KERNEL_ROOT = "/dev/mmcblk0p2" 43QB_KERNEL_ROOT = "/dev/mmcblk0p2"
45 44
46# Replicate BootROM like behaviour, having loaded SPL and PMU(ROM+FW) 45# Replicate BootROM like behaviour, having loaded SPL and PMU(ROM+FW)
diff --git a/meta-xilinx-core/conf/machine/zynqmp-generic.conf b/meta-xilinx-core/conf/machine/zynqmp-generic.conf
index 15fe9d11..32de4d50 100644
--- a/meta-xilinx-core/conf/machine/zynqmp-generic.conf
+++ b/meta-xilinx-core/conf/machine/zynqmp-generic.conf
@@ -31,6 +31,7 @@ EXTRA_IMAGEDEPENDS += "libyaml-native python3-cython-native python3-pyyaml-nativ
31 31
32UBOOT_MACHINE ?= "xilinx_zynqmp_virt_defconfig" 32UBOOT_MACHINE ?= "xilinx_zynqmp_virt_defconfig"
33SPL_BINARY ?= "spl/boot.bin" 33SPL_BINARY ?= "spl/boot.bin"
34BOOTMODE ?= "generic.root"
34 35
35# Default SD image build onfiguration, use qemu-sd to pad 36# Default SD image build onfiguration, use qemu-sd to pad
36IMAGE_CLASSES += "image-types-xilinx-qemu" 37IMAGE_CLASSES += "image-types-xilinx-qemu"