summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-kernel
diff options
context:
space:
mode:
authorJaewon Lee <jaewon.lee@xilinx.com>2021-05-20 15:22:47 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-07-14 15:00:08 -0700
commitccd14f2ae4b9e58e1fafe6be43689a12d1187af5 (patch)
tree33360395aba2479df08efc3636b96ecd7e2cda60 /meta-xilinx-bsp/recipes-kernel
parentb2ff614a75b99fcbd2e12b7c9fb5ac29cfd61f64 (diff)
downloadmeta-xilinx-ccd14f2ae4b9e58e1fafe6be43689a12d1187af5.tar.gz
Revert "linux-xlnx_2021.1.bb: Add flag to parametrize dt file extensions"
This reverts commit d4eeda3a87815747fc3c53ce6117dd4b0d8cacd1. Signed-off-by: Jaewon Lee <jaewon.lee@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-kernel')
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
index 4645bae5..0e83bc2d 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
+++ b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
@@ -12,7 +12,6 @@ fitimage_assemble() {
12 kernelcount=1 12 kernelcount=1
13 dtbcount="" 13 dtbcount=""
14 DTBS="" 14 DTBS=""
15 DT_SEARCH_ARG=""
16 ramdiskcount=${3} 15 ramdiskcount=${3}
17 setupcount="" 16 setupcount=""
18 rm -f ${1} arch/${ARCH}/boot/${2} 17 rm -f ${1} arch/${ARCH}/boot/${2}
@@ -50,11 +49,8 @@ fitimage_assemble() {
50 fi 49 fi
51 50
52 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then 51 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then
53 if [ -z "${DT_SEARCH_ARG}" ]; then
54 DT_SEARCH_ARG="-name *.dtb -o -name *.dtbo"
55 fi
56 dtbcount=1 52 dtbcount=1
57 for DTB in $(find "${EXTERNAL_KERNEL_DEVICETREE}" \( ${DT_SEARCH_ARG} \) -printf '%P\n' | sort); do 53 for DTB in $(find "${EXTERNAL_KERNEL_DEVICETREE}" \( -name '*.dtb' -o -name '*.dtbo' \) -printf '%P\n' | sort); do
58 DTB=$(echo "${DTB}" | tr '/' '_') 54 DTB=$(echo "${DTB}" | tr '/' '_')
59 DTBS="${DTBS} ${DTB}" 55 DTBS="${DTBS} ${DTB}"
60 fitimage_emit_section_dtb ${1} ${DTB} "${EXTERNAL_KERNEL_DEVICETREE}/${DTB}" 56 fitimage_emit_section_dtb ${1} ${DTB} "${EXTERNAL_KERNEL_DEVICETREE}/${DTB}"