summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
index 4645bae5..0e83bc2d 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
+++ b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.1.bb
@@ -12,7 +12,6 @@ fitimage_assemble() {
12 kernelcount=1 12 kernelcount=1
13 dtbcount="" 13 dtbcount=""
14 DTBS="" 14 DTBS=""
15 DT_SEARCH_ARG=""
16 ramdiskcount=${3} 15 ramdiskcount=${3}
17 setupcount="" 16 setupcount=""
18 rm -f ${1} arch/${ARCH}/boot/${2} 17 rm -f ${1} arch/${ARCH}/boot/${2}
@@ -50,11 +49,8 @@ fitimage_assemble() {
50 fi 49 fi
51 50
52 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then 51 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then
53 if [ -z "${DT_SEARCH_ARG}" ]; then
54 DT_SEARCH_ARG="-name *.dtb -o -name *.dtbo"
55 fi
56 dtbcount=1 52 dtbcount=1
57 for DTB in $(find "${EXTERNAL_KERNEL_DEVICETREE}" \( ${DT_SEARCH_ARG} \) -printf '%P\n' | sort); do 53 for DTB in $(find "${EXTERNAL_KERNEL_DEVICETREE}" \( -name '*.dtb' -o -name '*.dtbo' \) -printf '%P\n' | sort); do
58 DTB=$(echo "${DTB}" | tr '/' '_') 54 DTB=$(echo "${DTB}" | tr '/' '_')
59 DTBS="${DTBS} ${DTB}" 55 DTBS="${DTBS} ${DTB}"
60 fitimage_emit_section_dtb ${1} ${DTB} "${EXTERNAL_KERNEL_DEVICETREE}/${DTB}" 56 fitimage_emit_section_dtb ${1} ${DTB} "${EXTERNAL_KERNEL_DEVICETREE}/${DTB}"