summaryrefslogtreecommitdiffstats
path: root/conf/machine/include/zynqmp-pmu-config.inc
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-06 16:06:35 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-13 16:11:14 -0800
commita18947c20dba2c0c38db8bde1ad4684995df4bbd (patch)
tree917bf2abbe439a6f99ede8cfafb25812dca54a9a /conf/machine/include/zynqmp-pmu-config.inc
parent6ddc5873b0ede30e6542f0ab151a6236acc37944 (diff)
downloadmeta-xilinx-a18947c20dba2c0c38db8bde1ad4684995df4bbd.tar.gz
meta-xilinx: Restructuring meta-xilinx to support multiple layers
As discussed previously on mailing list, we are proceeding with layer restructuring. For rocko release we will have the following layers meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-xilinx-contrib In the subsequent releases we will add other layers from Xilinx meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-petalinux ->meta-xilinx-tools ->meta-xilinx-contrib This will provide one clone to get all the required meta layers from Xilinx for a complete solution, and the users can blacklist any layer which they don't want to use using bblayer.conf. This will enables us to help our vendors/partners to add their reference designs, board definitions etc. Recipe changes : * Move reference design zybo-linux-bd.bb to meta-xilinx-contrib * Move kernel patches realted to zybo-linux-bd-zynq7 board to meta-xilinx-contrib * Update README Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'conf/machine/include/zynqmp-pmu-config.inc')
-rw-r--r--conf/machine/include/zynqmp-pmu-config.inc20
1 files changed, 0 insertions, 20 deletions
diff --git a/conf/machine/include/zynqmp-pmu-config.inc b/conf/machine/include/zynqmp-pmu-config.inc
deleted file mode 100644
index fd9e9809..00000000
--- a/conf/machine/include/zynqmp-pmu-config.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1
2# Enable the use of zynqmp-pmu for specific recipes only
3def zynqmp_pmu_enable_for_bpns(d):
4 bpn = d.getVar("BPN")
5 crossbpns = ["binutils", "gcc"]
6 targetbpns = ["libgcc", "newlib", "libgloss"]
7 if bpn in targetbpns:
8 return True
9 if bpn in crossbpns and bb.data.inherits_class('cross', d):
10 return True
11 return False
12
13BBCLASSEXTEND_append = "${@' zynqmp-pmu' if zynqmp_pmu_enable_for_bpns(d) else ''}"
14
15# Add the pkgarch to the extra list, this is done to avoid warnings about
16# missing manifests due to implicit dependency chains on populate_sysroot when
17# a recipe/task depends on a IMAGE_EXTRADEPENDS/do_deploy task which is
18# provided by a zynqmp-pmu-* target.
19PACKAGE_EXTRA_ARCHS_append = " microblazeel-v9.2-bs-cmp"
20