summaryrefslogtreecommitdiffstats
path: root/recipes-core/busybox/busybox-initrd_1.36.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/busybox/busybox-initrd_1.36.0.bb')
-rw-r--r--recipes-core/busybox/busybox-initrd_1.36.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd_1.36.0.bb b/recipes-core/busybox/busybox-initrd_1.36.0.bb
new file mode 100644
index 00000000..6108e9af
--- /dev/null
+++ b/recipes-core/busybox/busybox-initrd_1.36.0.bb
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
2
3require recipes-core/busybox/busybox_${PV}.bb
4
5SRC_URI += "file://init.cfg \
6 file://mdev.cfg \
7 file://runx.cfg \
8 ${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', 'file://static.cfg', '', d)} \
9 file://initrd.cfg"
10
11S = "${WORKDIR}/busybox-${PV}"
12
13# override security-flags settings, we have some warnings to ignore
14SECURITY_STRINGFORMAT = ""
15
16# we do this to get the target binary available to recipes that
17# depend on busybox
18SYSROOT_DIRS += "/bin"
19BUSYBOX_SPLIT_SUID = "0"
20
21FILES:${PN} += "${sysconfdir}/init.d/*"