summaryrefslogtreecommitdiffstats
path: root/recipes-core/busybox/busybox-initrd_1.36.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-01-28 21:03:49 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-01-31 22:50:41 -0500
commite6a578bbb8f397fb577643016aaa2adbb9626e7b (patch)
treef778c7607758da53810190f0f7578bd305cade37 /recipes-core/busybox/busybox-initrd_1.36.0.bb
parent51bb65bece6acbf5ede9c5988e70e15adf95ca45 (diff)
downloadmeta-virtualization-e6a578bbb8f397fb577643016aaa2adbb9626e7b.tar.gz
busybox-initrd: update include
OEcore has an update to busybox, and since we include the core recipe directly, we have to update our PV to match. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core/busybox/busybox-initrd_1.36.0.bb')
-rw-r--r--recipes-core/busybox/busybox-initrd_1.36.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd_1.36.0.bb b/recipes-core/busybox/busybox-initrd_1.36.0.bb
new file mode 100644
index 00000000..6108e9af
--- /dev/null
+++ b/recipes-core/busybox/busybox-initrd_1.36.0.bb
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
2
3require recipes-core/busybox/busybox_${PV}.bb
4
5SRC_URI += "file://init.cfg \
6 file://mdev.cfg \
7 file://runx.cfg \
8 ${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', 'file://static.cfg', '', d)} \
9 file://initrd.cfg"
10
11S = "${WORKDIR}/busybox-${PV}"
12
13# override security-flags settings, we have some warnings to ignore
14SECURITY_STRINGFORMAT = ""
15
16# we do this to get the target binary available to recipes that
17# depend on busybox
18SYSROOT_DIRS += "/bin"
19BUSYBOX_SPLIT_SUID = "0"
20
21FILES:${PN} += "${sysconfdir}/init.d/*"