summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxcfs/lxcfs_3.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxcfs/lxcfs_3.0.3.bb')
-rw-r--r--recipes-containers/lxcfs/lxcfs_3.0.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-containers/lxcfs/lxcfs_3.0.3.bb b/recipes-containers/lxcfs/lxcfs_3.0.3.bb
new file mode 100644
index 00000000..b6b6ac6b
--- /dev/null
+++ b/recipes-containers/lxcfs/lxcfs_3.0.3.bb
@@ -0,0 +1,25 @@
1SUMMARY = "LXCFS is a userspace filesystem created to avoid kernel limitations"
2LICENSE = "Apache-2.0"
3
4inherit autotools pkgconfig systemd
5
6SRC_URI = " \
7 https://linuxcontainers.org/downloads/lxcfs/lxcfs-${PV}.tar.gz \
8 file://systemd-allow-for-distinct-build-directory.patch \
9 file://systemd-ensure-var-lib-lxcfs-exists.patch \
10"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
13SRC_URI[md5sum] = "bfc41f949caeabd0468189480222f25e"
14SRC_URI[sha256sum] = "890aa30d960d9b1e53b0c0712bf645c1f1924f750e32cd090f368c1338bd462f"
15
16DEPENDS += "fuse"
17RDEPENDS_${PN} += "fuse"
18
19FILES_${PN} += "${datadir}/lxc/config/common.conf.d/*"
20
21CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN='false // No help2man //'"
22EXTRA_OECONF += "--with-distro=unknown --with-init-script=${VIRTUAL-RUNTIME_init_manager}"
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "lxcfs.service"