summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxcfs/lxcfs_3.0.3.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-11-30 16:46:53 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-12-04 18:15:14 -0500
commit8e2ef132c1b1416808c403851206740dcec284db (patch)
treea9d756205a2b6ecb51a9ca4b0ca409a14ef4ba3c /recipes-containers/lxcfs/lxcfs_3.0.3.bb
parent5043d6263af3daa965e27bb027cdb5db00d0611b (diff)
downloadmeta-virtualization-8e2ef132c1b1416808c403851206740dcec284db.tar.gz
lxcfs: uprev from v3.0.1 to v3.0.3
A very small # of new commits. Most are minor bug fixes, no feature work. I looked at adding ptests but the tests are mostly in an unusable state at the moment, for example several require cgm despite cgmanager being deprecated. So I have opted to continue without them and only when we can work with upstream to improve their testing can we seriously consider adding them. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxcfs/lxcfs_3.0.3.bb')
-rw-r--r--recipes-containers/lxcfs/lxcfs_3.0.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-containers/lxcfs/lxcfs_3.0.3.bb b/recipes-containers/lxcfs/lxcfs_3.0.3.bb
new file mode 100644
index 00000000..b6b6ac6b
--- /dev/null
+++ b/recipes-containers/lxcfs/lxcfs_3.0.3.bb
@@ -0,0 +1,25 @@
1SUMMARY = "LXCFS is a userspace filesystem created to avoid kernel limitations"
2LICENSE = "Apache-2.0"
3
4inherit autotools pkgconfig systemd
5
6SRC_URI = " \
7 https://linuxcontainers.org/downloads/lxcfs/lxcfs-${PV}.tar.gz \
8 file://systemd-allow-for-distinct-build-directory.patch \
9 file://systemd-ensure-var-lib-lxcfs-exists.patch \
10"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
13SRC_URI[md5sum] = "bfc41f949caeabd0468189480222f25e"
14SRC_URI[sha256sum] = "890aa30d960d9b1e53b0c0712bf645c1f1924f750e32cd090f368c1338bd462f"
15
16DEPENDS += "fuse"
17RDEPENDS_${PN} += "fuse"
18
19FILES_${PN} += "${datadir}/lxc/config/common.conf.d/*"
20
21CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN='false // No help2man //'"
22EXTRA_OECONF += "--with-distro=unknown --with-init-script=${VIRTUAL-RUNTIME_init_manager}"
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "lxcfs.service"