summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker-compose')
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch33
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb31
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb34
3 files changed, 51 insertions, 47 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index 54835ff1..8d204a77 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -9,12 +9,13 @@ require old version recipes.
9Upstream-Status: Inappropriate [OE Specific] 9Upstream-Status: Inappropriate [OE Specific]
10 10
11Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 11Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
12Signed-off-by: Ming Liu <liu.ming50@gmail.com>
12--- 13---
13 setup.py | 22 +++++++++++----------- 14 setup.py | 22 +++++++++++-----------
14 1 file changed, 11 insertions(+), 11 deletions(-) 15 1 file changed, 11 insertions(+), 11 deletions(-)
15 16
16diff --git a/setup.py b/setup.py 17diff --git a/setup.py b/setup.py
17index 422ba54..c2b4556 100644 18index 23ae08a..eef2825 100644
18--- a/setup.py 19--- a/setup.py
19+++ b/setup.py 20+++ b/setup.py
20@@ -30,16 +30,16 @@ def find_version(*file_paths): 21@@ -30,16 +30,16 @@ def find_version(*file_paths):
@@ -22,37 +23,37 @@ index 422ba54..c2b4556 100644
22 23
23 install_requires = [ 24 install_requires = [
24- 'cached-property >= 1.2.0, < 2', 25- 'cached-property >= 1.2.0, < 2',
25- 'docopt >= 0.6.1, < 0.7', 26- 'docopt >= 0.6.1, < 1',
26- 'PyYAML >= 3.10, < 4', 27- 'PyYAML >= 3.10, < 5',
27- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19', 28- 'requests >= 2.20.0, < 3',
28- 'texttable >= 0.9.0, < 0.10', 29- 'texttable >= 0.9.0, < 2',
29- 'websocket-client >= 0.32.0, < 1.0', 30- 'websocket-client >= 0.32.0, < 1',
30- 'docker >= 3.3.0, < 4.0', 31- 'docker[ssh] >= 3.7.0, < 5',
31- 'dockerpty >= 0.4.1, < 0.5', 32- 'dockerpty >= 0.4.1, < 1',
32- 'six >= 1.3.0, < 2', 33- 'six >= 1.3.0, < 2',
33- 'jsonschema >= 2.5.1, < 3', 34- 'jsonschema >= 2.5.1, < 4',
34+ 'cached-property >= 1.2.0', 35+ 'cached-property >= 1.2.0',
35+ 'docopt >= 0.6.1', 36+ 'docopt >= 0.6.1',
36+ 'PyYAML >= 3.10', 37+ 'PyYAML >= 3.10',
37+ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0', 38+ 'requests >= 2.20.0',
38+ 'texttable >= 0.9.0', 39+ 'texttable >= 0.9.0',
39+ 'websocket-client >= 0.32.0', 40+ 'websocket-client >= 0.32.0',
40+ 'docker >= 3.3.0', 41+ 'docker[ssh] >= 3.7.0',
41+ 'dockerpty >= 0.4.1', 42+ 'dockerpty >= 0.4.1',
42+ 'six >= 1.3.0', 43+ 'six >= 1.3.0',
43+ 'jsonschema >= 2.5.1', 44+ 'jsonschema >= 2.5.1',
44 ] 45 ]
45 46
46 47
47@@ -56,7 +56,7 @@ extras_require = { 48@@ -58,7 +58,7 @@ extras_require = {
48 ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'], 49 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
49 ':python_version < "3.3"': ['ipaddress >= 1.0.16'], 50 'ipaddress >= 1.0.16, < 2'],
50 ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'], 51 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
51- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], 52- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
52+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'], 53+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
53 } 54 }
54 55
55 56
56-- 57--
572.17.1 582.7.4
58 59
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb b/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb
deleted file mode 100644
index a8950059..00000000
--- a/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch"
7
8inherit pypi setuptools3
9
10SRC_URI[md5sum] = "a243f59b2d286c41ff6ed1c4d4b50996"
11SRC_URI[sha256sum] = "68b07193755440d5f8d4f47e6f3484212afc255d5b785a81353ea1e9298c1c2c"
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-cached-property \
15 ${PYTHON_PN}-certifi \
16 ${PYTHON_PN}-chardet \
17 ${PYTHON_PN}-colorama \
18 ${PYTHON_PN}-docker \
19 ${PYTHON_PN}-docker-pycreds \
20 ${PYTHON_PN}-dockerpty \
21 ${PYTHON_PN}-docopt \
22 ${PYTHON_PN}-idna \
23 ${PYTHON_PN}-jsonschema \
24 ${PYTHON_PN}-pyyaml \
25 ${PYTHON_PN}-requests \
26 ${PYTHON_PN}-six \
27 ${PYTHON_PN}-terminal \
28 ${PYTHON_PN}-texttable \
29 ${PYTHON_PN}-urllib3 \
30 ${PYTHON_PN}-websocket-client \
31 "
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
new file mode 100644
index 00000000..36e24171
--- /dev/null
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "275b32cffdad6b9816dc8b4c7e55600a"
9SRC_URI[sha256sum] = "2c5fcbfd3ff445b6f3eebb549cb167ef1d8f70c5806aab8f309fc8fa74cd977e"
10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch"
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-cached-property \
15 ${PYTHON_PN}-certifi \
16 ${PYTHON_PN}-chardet \
17 ${PYTHON_PN}-colorama \
18 ${PYTHON_PN}-docker \
19 ${PYTHON_PN}-docker-pycreds \
20 ${PYTHON_PN}-dockerpty \
21 ${PYTHON_PN}-docopt \
22 ${PYTHON_PN}-fcntl \
23 ${PYTHON_PN}-idna \
24 ${PYTHON_PN}-jsonschema \
25 ${PYTHON_PN}-misc \
26 ${PYTHON_PN}-paramiko \
27 ${PYTHON_PN}-pyyaml \
28 ${PYTHON_PN}-requests \
29 ${PYTHON_PN}-six \
30 ${PYTHON_PN}-terminal \
31 ${PYTHON_PN}-texttable \
32 ${PYTHON_PN}-urllib3 \
33 ${PYTHON_PN}-websocket-client \
34"