diff options
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r-- | recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | 33 |
1 files changed, 17 insertions, 16 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch index 54835ff1..8d204a77 100644 --- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -9,12 +9,13 @@ require old version recipes. | |||
9 | Upstream-Status: Inappropriate [OE Specific] | 9 | Upstream-Status: Inappropriate [OE Specific] |
10 | 10 | ||
11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | 11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> |
12 | Signed-off-by: Ming Liu <liu.ming50@gmail.com> | ||
12 | --- | 13 | --- |
13 | setup.py | 22 +++++++++++----------- | 14 | setup.py | 22 +++++++++++----------- |
14 | 1 file changed, 11 insertions(+), 11 deletions(-) | 15 | 1 file changed, 11 insertions(+), 11 deletions(-) |
15 | 16 | ||
16 | diff --git a/setup.py b/setup.py | 17 | diff --git a/setup.py b/setup.py |
17 | index 422ba54..c2b4556 100644 | 18 | index 23ae08a..eef2825 100644 |
18 | --- a/setup.py | 19 | --- a/setup.py |
19 | +++ b/setup.py | 20 | +++ b/setup.py |
20 | @@ -30,16 +30,16 @@ def find_version(*file_paths): | 21 | @@ -30,16 +30,16 @@ def find_version(*file_paths): |
@@ -22,37 +23,37 @@ index 422ba54..c2b4556 100644 | |||
22 | 23 | ||
23 | install_requires = [ | 24 | install_requires = [ |
24 | - 'cached-property >= 1.2.0, < 2', | 25 | - 'cached-property >= 1.2.0, < 2', |
25 | - 'docopt >= 0.6.1, < 0.7', | 26 | - 'docopt >= 0.6.1, < 1', |
26 | - 'PyYAML >= 3.10, < 4', | 27 | - 'PyYAML >= 3.10, < 5', |
27 | - 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19', | 28 | - 'requests >= 2.20.0, < 3', |
28 | - 'texttable >= 0.9.0, < 0.10', | 29 | - 'texttable >= 0.9.0, < 2', |
29 | - 'websocket-client >= 0.32.0, < 1.0', | 30 | - 'websocket-client >= 0.32.0, < 1', |
30 | - 'docker >= 3.3.0, < 4.0', | 31 | - 'docker[ssh] >= 3.7.0, < 5', |
31 | - 'dockerpty >= 0.4.1, < 0.5', | 32 | - 'dockerpty >= 0.4.1, < 1', |
32 | - 'six >= 1.3.0, < 2', | 33 | - 'six >= 1.3.0, < 2', |
33 | - 'jsonschema >= 2.5.1, < 3', | 34 | - 'jsonschema >= 2.5.1, < 4', |
34 | + 'cached-property >= 1.2.0', | 35 | + 'cached-property >= 1.2.0', |
35 | + 'docopt >= 0.6.1', | 36 | + 'docopt >= 0.6.1', |
36 | + 'PyYAML >= 3.10', | 37 | + 'PyYAML >= 3.10', |
37 | + 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0', | 38 | + 'requests >= 2.20.0', |
38 | + 'texttable >= 0.9.0', | 39 | + 'texttable >= 0.9.0', |
39 | + 'websocket-client >= 0.32.0', | 40 | + 'websocket-client >= 0.32.0', |
40 | + 'docker >= 3.3.0', | 41 | + 'docker[ssh] >= 3.7.0', |
41 | + 'dockerpty >= 0.4.1', | 42 | + 'dockerpty >= 0.4.1', |
42 | + 'six >= 1.3.0', | 43 | + 'six >= 1.3.0', |
43 | + 'jsonschema >= 2.5.1', | 44 | + 'jsonschema >= 2.5.1', |
44 | ] | 45 | ] |
45 | 46 | ||
46 | 47 | ||
47 | @@ -56,7 +56,7 @@ extras_require = { | 48 | @@ -58,7 +58,7 @@ extras_require = { |
48 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'], | 49 | ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', |
49 | ':python_version < "3.3"': ['ipaddress >= 1.0.16'], | 50 | 'ipaddress >= 1.0.16, < 2'], |
50 | ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'], | 51 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], |
51 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | 52 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], |
52 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | 53 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], |
53 | } | 54 | } |
54 | 55 | ||
55 | 56 | ||
56 | -- | 57 | -- |
57 | 2.17.1 | 58 | 2.7.4 |
58 | 59 | ||