diff options
Diffstat (limited to 'recipes-containers/cri-o/files')
-rw-r--r-- | recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch | 16 | ||||
-rw-r--r-- | recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch | 43 |
2 files changed, 8 insertions, 51 deletions
diff --git a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch index 0b106e41..4328647d 100644 --- a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch +++ b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch | |||
@@ -1,26 +1,26 @@ | |||
1 | From 53371afbf0f20a1651ee6f2406cd2be056a31066 Mon Sep 17 00:00:00 2001 | 1 | From 52fd70ae7d82dfa0db46ff7ba67cfb4868074368 Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> | 2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> |
3 | Date: Thu, 1 Nov 2018 11:17:05 -0400 | 3 | Date: Tue, 7 Jun 2022 15:42:22 -0400 |
4 | Subject: [PATCH] Makefile: force symlinks | 4 | Subject: [PATCH] Makefile: force symlinks |
5 | 5 | ||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | 6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> |
7 | --- | 7 | --- |
8 | Makefile | 2 +- | 8 | Makefile | 2 +- |
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | 9 | 1 file changed, 1 insertion(+), 1 deletion(-) |
10 | 10 | ||
11 | diff --git a/src/import/Makefile b/src/import/Makefile | 11 | diff --git a/src/import/Makefile b/src/import/Makefile |
12 | index cf37bec..68c8eeb 100644 | 12 | index 8abc8619d..d1a98f3d3 100644 |
13 | --- a/src/import/Makefile | 13 | --- a/src/import/Makefile |
14 | +++ b/src/import/Makefile | 14 | +++ b/src/import/Makefile |
15 | @@ -66,7 +66,7 @@ help: | 15 | @@ -141,7 +141,7 @@ help: |
16 | .gopathok: | 16 | .gopathok: |
17 | ifeq ("$(wildcard $(GOPKGDIR))","") | 17 | ifeq ("$(wildcard $(GOPKGDIR))","") |
18 | mkdir -p "$(GOPKGBASEDIR)" | 18 | mkdir -p "$(GOPKGBASEDIR)" |
19 | - ln -s "$(CURDIR)" "$(GOPKGDIR)" | 19 | - ln -s "$(CURDIR)" "$(GOPKGDIR)" |
20 | + ln -sf "$(CURDIR)" "$(GOPKGDIR)" | 20 | + ln -sf "$(CURDIR)" "$(GOPKGDIR)" |
21 | endif | 21 | endif |
22 | if [ ! -d "$(GOPATH)" ]; then mkdir -p $(GOPATH); fi | ||
22 | touch "$(GOPATH)/.gopathok" | 23 | touch "$(GOPATH)/.gopathok" |
23 | |||
24 | -- | 24 | -- |
25 | 2.7.4 | 25 | 2.19.1 |
26 | 26 | ||
diff --git a/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch b/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch deleted file mode 100644 index 24c7e9d7..00000000 --- a/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 3822e834d2dbd87a4dc8cdd36e7fe3b0e9020c4f Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Tue, 9 Apr 2019 13:52:59 -0400 | ||
4 | Subject: [PATCH] Makefile: skip install when generating the config.h | ||
5 | |||
6 | When running 'go build' "The -i flag installs the packages that are | ||
7 | dependencies of the target." The Makefile makes use of this since many | ||
8 | of the dependencies needed to complete this rule will be used to by | ||
9 | other rules in the Makefile, thus speeding the overall build time | ||
10 | (avoiding redoing work). | ||
11 | |||
12 | In our case the crio-config tool and its dependencies are not being | ||
13 | cross-compiled as they have to run locally to produce the | ||
14 | conmon/config.h file and thus installing them is not useful. In this | ||
15 | case there are no savings and can actually result in errors during the | ||
16 | build or if the build ARCH and target ARCH are the same, a potential | ||
17 | for host contamination. | ||
18 | |||
19 | So we drop the use of '-i'. | ||
20 | |||
21 | Upstream-Status: Inappropriate [cross compile issue] | ||
22 | |||
23 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
24 | --- | ||
25 | Makefile | 2 +- | ||
26 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
27 | |||
28 | diff --git a/src/import/Makefile b/src/import/Makefile | ||
29 | index b9fa97f..8336a5b 100644 | ||
30 | --- a/src/import/Makefile | ||
31 | +++ b/src/import/Makefile | ||
32 | @@ -109,7 +109,7 @@ release-note: | ||
33 | @$(GOPATH)/bin/release-tool -n $(release) | ||
34 | |||
35 | conmon/config.h: cmd/crio-config/config.go oci/oci.go | ||
36 | - $(GO) build -i $(LDFLAGS) -o bin/crio-config $(PROJECT)/cmd/crio-config | ||
37 | + $(GO) build $(LDFLAGS) -o bin/crio-config $(PROJECT)/cmd/crio-config | ||
38 | ( cd conmon && $(CURDIR)/bin/crio-config ) | ||
39 | |||
40 | clean: | ||
41 | -- | ||
42 | 2.7.4 | ||
43 | |||