summaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-o
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/cri-o')
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb8
-rw-r--r--recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch16
-rw-r--r--recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch43
3 files changed, 12 insertions, 55 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 7940bbd2..175b6b3e 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -14,9 +14,9 @@ At a high level, we expect the scope of cri-o to be restricted to the following
14 - Resource isolation as required by the CRI \ 14 - Resource isolation as required by the CRI \
15 " 15 "
16 16
17SRCREV_cri-o = "1607c6ec2eddc927ef736db5525761e49df13e24" 17SRCREV_cri-o = "a3bbde8a77c323aa6a485da9a9046299155c6016"
18SRC_URI = "\ 18SRC_URI = "\
19 git://github.com/kubernetes-sigs/cri-o.git;branch=release-1.23;name=cri-o;protocol=https \ 19 git://github.com/kubernetes-sigs/cri-o.git;branch=release-1.24;name=cri-o;protocol=https \
20 file://0001-Makefile-force-symlinks.patch \ 20 file://0001-Makefile-force-symlinks.patch \
21 file://crio.conf \ 21 file://crio.conf \
22 " 22 "
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2
27 27
28GO_IMPORT = "import" 28GO_IMPORT = "import"
29 29
30PV = "1.23.1+git${SRCREV_cri-o}" 30PV = "1.24.1+git${SRCREV_cri-o}"
31 31
32inherit features_check 32inherit features_check
33REQUIRED_DISTRO_FEATURES ?= "seccomp" 33REQUIRED_DISTRO_FEATURES ?= "seccomp"
@@ -106,7 +106,7 @@ FILES:${PN} += "/usr/share/containers/oci/hooks.d"
106# don't clobber hooks.d 106# don't clobber hooks.d
107ALLOW_EMPTY:${PN} = "1" 107ALLOW_EMPTY:${PN} = "1"
108 108
109INSANE_SKIP:${PN} += "ldflags already-stripped" 109INSANE_SKIP:${PN} += "ldflags already-stripped textrel"
110 110
111deltask compile_ptest_base 111deltask compile_ptest_base
112 112
diff --git a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
index 0b106e41..4328647d 100644
--- a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
+++ b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
@@ -1,26 +1,26 @@
1From 53371afbf0f20a1651ee6f2406cd2be056a31066 Mon Sep 17 00:00:00 2001 1From 52fd70ae7d82dfa0db46ff7ba67cfb4868074368 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com> 2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Thu, 1 Nov 2018 11:17:05 -0400 3Date: Tue, 7 Jun 2022 15:42:22 -0400
4Subject: [PATCH] Makefile: force symlinks 4Subject: [PATCH] Makefile: force symlinks
5 5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> 6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7--- 7---
8 Makefile | 2 +- 8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git a/src/import/Makefile b/src/import/Makefile 11diff --git a/src/import/Makefile b/src/import/Makefile
12index cf37bec..68c8eeb 100644 12index 8abc8619d..d1a98f3d3 100644
13--- a/src/import/Makefile 13--- a/src/import/Makefile
14+++ b/src/import/Makefile 14+++ b/src/import/Makefile
15@@ -66,7 +66,7 @@ help: 15@@ -141,7 +141,7 @@ help:
16 .gopathok: 16 .gopathok:
17 ifeq ("$(wildcard $(GOPKGDIR))","") 17 ifeq ("$(wildcard $(GOPKGDIR))","")
18 mkdir -p "$(GOPKGBASEDIR)" 18 mkdir -p "$(GOPKGBASEDIR)"
19- ln -s "$(CURDIR)" "$(GOPKGDIR)" 19- ln -s "$(CURDIR)" "$(GOPKGDIR)"
20+ ln -sf "$(CURDIR)" "$(GOPKGDIR)" 20+ ln -sf "$(CURDIR)" "$(GOPKGDIR)"
21 endif 21 endif
22 if [ ! -d "$(GOPATH)" ]; then mkdir -p $(GOPATH); fi
22 touch "$(GOPATH)/.gopathok" 23 touch "$(GOPATH)/.gopathok"
23
24-- 24--
252.7.4 252.19.1
26 26
diff --git a/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch b/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch
deleted file mode 100644
index 24c7e9d7..00000000
--- a/recipes-containers/cri-o/files/Makefile-skip-install-when-generating-the-config.h.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 3822e834d2dbd87a4dc8cdd36e7fe3b0e9020c4f Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 9 Apr 2019 13:52:59 -0400
4Subject: [PATCH] Makefile: skip install when generating the config.h
5
6When running 'go build' "The -i flag installs the packages that are
7dependencies of the target." The Makefile makes use of this since many
8of the dependencies needed to complete this rule will be used to by
9other rules in the Makefile, thus speeding the overall build time
10(avoiding redoing work).
11
12In our case the crio-config tool and its dependencies are not being
13cross-compiled as they have to run locally to produce the
14conmon/config.h file and thus installing them is not useful. In this
15case there are no savings and can actually result in errors during the
16build or if the build ARCH and target ARCH are the same, a potential
17for host contamination.
18
19So we drop the use of '-i'.
20
21Upstream-Status: Inappropriate [cross compile issue]
22
23Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
24---
25 Makefile | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/src/import/Makefile b/src/import/Makefile
29index b9fa97f..8336a5b 100644
30--- a/src/import/Makefile
31+++ b/src/import/Makefile
32@@ -109,7 +109,7 @@ release-note:
33 @$(GOPATH)/bin/release-tool -n $(release)
34
35 conmon/config.h: cmd/crio-config/config.go oci/oci.go
36- $(GO) build -i $(LDFLAGS) -o bin/crio-config $(PROJECT)/cmd/crio-config
37+ $(GO) build $(LDFLAGS) -o bin/crio-config $(PROJECT)/cmd/crio-config
38 ( cd conmon && $(CURDIR)/bin/crio-config )
39
40 clean:
41--
422.7.4
43