summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2021-04-19 16:08:54 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-20 17:00:12 -0400
commitd5aa7e668db030f45d9e23b4cae0ddf2088d12d8 (patch)
treee04aacce9ef30eef54edd26b20e3f8c0d612e405 /recipes-extended
parent2406c1785dbfae5a7e2aa0c6e7a284ae3070f737 (diff)
downloadmeta-virtualization-d5aa7e668db030f45d9e23b4cae0ddf2088d12d8.tar.gz
xtf: update SRCREV and remove multilib dependency
The latest Xen Test Framework has removed the gcc-multilib dependency. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xtf_git.bb21
1 files changed, 2 insertions, 19 deletions
diff --git a/recipes-extended/xen/xtf_git.bb b/recipes-extended/xen/xtf_git.bb
index db086435..35803241 100644
--- a/recipes-extended/xen/xtf_git.bb
+++ b/recipes-extended/xen/xtf_git.bb
@@ -6,7 +6,7 @@ LICENSE = "BSD-2-Clause"
6# https://static.sched.com/hosted_files/xendeveloperanddesignsummit2017/79/xtf.pdf 6# https://static.sched.com/hosted_files/xendeveloperanddesignsummit2017/79/xtf.pdf
7 7
8SRC_URI = "git://xenbits.xen.org/xtf" 8SRC_URI = "git://xenbits.xen.org/xtf"
9SRCREV = "8ab15139728a8efd3ebbb60beb16a958a6a93fa1" 9SRCREV = "b0bc49846c154b79243f39d461a4515804bcaf53"
10 10
11COMPATIBLE_HOST = '(x86_64.*).*-linux' 11COMPATIBLE_HOST = '(x86_64.*).*-linux'
12 12
@@ -18,23 +18,6 @@ S = "${WORKDIR}/git"
18 18
19inherit python3native 19inherit python3native
20 20
21# To build 32-bit binaries some files from 32-bit glibc are needed.
22# To enable multilib, please add the following to your local.conf -:
23#
24# require conf/multilib.conf
25# MULTILIBS = "multilib:lib32"
26# DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
27
28# Use this multilib prefix for x86 32-bit to match local.conf:
29MLPREFIX32 = "lib32-"
30# Add the multilib 32-bit glibc to DEPENDS only when necessary:
31# The DEPENDS on a multilib 32-bit glibc is only added when target is x86-64
32# This x86-64 override is never intended for native use, so clear that.
33GLIBC32 = ""
34GLIBC32_x86-64 = "${MLPREFIX32}glibc"
35GLIBC32_class-native = ""
36DEPENDS += "${GLIBC32}"
37
38PACKAGES = "${PN}" 21PACKAGES = "${PN}"
39 22
40FILES_${PN} = " \ 23FILES_${PN} = " \
@@ -47,7 +30,7 @@ RDEPENDS_${PN} = " \
47 " 30 "
48 31
49do_compile() { 32do_compile() {
50 oe_runmake CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} -I${RECIPE_SYSROOT}/../${MLPREFIX32}recipe-sysroot/usr/include" \ 33 oe_runmake CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" \
51 CPP="${CPP}" \ 34 CPP="${CPP}" \
52 OBJCOPY="${OBJCOPY}" \ 35 OBJCOPY="${OBJCOPY}" \
53 PYTHON="${PYTHON}" 36 PYTHON="${PYTHON}"