summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2021-04-19 16:08:53 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-20 17:00:12 -0400
commit2406c1785dbfae5a7e2aa0c6e7a284ae3070f737 (patch)
tree533b321948febf8f6ce34da77e0b1246f511a15e /recipes-extended
parent298237cbad7dc1d8b03fa9ad02635edd25a557da (diff)
downloadmeta-virtualization-2406c1785dbfae5a7e2aa0c6e7a284ae3070f737.tar.gz
xen-tools: remove multilib build requirement for x86-64
Xen 4.15 added support for standalone x86-64 hvmloader build and previous commit provided Xen 4.14 backports. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xen-tools.inc37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-extended/xen/xen-tools.inc b/recipes-extended/xen/xen-tools.inc
index 722c5032..3560e798 100644
--- a/recipes-extended/xen/xen-tools.inc
+++ b/recipes-extended/xen/xen-tools.inc
@@ -6,29 +6,6 @@ COMPATIBLE_HOST = 'i686-.*-linux|(x86_64.*).*-linux|aarch64.*-linux|arm-.*-linux
6inherit setuptools3 update-rc.d systemd deploy 6inherit setuptools3 update-rc.d systemd deploy
7require xen-blktap.inc 7require xen-blktap.inc
8 8
9# To build hvmloader, which is needed on x86-64 targets when 'hvm' is enabled
10# in PACKAGECONFIG, to support running HVM-mode guest VMs, some files from
11# 32-bit glibc are needed.
12# Add the multilib 32-bit glibc to DEPENDS only when necessary.
13#
14# To enable multilib, please add the following to your local.conf -:
15#
16# require conf/multilib.conf
17# MULTILIBS = "multilib:lib32"
18# DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
19
20# Use this multilib prefix for x86 32-bit to match local.conf:
21MLPREFIX32 = "lib32-"
22
23# The DEPENDS on a multilib 32-bit glibc is only added when target is x86-64
24# and 'hvm' is enabled in PACKAGECONFIG.
25# This x86-64 override is never intended for native use, so clear that.
26GLIBC32 = ""
27GLIBC32_x86-64 = \
28 "${@bb.utils.contains('PACKAGECONFIG', 'hvm', '${MLPREFIX32}glibc', '', d)}"
29GLIBC32_class-native = ""
30DEPENDS += "${GLIBC32}"
31
32RDEPENDS_${PN} = "\ 9RDEPENDS_${PN} = "\
33 bash perl xz \ 10 bash perl xz \
34 ${PN}-console \ 11 ${PN}-console \
@@ -736,16 +713,6 @@ SYSTEMD_SERVICE_${PN}-xencommons = " \
736 " 713 "
737SYSTEMD_SERVICE_${PN}-xendomains = "xendomains.service" 714SYSTEMD_SERVICE_${PN}-xendomains = "xendomains.service"
738 715
739# To build hvmloader, which is needed on x86-64 targets when 'hvm' is enabled
740# in PACKAGECONFIG, additional CFLAGS are needed to set the 32-bit sysroot.
741RECIPE_SYSROOT32 = "${WORKDIR}/${MLPREFIX32}recipe-sysroot"
742ADD_SYSROOT32_CFLAGS = ""
743ADD_SYSROOT32_CFLAGS_x86-64 = \
744 "${@bb.utils.contains('PACKAGECONFIG', 'hvm', \
745 'CFLAGS += "--sysroot=${RECIPE_SYSROOT32}"', '', d)}"
746# This x86-64 override is never intended for native use, so clear that.
747ADD_SYSROOT32_CFLAGS_class-native = ""
748
749EXTRA_OECONF += " \ 716EXTRA_OECONF += " \
750 --with-systemd=${systemd_unitdir}/system \ 717 --with-systemd=${systemd_unitdir}/system \
751 --with-systemd-modules-load=${systemd_unitdir}/modules-load.d \ 718 --with-systemd-modules-load=${systemd_unitdir}/modules-load.d \
@@ -756,10 +723,6 @@ EXTRA_OECONF += " \
756 723
757do_configure() { 724do_configure() {
758 do_configure_common 725 do_configure_common
759
760 if [ -n '${ADD_SYSROOT32_CFLAGS}' ] ; then
761 echo '${ADD_SYSROOT32_CFLAGS}' >>"${S}/tools/firmware/Rules.mk"
762 fi
763} 726}
764 727
765do_compile() { 728do_compile() {