summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2018-09-29 09:15:33 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-30 21:31:21 -0400
commita49ca99d063bce9158c7094279cf498dfbfe0455 (patch)
tree442091efd898410ce9c90802ba7f7ca4b7445a53 /recipes-extended/ceph/ceph
parent2dc1de2286bbf72afd8009188e1e1ec9fb35f804 (diff)
downloadmeta-virtualization-a49ca99d063bce9158c7094279cf498dfbfe0455.tar.gz
ceph: add support for ceph
Ceph is a distributed object, block, and file storage platform, ceph depends on oath-toolkit, so add the oath-toolkit also. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/ceph/ceph')
-rw-r--r--recipes-extended/ceph/ceph/0001-Correct-the-path-to-find-version.h-in-rocksdb.patch40
-rw-r--r--recipes-extended/ceph/ceph/0001-ceph-disable-pybind.patch28
-rw-r--r--recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch26
3 files changed, 94 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-Correct-the-path-to-find-version.h-in-rocksdb.patch b/recipes-extended/ceph/ceph/0001-Correct-the-path-to-find-version.h-in-rocksdb.patch
new file mode 100644
index 00000000..788505b2
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-Correct-the-path-to-find-version.h-in-rocksdb.patch
@@ -0,0 +1,40 @@
1From a53605694d5301b7bb543464b17f74bbbd35d372 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Tue, 28 Aug 2018 10:04:40 +0800
4Subject: [PATCH] Correct the path to find version.h in rocksdb
5
6Signed-off-by: Dengke Du <dengke.du@windriver.com>
7---
8 cmake/modules/Findrocksdb.cmake | 10 +++++-----
9 1 file changed, 5 insertions(+), 5 deletions(-)
10
11diff --git a/cmake/modules/Findrocksdb.cmake b/cmake/modules/Findrocksdb.cmake
12index f8369f7..36b67ea 100644
13--- a/cmake/modules/Findrocksdb.cmake
14+++ b/cmake/modules/Findrocksdb.cmake
15@@ -9,17 +9,17 @@
16 # ROCKSDB_VERSION_MINOR
17 # ROCKSDB_VERSION_PATCH
18
19-find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h)
20+find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h ${CMAKE_SYSROOT})
21
22-find_library(ROCKSDB_LIBRARIES rocksdb)
23+find_library(ROCKSDB_LIBRARIES rocksdb ${CMAKE_SYSROOT})
24
25 if(ROCKSDB_INCLUDE_DIR AND EXISTS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h")
26 foreach(ver "MAJOR" "MINOR" "PATCH")
27- file(STRINGS "${ROCKSDB_INCLUDE_DIR}/version.h" ROCKSDB_VER_${ver}_LINE
28+ file(STRINGS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h" ROCKSDB_VER_${ver}_LINE
29 REGEX "^#define[ \t]+ROCKSDB_${ver}[ \t]+[0-9]+$")
30 string(REGEX REPLACE "^#define[ \t]+ROCKSDB_${ver}[ \t]+([0-9]+)$"
31- "\\1" ROCKSDB_VERSION_${ver} "${ROCKDB_VER_${ver}_LINE}")
32- unset(${ROCKDB_VER_${ver}_LINE})
33+ "\\1" ROCKSDB_VERSION_${ver} "${ROCKSDB_VER_${ver}_LINE}")
34+ unset(ROCKSDB_VER_${ver}_LINE)
35 endforeach()
36 set(ROCKSDB_VERSION_STRING
37 "${ROCKSDB_VERSION_MAJOR}.${ROCKSDB_VERSION_MINOR}.${ROCKSDB_VERSION_PATCH}")
38--
392.7.4
40
diff --git a/recipes-extended/ceph/ceph/0001-ceph-disable-pybind.patch b/recipes-extended/ceph/ceph/0001-ceph-disable-pybind.patch
new file mode 100644
index 00000000..bfba5b07
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-ceph-disable-pybind.patch
@@ -0,0 +1,28 @@
1From 05bdb2bb6026c3a2e536c7143b39a763ffc1225f Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Thu, 27 Sep 2018 09:09:40 +0800
4Subject: [PATCH] ceph: disable pybind
5
6New ceph version have bad support for corss compile,
7so disable pybind temporarily.
8
9Signed-off-by: Dengke Du <dengke.du@windriver.com>
10---
11 src/CMakeLists.txt | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
15index 374cbc7..44845f8 100644
16--- a/src/CMakeLists.txt
17+++ b/src/CMakeLists.txt
18@@ -777,7 +777,6 @@ if(NOT CEPH_BUILD_VIRTUALENV)
19 set(CEPH_BUILD_VIRTUALENV /tmp)
20 endif()
21
22-add_subdirectory(pybind)
23 add_subdirectory(ceph-disk)
24 add_subdirectory(ceph-volume)
25 add_subdirectory(ceph-detect-init)
26--
272.7.4
28
diff --git a/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch b/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch
new file mode 100644
index 00000000..66b5f0a5
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch
@@ -0,0 +1,26 @@
1From 3e86b6d9db2682b123839e38e9bf45060e2bb2ab Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 29 Aug 2018 16:57:52 +0800
4Subject: [PATCH] zstd: fix error for cross compile
5
6Signed-off-by: Dengke Du <dengke.du@windriver.com>
7---
8 src/compressor/zstd/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt
12index e30cb89..b298a3d 100644
13--- a/src/compressor/zstd/CMakeLists.txt
14+++ b/src/compressor/zstd/CMakeLists.txt
15@@ -9,7 +9,7 @@ ExternalProject_Add(zstd_ext
16 CMAKE_ARGS -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
17 -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
18 -DCMAKE_C_FLAGS=${ZSTD_C_FLAGS}
19- -DCMAKE_AR=${CMAKE_AR}
20+ -DCMAKE_SYSROOT=${CMAKE_SYSROOT}
21 BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd
22 BUILD_COMMAND $(MAKE) libzstd_static
23 INSTALL_COMMAND "true")
24--
252.7.4
26