summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch')
-rw-r--r--recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch b/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch
new file mode 100644
index 00000000..66b5f0a5
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-zstd-fix-error-for-cross-compile.patch
@@ -0,0 +1,26 @@
1From 3e86b6d9db2682b123839e38e9bf45060e2bb2ab Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 29 Aug 2018 16:57:52 +0800
4Subject: [PATCH] zstd: fix error for cross compile
5
6Signed-off-by: Dengke Du <dengke.du@windriver.com>
7---
8 src/compressor/zstd/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt
12index e30cb89..b298a3d 100644
13--- a/src/compressor/zstd/CMakeLists.txt
14+++ b/src/compressor/zstd/CMakeLists.txt
15@@ -9,7 +9,7 @@ ExternalProject_Add(zstd_ext
16 CMAKE_ARGS -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
17 -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
18 -DCMAKE_C_FLAGS=${ZSTD_C_FLAGS}
19- -DCMAKE_AR=${CMAKE_AR}
20+ -DCMAKE_SYSROOT=${CMAKE_SYSROOT}
21 BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd
22 BUILD_COMMAND $(MAKE) libzstd_static
23 INSTALL_COMMAND "true")
24--
252.7.4
26