summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2023-05-12 13:04:04 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-05-17 11:46:05 -0400
commit49a6827cbdb6e00d3af5e5c4a4479c47573a4533 (patch)
treea63b1807d749af3f0cce4ebacd731d02afb80cf0 /recipes-devtools
parent8e7b015b35593d14e57532b28e50396ed8a92280 (diff)
downloadmeta-virtualization-49a6827cbdb6e00d3af5e5c4a4479c47573a4533.tar.gz
yq: Redefine do_compile
This reverts commit 9b87b12885243c8cbba933e218c325416ec4d19d which states the linkshared issue is resolved. Actually the issue still exists as build fails on qemuarm64 and we still need the fix [1]. So add the fix [1] back and it's also better define its own do_compile and not let the do_compile logic in go.bbclass affect the build. [1] https://git.yoctoproject.org/meta-virtualization/commit/?id=d2a630ce6cf67a145f218012fbf02e4d0d9648df Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/yq/yq_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
index 45f2f970..bd474a79 100644
--- a/recipes-devtools/yq/yq_git.bb
+++ b/recipes-devtools/yq/yq_git.bb
@@ -50,7 +50,7 @@ GO_IMPORT = "github.com/mikefarah/yq"
50 50
51inherit go ptest 51inherit go ptest
52 52
53do_compile:prepend() { 53do_compile() {
54 # arrange for some of the golang built ins to be found 54 # arrange for some of the golang built ins to be found
55 ( 55 (
56 cd ${WORKDIR}/build/src/ 56 cd ${WORKDIR}/build/src/
@@ -60,6 +60,7 @@ do_compile:prepend() {
60 # arrange for the fetched dependencies to be found 60 # arrange for the fetched dependencies to be found
61 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/" 61 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/"
62 export GO111MODULE=off 62 export GO111MODULE=off
63 ${GO} install ${GOBUILDFLAGS} `go_list_packages`
63} 64}
64 65
65do_install:append() { 66do_install:append() {