summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-04-24 16:31:30 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-04-24 22:51:29 -0400
commitd3c6004e92bf21f7f2b425d062b6276ff53c8c18 (patch)
tree3d40f8afb203d5fe433cec3931f06ffa9feec3e5 /recipes-containers/criu/files
parent76c38f219d87da97ea3b1692aa886b2398466b51 (diff)
downloadmeta-virtualization-d3c6004e92bf21f7f2b425d062b6276ff53c8c18.tar.gz
criu: force python to install in ${libdir}
Historically Yocto installs python modules in ${libdir} and not the no-arch variant. The criu install was following every other distros use of the non-arch variant, /usr/lib, which was being picked up by the QA check. Modify the criu Makefile to enable us to overwrite this location by using setup.py's install-lib directive. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu/files')
-rw-r--r--recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
new file mode 100644
index 00000000..8bda8c42
--- /dev/null
+++ b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
@@ -0,0 +1,30 @@
1From 2e0c5c66786016f6443da2c1ff15ad77f018ec9b Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Mon, 24 Apr 2017 16:12:05 -0400
4Subject: [PATCH] lib/Makefile: overwrite install-lib, to allow multiarch
5
6I am not sure why Yocto installs python modules in arch specific
7/usr/libXX directories but it does. Allow the recipe to pass this via
8INSTALL_LIB.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 lib/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/lib/Makefile b/lib/Makefile
16index f1c0821..c714d12 100644
17--- a/lib/Makefile
18+++ b/lib/Makefile
19@@ -56,7 +56,7 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in
20 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc
21 $(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
22 $(E) " INSTALL " crit
23- $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES)
24+ $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(INSTALL_LIB)
25 .PHONY: install
26
27 uninstall:
28--
292.7.4
30