summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch')
-rw-r--r--recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
new file mode 100644
index 00000000..8bda8c42
--- /dev/null
+++ b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
@@ -0,0 +1,30 @@
1From 2e0c5c66786016f6443da2c1ff15ad77f018ec9b Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Mon, 24 Apr 2017 16:12:05 -0400
4Subject: [PATCH] lib/Makefile: overwrite install-lib, to allow multiarch
5
6I am not sure why Yocto installs python modules in arch specific
7/usr/libXX directories but it does. Allow the recipe to pass this via
8INSTALL_LIB.
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 lib/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/lib/Makefile b/lib/Makefile
16index f1c0821..c714d12 100644
17--- a/lib/Makefile
18+++ b/lib/Makefile
19@@ -56,7 +56,7 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in
20 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc
21 $(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
22 $(E) " INSTALL " crit
23- $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES)
24+ $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(INSTALL_LIB)
25 .PHONY: install
26
27 uninstall:
28--
292.7.4
30