summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-04-02 00:30:50 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-02 00:34:18 -0400
commita5074cecf18faea1a325c8ac9220d2df41250af5 (patch)
treec6be5b7ec3610572d7e9675787dc8ae88c85a35b
parente3d960f4fcd91a84067fbbd6293ce271e74a7740 (diff)
downloadmeta-virtualization-a5074cecf18faea1a325c8ac9220d2df41250af5.tar.gz
docker: uprev to 18.03.0
Uprev the docker daemon, proxy and cli to 18.03.0. The SRCREVs for these updates come from the versions logged in the docker-ce 18.03.0 release. The docker-ce recipe has a pure docker-ce single repository build, but here, we continue to assemble the individual parts for maximum flexibility. Along with the uprev, we add new dependencies required to build the new version; libtool and pkcconfig (although unused by the recipe itself). Finally we switch to a Makefile based build of the cli to allow the commit and docker version to be properly captured in the docker executable. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker_git.bb26
-rw-r--r--recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch75
2 files changed, 17 insertions, 84 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 28781fa0..13c27313 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -18,16 +18,15 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "e639a70fbe999d96354a5bcf560231b7b8aa935c" 21SRCREV_docker = "708b068d3095c6a6be939eb2da78c921d2e945e2"
22SRCREV_libnetwork = "26addf43a5d925ff79d262dbbdb5344bc2b6e198" 22SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c"
23SRCREV_cli = "a765218f1988e85b68aa3977f34893ec7b059a60" 23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457"
24SRC_URI = "\ 24SRC_URI = "\
25 git://github.com/moby/moby.git;nobranch=1;name=docker \ 25 git://github.com/moby/moby.git;nobranch=1;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \ 27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \
28 file://docker.init \ 28 file://docker.init \
29 file://hi.Dockerfile \ 29 file://hi.Dockerfile \
30 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \
31 " 30 "
32 31
33# Apache-2.0 for docker 32# Apache-2.0 for docker
@@ -38,7 +37,7 @@ GO_IMPORT = "import"
38 37
39S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
40 39
41DOCKER_VERSION = "17.06.0" 40DOCKER_VERSION = "18.03.0"
42PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 41PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
43 42
44DEPENDS = " \ 43DEPENDS = " \
@@ -59,6 +58,7 @@ DEPENDS = " \
59 go-connections \ 58 go-connections \
60 notary \ 59 notary \
61 grpc-go \ 60 grpc-go \
61 libtool \
62 " 62 "
63 63
64PACKAGES =+ "${PN}-contrib" 64PACKAGES =+ "${PN}-contrib"
@@ -77,6 +77,7 @@ DOCKER_PKG="github.com/docker/docker"
77inherit systemd update-rc.d 77inherit systemd update-rc.d
78inherit go 78inherit go
79inherit goarch 79inherit goarch
80inherit pkgconfig
80 81
81do_configure[noexec] = "1" 82do_configure[noexec] = "1"
82 83
@@ -105,17 +106,24 @@ do_compile() {
105 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 106 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056
106 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper' 107 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper'
107 108
109 export DISABLE_WARN_OUTSIDE_CONTAINER=1
110
111 cd ${S}/src/import/
112
108 # this is the unsupported built structure 113 # this is the unsupported built structure
109 # that doesn't rely on an existing docker 114 # that doesn't rely on an existing docker
110 # to build this: 115 # to build this:
111 DOCKER_GITCOMMIT="${SRCREV}" \ 116 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary
112 ./hack/make.sh dynbinary
113 117
114 # build the proxy 118 # build the proxy
115 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy 119 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy
116 120
117 # build the cli 121 # build the cli
118 go build -o ${S}/src/import/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker 122 cd ${S}/src/import/.gopath/src/github.com/docker/cli
123 export CFLAGS=""
124 export LDFLAGS=""
125 export DOCKER_VERSION=${DOCKER_VERSION}
126 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" make dynbinary
119} 127}
120 128
121SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 129SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
@@ -129,7 +137,7 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
129 137
130do_install() { 138do_install() {
131 mkdir -p ${D}/${bindir} 139 mkdir -p ${D}/${bindir}
132 cp ${S}/src/import/bundles/latest/dynbinary-client/docker ${D}/${bindir}/docker 140 cp ${WORKDIR}/cli/build/docker ${D}/${bindir}/docker
133 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 141 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
134 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy 142 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy
135 143
diff --git a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch b/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
deleted file mode 100644
index 7ed606ff..00000000
--- a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
+++ /dev/null
@@ -1,75 +0,0 @@
1From de69555afaf05efcdeea7b7c20c6f7b12f3e1bac Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Fri, 20 Jan 2017 11:58:44 -0500
4Subject: [PATCH] context: use golang.org/x/net pkg until we move to go 1.7
5
6In go 1.6 the context.go is not yet integrated and as such we will get
7build errors like:
8
9walwrap.go:4:2: cannot find package "context" in any of:
10...
11
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13---
14 client/README.md | 2 +-
15 client/client.go | 2 +-
16 daemon/info_unix.go | 2 +-
17 integration-cli/docker_api_attach_test.go | 2 +-
18 integration-cli/docker_cli_save_load_unix_test.go | 2 +-
19 5 files changed, 5 insertions(+), 5 deletions(-)
20
21--- a/src/import/client/README.md
22+++ b/src/import/client/README.md
23@@ -8,7 +8,7 @@ For example, to list running containers
24 package main
25
26 import (
27- "context"
28+ "golang.org/x/net/context"
29 "fmt"
30
31 "github.com/docker/docker/api/types"
32--- a/src/import/client/client.go
33+++ b/src/import/client/client.go
34@@ -19,7 +19,7 @@ For example, to list running containers
35 package main
36
37 import (
38- "context"
39+ "golang.org/x/net/context"
40 "fmt"
41
42 "github.com/docker/docker/api/types"
43--- a/src/import/daemon/info_unix.go
44+++ b/src/import/daemon/info_unix.go
45@@ -3,7 +3,7 @@
46 package daemon
47
48 import (
49- "context"
50+ "golang.org/x/net/context"
51 "os/exec"
52 "strings"
53
54--- a/src/import/integration-cli/docker_api_attach_test.go
55+++ b/src/import/integration-cli/docker_api_attach_test.go
56@@ -3,7 +3,7 @@ package main
57 import (
58 "bufio"
59 "bytes"
60- "context"
61+ "golang.org/x/net/context"
62 "io"
63 "net"
64 "net/http"
65--- a/src/import/integration-cli/docker_cli_save_load_unix_test.go
66+++ b/src/import/integration-cli/docker_cli_save_load_unix_test.go
67@@ -3,7 +3,7 @@
68 package main
69
70 import (
71- "context"
72+ "golang.org/x/net/context"
73 "fmt"
74 "io/ioutil"
75 "os"