summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/docker_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/docker_git.bb')
-rw-r--r--recipes-containers/docker/docker_git.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 28781fa0..13c27313 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -18,16 +18,15 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "e639a70fbe999d96354a5bcf560231b7b8aa935c" 21SRCREV_docker = "708b068d3095c6a6be939eb2da78c921d2e945e2"
22SRCREV_libnetwork = "26addf43a5d925ff79d262dbbdb5344bc2b6e198" 22SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c"
23SRCREV_cli = "a765218f1988e85b68aa3977f34893ec7b059a60" 23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457"
24SRC_URI = "\ 24SRC_URI = "\
25 git://github.com/moby/moby.git;nobranch=1;name=docker \ 25 git://github.com/moby/moby.git;nobranch=1;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \ 27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \
28 file://docker.init \ 28 file://docker.init \
29 file://hi.Dockerfile \ 29 file://hi.Dockerfile \
30 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \
31 " 30 "
32 31
33# Apache-2.0 for docker 32# Apache-2.0 for docker
@@ -38,7 +37,7 @@ GO_IMPORT = "import"
38 37
39S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
40 39
41DOCKER_VERSION = "17.06.0" 40DOCKER_VERSION = "18.03.0"
42PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 41PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
43 42
44DEPENDS = " \ 43DEPENDS = " \
@@ -59,6 +58,7 @@ DEPENDS = " \
59 go-connections \ 58 go-connections \
60 notary \ 59 notary \
61 grpc-go \ 60 grpc-go \
61 libtool \
62 " 62 "
63 63
64PACKAGES =+ "${PN}-contrib" 64PACKAGES =+ "${PN}-contrib"
@@ -77,6 +77,7 @@ DOCKER_PKG="github.com/docker/docker"
77inherit systemd update-rc.d 77inherit systemd update-rc.d
78inherit go 78inherit go
79inherit goarch 79inherit goarch
80inherit pkgconfig
80 81
81do_configure[noexec] = "1" 82do_configure[noexec] = "1"
82 83
@@ -105,17 +106,24 @@ do_compile() {
105 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 106 # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056
106 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper' 107 export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper'
107 108
109 export DISABLE_WARN_OUTSIDE_CONTAINER=1
110
111 cd ${S}/src/import/
112
108 # this is the unsupported built structure 113 # this is the unsupported built structure
109 # that doesn't rely on an existing docker 114 # that doesn't rely on an existing docker
110 # to build this: 115 # to build this:
111 DOCKER_GITCOMMIT="${SRCREV}" \ 116 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary
112 ./hack/make.sh dynbinary
113 117
114 # build the proxy 118 # build the proxy
115 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy 119 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy
116 120
117 # build the cli 121 # build the cli
118 go build -o ${S}/src/import/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker 122 cd ${S}/src/import/.gopath/src/github.com/docker/cli
123 export CFLAGS=""
124 export LDFLAGS=""
125 export DOCKER_VERSION=${DOCKER_VERSION}
126 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" make dynbinary
119} 127}
120 128
121SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 129SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
@@ -129,7 +137,7 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
129 137
130do_install() { 138do_install() {
131 mkdir -p ${D}/${bindir} 139 mkdir -p ${D}/${bindir}
132 cp ${S}/src/import/bundles/latest/dynbinary-client/docker ${D}/${bindir}/docker 140 cp ${WORKDIR}/cli/build/docker ${D}/${bindir}/docker
133 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 141 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
134 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy 142 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy
135 143