summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-10 14:59:14 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:35:06 -0400
commit5e20120aa7ce1b870ce9f1085e689015a624f269 (patch)
treec7c4894b4a17f98e5768829ef8e20376b735c0a6
parent279dbced29e928618ba836226542926604d7e570 (diff)
downloadmeta-virtualization-5e20120aa7ce1b870ce9f1085e689015a624f269.tar.gz
oci-runtime-tools: fix do package qa warning
1. After security flag PIE is enabled by default, we might met below QA warning on some arch, like aarch64, fix it by skip textrel QA check refer commit b689c72a of oe-core oci-runtime-tools-0.1.0+gitAUTOINC+6e7da8148f-r0 do_package_qa: QA Issue: ELF binary 'work/aarch64-poky-linux/oci-runtime-tools/0.1.0+gitAUTOINC+6e7 da8148f-r0/packages-split/oci-runtime-tools/usr/sbin/oci-runtime-tool' has relocations in .text [textrel] 2. This problem is caused since security_flags.inc is used by default. so alternative work around is: SECURITY_CFLAGS_pn-oci-runtime-tools = "${SECURITY_NOPIE_CFLAGS}" SECURITY_LDFLAGS_pn-oci-runtime-tools = "" Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 61b68b5f..adbfc1ef 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -11,7 +11,7 @@ SRCREV = "6e7da8148f4de2c9e9c9d3b345576898d4f412cb"
11PV = "0.1.0+git${SRCPV}" 11PV = "0.1.0+git${SRCPV}"
12GO_IMPORT = "import" 12GO_IMPORT = "import"
13 13
14INSANE_SKIP_${PN} += "ldflags" 14INSANE_SKIP_${PN} += "ldflags textrel"
15 15
16inherit goarch 16inherit goarch
17inherit go 17inherit go