summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Patterson <pattersonc@ainfosec.com>2018-10-11 11:15:39 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:17:39 -0400
commit279dbced29e928618ba836226542926604d7e570 (patch)
tree74bda8d9fdd1753119b0f7509525803047c5e9bd
parentfd6854231fae5973932e87ebafb1b032d20d4135 (diff)
downloadmeta-virtualization-279dbced29e928618ba836226542926604d7e570.tar.gz
iasl: remove iasl in favor of acpica in openembedded-core
It is out of date, causes compilation errors, and is replacable with acpica. This commit removes the iasl recipe as well as updating references within seabios and xen, even though acpcica PROVIDES iasl. Signed-off-by: Chris Patterson <pattersonc@ainfosec.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch29
-rw-r--r--recipes-extended/iasl/iasl/iasl.1135
-rw-r--r--recipes-extended/iasl/iasl_20160527.bb36
-rw-r--r--recipes-extended/seabios/seabios_1.11.2.bb2
-rw-r--r--recipes-extended/xen/xen.inc2
5 files changed, 2 insertions, 202 deletions
diff --git a/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch b/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch
deleted file mode 100644
index f69a36c6..00000000
--- a/recipes-extended/iasl/iasl/Make-CC-definition-conditional.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1[PATCH] Make CC definition conditional
2
3Upstream-Status: pending
4
5By hardcoding CC's definition to gcc, make this packages unable to
6cross-compile. the -e options of make can not override the CC since
7it is not defined in Makefile, but in Makefile.config
8
9Signed-off-by: Roy.Li <rongqing.li@windriver.com>
10---
11 generate/unix/Makefile.config | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
15index 8d41399..72d597d 100644
16--- a/generate/unix/Makefile.config
17+++ b/generate/unix/Makefile.config
18@@ -35,7 +35,7 @@
19 .SUFFIXES :
20 PROGS = acpibin acpidump acpiexamples acpiexec acpihelp acpinames acpisrc acpixtract iasl
21 HOST ?= _CYGWIN
22-CC = gcc
23+CC ?= gcc
24
25 #
26 # Common defines
27--
281.9.1
29
diff --git a/recipes-extended/iasl/iasl/iasl.1 b/recipes-extended/iasl/iasl/iasl.1
deleted file mode 100644
index 000a3b81..00000000
--- a/recipes-extended/iasl/iasl/iasl.1
+++ /dev/null
@@ -1,135 +0,0 @@
1.\" First parameter, NAME, should be all caps
2.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
3.\" other parameters are allowed: see man(7), man(1)
4.TH IASL 1 "October 14, 2005"
5.\" Please adjust this date whenever revising the manpage.
6.\"
7.\" Some roff macros, for reference:
8.\" .nh disable hyphenation
9.\" .hy enable hyphenation
10.\" .ad l left justify
11.\" .ad b justify to both left and right margins
12.\" .nf disable filling
13.\" .fi enable filling
14.\" .br insert line break
15.\" .sp <n> insert n+1 empty lines
16.\" for manpage-specific macros, see man(7)
17.SH NAME
18iasl \- ACPI Source Language compiler/decompiler
19.SH SYNOPSIS
20.B iasl
21.RI [ options ]
22.RI [ "input file" ]
23.SH DESCRIPTION
24This manual page documents briefly the
25.B iasl
26command. The option list is taken from the iasl interactive help.
27.PP
28.\" TeX users may be more comfortable with the \fB<whatever>\fP and
29.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
30.\" respectively.
31.B iasl
32is an ASL compiler and decompiler.
33
34.SH OPTIONS
35
36.PP
37.SS General Output
38.TP
39.B \-p <prefix>
40Specify filename prefix for all output files (including .aml)
41.TP
42.B \-vi
43Less verbose errors and warnings for use with IDEs
44.TP
45.B \-vo
46Enable optimization comments
47.TP
48.B \-vr
49Disable remarks
50.TP
51.B \-vs
52Disable signon
53
54.PP
55.SS AML Output Files
56.TP
57.B \-s<a|c>
58Create AML in assembler or C source file (*.asm or *.c)
59.TP
60.B \-i<a|c>
61Create assembler or C include file (*.inc or *.h)
62.TP
63.B \-t<a|c>
64Create AML in assembler or C hex table (*.hex)
65
66.PP
67.SS AML Code Generation
68.TP
69.B \-oa
70Disable all optimizations (compatibility mode)
71.TP
72.B \-of
73Disable constant folding
74.TP
75.B \-oi
76Disable integer optimization to Zero/One/Ones
77.TP
78.B \-on
79Disable named reference string optimization
80.TP
81.B \-r<Revision>
82Override table header Revision (1-255)
83
84.PP
85.SS Listings
86.TP
87.B \-l
88Create mixed listing file (ASL source and AML) (*.lst)
89.TP
90.B \-ln
91Create namespace file (*.nsp)
92.TP
93.B \-ls
94Create combined source file (expanded includes) (*.src)
95
96.PP
97.SS AML Disassembler
98.TP
99.B \-d [file]
100Disassemble AML to ASL source code file (*.dsl)
101.TP
102.B \-dc [file]
103Disassemble AML and immediately compile it
104.br
105(Obtain DSDT from current system if no input file)
106.TP
107.B \-e
108Generate External() statements for unresolved symbols
109.TP
110.B \-g
111Get ACPI tables and write to files (*.dat)
112
113.PP
114.SS Miscellaneous
115.TP
116.B \-a
117Verify source file is entirely ASCII text (0x00-0x7F)
118
119.PP
120.SS Help
121.TP
122.B \-h
123Additional help and compiler debug options
124.TP
125.B \-hc
126Display operators allowed in constant expressions
127.TP
128.B \-hr
129Display ACPI reserved method names
130
131.SH AUTHOR
132iasl was written by Robert Moore <robert.moore@intel.com>.
133.PP
134This manual page was written by Mattia Dongili <malattia@debian.org>,
135for the Debian project (but may be used by others).
diff --git a/recipes-extended/iasl/iasl_20160527.bb b/recipes-extended/iasl/iasl_20160527.bb
deleted file mode 100644
index 62e83c47..00000000
--- a/recipes-extended/iasl/iasl_20160527.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "Intel ASL compiler/decompiler"
2DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)"
3HOMEPAGE = "http://www.acpica.org/"
4LICENSE = "Intel-ACPI"
5LIC_FILES_CHKSUM = "file://source/compiler/aslcompiler.h;beginline=7;endline=114;md5=09f82edcd148ab4c8aa554bc3e9d0676"
6SECTION = "console/tools"
7
8DEPENDS = "bison-native flex-native"
9
10SRC_URI = "https://www.acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz \
11 file://iasl.1 \
12 file://Make-CC-definition-conditional.patch \
13"
14
15SRC_URI[md5sum] = "be677fc358de9dadc036e1ea678a101b"
16SRC_URI[sha256sum] = "6b681732624de1eb58b2bcf1c7ef0744ba14ed35fcaa534d4421574782fbb848"
17
18S = "${WORKDIR}/acpica-unix-${PV}/"
19
20BBCLASSEXTEND = "native"
21CFLAGS += "-D_LINUX -DACPI_ASL_COMPILER -I../include -I../compiler"
22
23COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
24
25# By setting NOOPT we suppress forcing -O2 and setting _FORTIFY_SOURCE=2. Let the
26# optimization and security cflags set them.
27#
28do_compile() {
29 oe_runmake iasl NOOPT=TRUE NOFORTIFY=TRUE
30}
31
32do_install() {
33 install -d ${D}${bindir} ${D}${mandir}/man1
34 install -m 0755 ${S}/generate/unix/bin/iasl ${D}${bindir}
35 install -m 0644 ${WORKDIR}/iasl.1 ${D}${mandir}/man1
36}
diff --git a/recipes-extended/seabios/seabios_1.11.2.bb b/recipes-extended/seabios/seabios_1.11.2.bb
index 4ea9eb78..81eaec96 100644
--- a/recipes-extended/seabios/seabios_1.11.2.bb
+++ b/recipes-extended/seabios/seabios_1.11.2.bb
@@ -18,7 +18,7 @@ SRC_URI[sha256sum] = "73e73c8e406d97265782f6c942b3c1d178ed4f4afc9f381b22336c3968
18 18
19FILES_${PN} = "/usr/share/firmware" 19FILES_${PN} = "/usr/share/firmware"
20 20
21DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native iasl-native python-native" 21DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native acpica-native python-native"
22 22
23TUNE_CCARGS = "" 23TUNE_CCARGS = ""
24EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'" 24EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'"
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index 365f71d9..7efc8df1 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -30,7 +30,7 @@ DEPENDS = " \
30 flex-native \ 30 flex-native \
31 file-native \ 31 file-native \
32 gettext-native \ 32 gettext-native \
33 iasl-native \ 33 acpica-native \
34 ncurses-native \ 34 ncurses-native \
35 util-linux-native \ 35 util-linux-native \
36 xz-native \ 36 xz-native \