summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-03-04 20:22:53 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:19 +0000
commit417cfa77c5fe870a7cd3f76a37f5d45f5f743c79 (patch)
tree6520d50fdd6ed16a42f811558c03a9f97d2b9d32
parente11497bda23ecb573c776104106fa160e32be841 (diff)
downloadmeta-virtualization-417cfa77c5fe870a7cd3f76a37f5d45f5f743c79.tar.gz
kubernetes: fix build with go 1.21+
go1.21+ checks the GOTOOLCHAIN variable and will attempt to validate/fetch the toolchain version requested. That doesn't work in our environment, so we export the variable as "local" to indicate that the build should trust (and use) the local toolchain. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 9923c4e8..caa5ec17 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -71,6 +71,11 @@ do_compile() {
71 export CC="${BUILD_CC}" 71 export CC="${BUILD_CC}"
72 export LD="${BUILD_LD}" 72 export LD="${BUILD_LD}"
73 73
74 # set the toolchain to local to avoid an attempted fetch of
75 # valiation by the build
76 # https://github.com/actions/setup-go/issues/420
77 export GOTOOLCHAIN="local"
78
74 # make generated_files GO="go" KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}" 79 # make generated_files GO="go" KUBE_BUILD_PLATFORMS="${HOST_GOOS}/${BUILD_GOARCH}"
75 # is replaced by: 80 # is replaced by:
76 # ./hack/update-codegen.sh 81 # ./hack/update-codegen.sh