summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-02-27 18:24:29 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:19 +0000
commite11497bda23ecb573c776104106fa160e32be841 (patch)
tree0245b1b3cc9a407204a6569d78e9a43d5ab03940
parent17eeea68a5022a47bfcf803fa383adb77bc717c2 (diff)
downloadmeta-virtualization-e11497bda23ecb573c776104106fa160e32be841.tar.gz
kubernetes: allow go 1.20 building
Although k8s checks for, and demands, golang 1.21.x, runtime tests show that golang 1.20.x is properly building and providing enough for core functionality. In an effort to see what else may be lurking, we patch out the check to allow builds with our 1.20.x toolchain. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/kubernetes/kubernetes/0001-build-hack-allow-go-1.20-building.patch35
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-containers/kubernetes/kubernetes/0001-build-hack-allow-go-1.20-building.patch b/recipes-containers/kubernetes/kubernetes/0001-build-hack-allow-go-1.20-building.patch
new file mode 100644
index 00000000..ac2d8c47
--- /dev/null
+++ b/recipes-containers/kubernetes/kubernetes/0001-build-hack-allow-go-1.20-building.patch
@@ -0,0 +1,35 @@
1From 6f67131b030c4c228cabb33d45ae9330cbf8fa0a Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 27 Feb 2024 18:05:54 +0000
4Subject: [PATCH] build/hack: allow go 1.20 building
5
6Although k8s checks for, and demands, golang 1.21.x, runtime
7tests show that golang 1.20.x is properly building and providing
8enough for core functionality.
9
10In an effort to see what else may be lurking, we patch out the
11check to allow builds with our 1.20.x toolchain.
12
13Upstream-Status: Inappropriate [embedded specific]
14
15Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
16---
17 hack/lib/golang.sh | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/hack/lib/golang.sh b/hack/lib/golang.sh
21index 588288285bb..eb2bcc917b8 100755
22--- a/hack/lib/golang.sh
23+++ b/hack/lib/golang.sh
24@@ -499,7 +499,7 @@ Detected go version: ${go_version[*]}.
25 Kubernetes requires ${minimum_go_version} or greater.
26 Please install ${minimum_go_version} or later.
27 EOF
28- return 2
29+ return 0
30 fi
31 }
32
33--
342.39.2
35
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 01bc3e59..9923c4e8 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -30,6 +30,7 @@ SRC_URI:append = " \
30 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \ 30 file://0001-hack-lib-golang.sh-use-CC-from-environment.patch \
31 file://0001-cross-don-t-build-tests-by-default.patch \ 31 file://0001-cross-don-t-build-tests-by-default.patch \
32 file://0001-build-golang.sh-convert-remaining-go-calls-to-use.patch \ 32 file://0001-build-golang.sh-convert-remaining-go-calls-to-use.patch \
33 file://0001-build-hack-allow-go-1.20-building.patch \
33 file://cni-containerd-net.conflist \ 34 file://cni-containerd-net.conflist \
34 file://k8s-init \ 35 file://k8s-init \
35 file://99-kubernetes.conf \ 36 file://99-kubernetes.conf \