summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-03-22 16:28:01 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-22 18:37:08 +0000
commit3fbc1ae7cab384db405c26679ca2fedcb4b6c93d (patch)
tree67d42d3bcdce17b13be1de66439eed50c674b77e
parent4666b2a2d80c8d063b4de3fea3142115b7598779 (diff)
downloadmeta-virtualization-3fbc1ae7cab384db405c26679ca2fedcb4b6c93d.tar.gz
podman: conditionally add cni build tag
We should ensure that cni is built as part of podman if that's the configured virtual runtime. Although cni is not a primary networking backend for podman, this also allows it to be skipped if netavark is used. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/podman/podman_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index fc532d6a..6ae93369 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -39,9 +39,11 @@ CVE_STATUS[CVE-2023-0778] = "fixed-version: fixed since v4.5.0"
39PACKAGES =+ "${PN}-contrib" 39PACKAGES =+ "${PN}-contrib"
40 40
41PODMAN_PKG = "github.com/containers/libpod" 41PODMAN_PKG = "github.com/containers/libpod"
42
43BUILDTAGS_EXTRA ?= "${@bb.utils.contains('VIRTUAL-RUNTIME_container_networking','cni','cni','',d)}"
42BUILDTAGS ?= "seccomp varlink \ 44BUILDTAGS ?= "seccomp varlink \
43${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ 45${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
44exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" 46exclude_graphdriver_btrfs exclude_graphdriver_devicemapper ${BUILDTAGS_EXTRA}"
45 47
46# overide LDFLAGS to allow podman to build without: "flag provided but not # defined: -Wl,-O1 48# overide LDFLAGS to allow podman to build without: "flag provided but not # defined: -Wl,-O1
47export LDFLAGS="" 49export LDFLAGS=""