summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-03-21 23:15:13 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-21 23:15:13 +0000
commit4666b2a2d80c8d063b4de3fea3142115b7598779 (patch)
tree53406f7c4c3145830744874d20af346c92bb6a49
parent4e6a74ff63efe58c92c267c5ace3e464e76448f6 (diff)
downloadmeta-virtualization-4666b2a2d80c8d063b4de3fea3142115b7598779.tar.gz
xen: use bzImage for boot (instead of vmlinux)
Testing with the latest oe-core was unable to boot and only syslinux was running. It appears that the desired kernel is not on the /boot partition, and hence the system can't continue. bzImage is installed and available, so we switch to that. We also ensure that both kernel-vmlinux and kernel-image are installed to the rootfs so we can have choices in the future. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/images/xen-image-minimal.bb7
-rw-r--r--wic/qemuboot-xen-x86-64.cfg2
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index 7f1acbfe..fe79a485 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -14,6 +14,8 @@ IMAGE_INSTALL += " \
14 ${XEN_KERNEL_MODULES} \ 14 ${XEN_KERNEL_MODULES} \
15 xen-tools \ 15 xen-tools \
16 qemu \ 16 qemu \
17 kernel-image \
18 kernel-vmlinux \
17 " 19 "
18 20
19# The hypervisor may not be within the dom0 filesystem image but at least 21# The hypervisor may not be within the dom0 filesystem image but at least
@@ -50,20 +52,24 @@ do_check_xen_state() {
50 52
51addtask check_xen_state before do_rootfs 53addtask check_xen_state before do_rootfs
52 54
55# note: this may be unused, see the wic plugin
53syslinux_iso_populate:append() { 56syslinux_iso_populate:append() {
54 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${ISODIR}${ISOLINUXDIR} 57 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${ISODIR}${ISOLINUXDIR}
55 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${ISODIR}${ISOLINUXDIR} 58 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${ISODIR}${ISOLINUXDIR}
56} 59}
57 60
61# note: this may be unused, see the wic plugin
58syslinux_hddimg_populate:append() { 62syslinux_hddimg_populate:append() {
59 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${HDDDIR}${SYSLINUXDIR} 63 install -m 0444 ${STAGING_DATADIR}/syslinux/libcom32.c32 ${HDDDIR}${SYSLINUXDIR}
60 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${HDDDIR}${SYSLINUXDIR} 64 install -m 0444 ${STAGING_DATADIR}/syslinux/mboot.c32 ${HDDDIR}${SYSLINUXDIR}
61} 65}
62 66
67# note: this may be unused, see the wic plugin
63grubefi_populate:append() { 68grubefi_populate:append() {
64 install -m 0644 ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz ${DEST}${EFIDIR}/xen.gz 69 install -m 0644 ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz ${DEST}${EFIDIR}/xen.gz
65} 70}
66 71
72# note: this may be unused, see the wic plugin
67syslinux_populate:append() { 73syslinux_populate:append() {
68 install -m 0644 ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz ${DEST}/xen.gz 74 install -m 0644 ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.gz ${DEST}/xen.gz
69} 75}
@@ -71,6 +77,7 @@ syslinux_populate:append() {
71SYSLINUX_XEN_ARGS ?= "loglvl=all guest_loglvl=all console=com1,vga com1=115200,8n1" 77SYSLINUX_XEN_ARGS ?= "loglvl=all guest_loglvl=all console=com1,vga com1=115200,8n1"
72SYSLINUX_KERNEL_ARGS ?= "ramdisk_size=32768 root=/dev/ram0 rw console=hvc0 earlyprintk=xen console=tty0 panic=10 LABEL=boot debugshell=5" 78SYSLINUX_KERNEL_ARGS ?= "ramdisk_size=32768 root=/dev/ram0 rw console=hvc0 earlyprintk=xen console=tty0 panic=10 LABEL=boot debugshell=5"
73 79
80# note: this may be unused, see the wic plugin
74build_syslinux_cfg () { 81build_syslinux_cfg () {
75 echo "ALLOWOPTIONS 1" > ${SYSLINUX_CFG} 82 echo "ALLOWOPTIONS 1" > ${SYSLINUX_CFG}
76 echo "DEFAULT boot" >> ${SYSLINUX_CFG} 83 echo "DEFAULT boot" >> ${SYSLINUX_CFG}
diff --git a/wic/qemuboot-xen-x86-64.cfg b/wic/qemuboot-xen-x86-64.cfg
index 297e19b2..94fb0890 100644
--- a/wic/qemuboot-xen-x86-64.cfg
+++ b/wic/qemuboot-xen-x86-64.cfg
@@ -5,4 +5,4 @@ SERIAL 0 115200
5 5
6LABEL boot 6LABEL boot
7 KERNEL mboot.c32 7 KERNEL mboot.c32
8 APPEND /xen.gz console=com1,vga com1=115200,8n1 loglvl=all guest_loglvl=all --- /vmlinuz console=hvc0 earlyprintk=xen root=/dev/sda2 pmtmr=0 8 APPEND /xen.gz console=com1,vga com1=115200,8n1 loglvl=all guest_loglvl=all --- /bZimage console=hvc0 earlyprintk=xen root=/dev/sda2 pmtmr=0