summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-10-13 19:27:13 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-16 11:54:24 -0400
commit37b2f2f3cc6067f6aaa264a40d34debd02be6ef2 (patch)
treed29fc65b9774b235d3107c74bfc103ca46fd6bbd
parent123cb0a0088247c7d8c8d0451533c40b37ef3201 (diff)
downloadmeta-virtualization-37b2f2f3cc6067f6aaa264a40d34debd02be6ef2.tar.gz
runc-opencontainers: Drop unnecessary do_compile_prepend
The "vendor/src" symlink is already created in do_compile in runc.inc. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb7
1 files changed, 0 insertions, 7 deletions
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index 2cfceea8..78488e03 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -10,10 +10,3 @@ PROVIDES += "virtual/runc"
10RPROVIDES_${PN} = "virtual/runc" 10RPROVIDES_${PN} = "virtual/runc"
11 11
12GO_IMPORT = "import" 12GO_IMPORT = "import"
13
14do_compile_prepend() {
15 # Go looks in a src directory under any directory in GOPATH but
16 # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix
17 # this with a symlink.
18 ln -sfn . "${S}/src/import/vendor/src"
19}