summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Patterson <pattersonc@ainfosec.com>2018-10-11 11:17:06 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:17:39 -0400
commitfd6854231fae5973932e87ebafb1b032d20d4135 (patch)
treec84cba1c2b2eea3adfd74a3359c4def2ea658df8
parent4be88e83904f62786d4af9d03204ba559777ab0f (diff)
downloadmeta-virtualization-fd6854231fae5973932e87ebafb1b032d20d4135.tar.gz
ipxe: recipe cleanup and uprev to current
- Use OE's cross compiler (was building with host's). - Uprev to latest git (no releases) - Update LICENSE file path and checksum - Remove configure sed and set isolinux bin variable used in Makefile - Scrub LDFLAGS and use LD - Add xz depends Signed-off-by: Chris Patterson <pattersonc@ainfosec.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/ipxe/ipxe_git.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/recipes-extended/ipxe/ipxe_git.bb b/recipes-extended/ipxe/ipxe_git.bb
index c0c8a7b7..18c92d2b 100644
--- a/recipes-extended/ipxe/ipxe_git.bb
+++ b/recipes-extended/ipxe/ipxe_git.bb
@@ -1,10 +1,10 @@
1DESCRIPTION = "Open source network boot firmware" 1DESCRIPTION = "Open source network boot firmware"
2HOMEPAGE = "http://ipxe.org" 2HOMEPAGE = "http://ipxe.org"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native" 4DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native xz"
5LIC_FILES_CHKSUM = "file://../COPYING;md5=8ca43cbc842c2336e835926c2166c28b" 5LIC_FILES_CHKSUM = "file://../COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6 6
7SRCREV = "8c43891db4eb131d019360ccfb619f235b17eb58" 7SRCREV = "133f4c47baef6002b2ccb4904a035cda2303c6e5"
8PV = "gitr${SRCPV}" 8PV = "gitr${SRCPV}"
9PR = "r0" 9PR = "r0"
10 10
@@ -12,15 +12,10 @@ SRC_URI = "git://git.ipxe.org/ipxe.git;protocol=https"
12 12
13FILES_${PN} = "/usr/share/firmware/*.rom" 13FILES_${PN} = "/usr/share/firmware/*.rom"
14 14
15EXTRA_OEMAKE = "NO_WERROR=1" 15EXTRA_OEMAKE = "NO_WERROR=1 ISOLINUX_BIN="${STAGING_DIR_TARGET}/usr/share/syslinux/isolinux.bin" CROSS_COMPILE="${TARGET_PREFIX}""
16#PARALLEL_MAKE=""
17 16
18S = "${WORKDIR}/git/src" 17S = "${WORKDIR}/git/src"
19 18
20do_configure() {
21 sed -i s#^ISOLINUX_BIN[\ \\t]*=.*#ISOLINUX_BIN\ =\ ${STAGING_DIR_TARGET}/usr/lib/syslinux/isolinux.bin# arch/i386/Makefile
22}
23
24do_compile() { 19do_compile() {
25 oe_runmake 20 oe_runmake
26} 21}