summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2018-10-26 17:43:53 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-30 13:41:16 -0400
commit2519e5b16d692bb7479f75be1a3e58912e070d4c (patch)
treef46a53eac4a1e1c6178263102b04dcdd40fef258
parentf33c8698fd5fda6c687a2604c2405721fc096cae (diff)
downloadmeta-virtualization-2519e5b16d692bb7479f75be1a3e58912e070d4c.tar.gz
ceph: fix Distutils.cmake installation for cross compile
1. Remove the detection for build host and correct the install destination for cross compile. 2. Delete the build host information in the results files. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch36
-rw-r--r--recipes-extended/ceph/ceph_13.2.2.bb30
2 files changed, 58 insertions, 8 deletions
diff --git a/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch b/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch
new file mode 100644
index 00000000..875501bf
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch
@@ -0,0 +1,36 @@
1From 6aaf04036f0affbeddda123bff111990c4d5fd72 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Fri, 26 Oct 2018 14:31:10 +0800
4Subject: [PATCH] ceph-detect-init: correct the installation for OE
5
6Signed-off-by: Dengke Du <dengke.du@windriver.com>
7Upstream-Status: Inappropriate [oe specific]
8---
9 cmake/modules/Distutils.cmake | 11 ++---------
10 1 file changed, 2 insertions(+), 9 deletions(-)
11
12diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake
13index 3091d97..c50fe77 100644
14--- a/cmake/modules/Distutils.cmake
15+++ b/cmake/modules/Distutils.cmake
16@@ -16,15 +16,8 @@ function(distutils_install_module name)
17 cmake_parse_arguments(DU "" INSTALL_SCRIPT "" ${ARGN})
18 install(CODE "
19 set(options --prefix=${CMAKE_INSTALL_PREFIX})
20- if(DEFINED ENV{DESTDIR})
21- if(EXISTS /etc/debian_version)
22- list(APPEND options --install-layout=deb)
23- endif()
24- list(APPEND options --root=\$ENV{DESTDIR})
25- if(NOT \"${DU_INSTALL_SCRIPT}\" STREQUAL \"\")
26- list(APPEND options --install-script=${DU_INSTALL_SCRIPT})
27- endif()
28- endif()
29+ list(APPEND options --root=${CMAKE_DESTDIR})
30+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
31 execute_process(
32 COMMAND ${PYTHON${PYTHON_VERSION}_EXECUTABLE}
33 setup.py install \${options}
34--
352.7.4
36
diff --git a/recipes-extended/ceph/ceph_13.2.2.bb b/recipes-extended/ceph/ceph_13.2.2.bb
index 6c6da41b..3d9faae3 100644
--- a/recipes-extended/ceph/ceph_13.2.2.bb
+++ b/recipes-extended/ceph/ceph_13.2.2.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
12 file://0001-Correct-the-path-to-find-version.h-in-rocksdb.patch \ 12 file://0001-Correct-the-path-to-find-version.h-in-rocksdb.patch \
13 file://0001-zstd-fix-error-for-cross-compile.patch \ 13 file://0001-zstd-fix-error-for-cross-compile.patch \
14 file://0001-ceph-add-pybind-support-in-OE.patch \ 14 file://0001-ceph-add-pybind-support-in-OE.patch \
15 file://0001-ceph-detect-init-correct-the-installation-for-OE.patch \
15 file://ceph.conf \ 16 file://ceph.conf \
16" 17"
17SRC_URI[md5sum] = "ce118be451dcb6b89e9e0a45057827dd" 18SRC_URI[md5sum] = "ce118be451dcb6b89e9e0a45057827dd"
@@ -24,12 +25,25 @@ DEPENDS = "boost bzip2 curl expat gperf-native \
24 python python-cython-native rocksdb snappy udev \ 25 python python-cython-native rocksdb snappy udev \
25 valgrind xfsprogs zlib \ 26 valgrind xfsprogs zlib \
26" 27"
27SYSTEMD_SERVICE_${PN} = "ceph-radosgw@.service \ 28SYSTEMD_SERVICE_${PN} = " \
29 ceph-radosgw@.service \
30 ceph-radosgw.target \
28 ceph-mon@.service \ 31 ceph-mon@.service \
32 ceph-mon.target \
29 ceph-mds@.service \ 33 ceph-mds@.service \
34 ceph-mds.target \
30 ceph-disk@.service \ 35 ceph-disk@.service \
31 ceph-osd@.service \ 36 ceph-osd@.service \
37 ceph-osd.target \
32 ceph.target \ 38 ceph.target \
39 ceph-fuse@.service \
40 ceph-fuse.target \
41 ceph-rbd-mirror@.service \
42 ceph-rbd-mirror.target \
43 ceph-volume@.service \
44 ceph-mgr@.service \
45 ceph-mgr.target \
46 rbdmap.service \
33" 47"
34OECMAKE_GENERATOR = "Unix Makefiles" 48OECMAKE_GENERATOR = "Unix Makefiles"
35 49
@@ -54,15 +68,15 @@ do_configure_prepend () {
54 68
55do_install_append () { 69do_install_append () {
56 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph 70 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph
71 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph-disk
72 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph-detect-init
73 find ${D} -name SOURCES.txt | xargs sed -i -e 's:${WORKDIR}::'
57 install -d ${D}${sysconfdir}/ceph 74 install -d ${D}${sysconfdir}/ceph
58 install -m 644 ${WORKDIR}/ceph.conf ${D}${sysconfdir}/ceph/ 75 install -m 644 ${WORKDIR}/ceph.conf ${D}${sysconfdir}/ceph/
59 install -d ${D}${systemd_unitdir}/system 76 install -d ${D}${systemd_unitdir}
60 mv ${D}${libexecdir}/systemd/system/ceph-radosgw@.service ${D}${systemd_unitdir}/system/ceph-radosgw@.service 77 mv ${D}${libexecdir}/systemd/system ${D}${systemd_unitdir}
61 mv ${D}${libexecdir}/systemd/system/ceph-mon@.service ${D}${systemd_unitdir}/system/ceph-mon@.service 78 mv ${D}${libexecdir}/ceph/ceph-osd-prestart.sh ${D}${libdir}/ceph
62 mv ${D}${libexecdir}/systemd/system/ceph-mds@.service ${D}${systemd_unitdir}/system/ceph-mds@.service 79 mv ${D}${libexecdir}/ceph/ceph_common.sh ${D}${libdir}/ceph
63 mv ${D}${libexecdir}/systemd/system/ceph-disk@.service ${D}${systemd_unitdir}/system/ceph-disk@.service
64 mv ${D}${libexecdir}/systemd/system/ceph-osd@.service ${D}${systemd_unitdir}/system/ceph-osd@.service
65 mv ${D}${libexecdir}/systemd/system/ceph.target ${D}${systemd_unitdir}/system/ceph.target
66} 80}
67 81
68FILES_${PN} += "\ 82FILES_${PN} += "\