summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch')
-rw-r--r--recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch b/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch
new file mode 100644
index 00000000..875501bf
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-ceph-detect-init-correct-the-installation-for-OE.patch
@@ -0,0 +1,36 @@
1From 6aaf04036f0affbeddda123bff111990c4d5fd72 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Fri, 26 Oct 2018 14:31:10 +0800
4Subject: [PATCH] ceph-detect-init: correct the installation for OE
5
6Signed-off-by: Dengke Du <dengke.du@windriver.com>
7Upstream-Status: Inappropriate [oe specific]
8---
9 cmake/modules/Distutils.cmake | 11 ++---------
10 1 file changed, 2 insertions(+), 9 deletions(-)
11
12diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake
13index 3091d97..c50fe77 100644
14--- a/cmake/modules/Distutils.cmake
15+++ b/cmake/modules/Distutils.cmake
16@@ -16,15 +16,8 @@ function(distutils_install_module name)
17 cmake_parse_arguments(DU "" INSTALL_SCRIPT "" ${ARGN})
18 install(CODE "
19 set(options --prefix=${CMAKE_INSTALL_PREFIX})
20- if(DEFINED ENV{DESTDIR})
21- if(EXISTS /etc/debian_version)
22- list(APPEND options --install-layout=deb)
23- endif()
24- list(APPEND options --root=\$ENV{DESTDIR})
25- if(NOT \"${DU_INSTALL_SCRIPT}\" STREQUAL \"\")
26- list(APPEND options --install-script=${DU_INSTALL_SCRIPT})
27- endif()
28- endif()
29+ list(APPEND options --root=${CMAKE_DESTDIR})
30+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
31 execute_process(
32 COMMAND ${PYTHON${PYTHON_VERSION}_EXECUTABLE}
33 setup.py install \${options}
34--
352.7.4
36