summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-11-02 21:18:15 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-05 10:22:54 -0500
commit100fb480e7fa7646682891307a9091e07e7981cd (patch)
tree85f2fc112cb377bb24bb86d08bf1ce6e2adefa80
parent86db36879f50ae0a0e1e3d4a2ee3385d2e6dea1d (diff)
downloadmeta-virtualization-100fb480e7fa7646682891307a9091e07e7981cd.tar.gz
runc: refresh to tip of tree
docker/k8s and other components have been refreshed to the 18.09 release tags. So we update runc to keep in sync. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-docker/0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch19
-rw-r--r--recipes-containers/runc/runc-docker_git.bb2
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb2
3 files changed, 9 insertions, 14 deletions
diff --git a/recipes-containers/runc/runc-docker/0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch b/recipes-containers/runc/runc-docker/0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch
index f885aaf7..faeac46f 100644
--- a/recipes-containers/runc/runc-docker/0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch
+++ b/recipes-containers/runc/runc-docker/0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch
@@ -8,20 +8,15 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
8 Makefile | 3 +-- 8 Makefile | 3 +--
9 1 file changed, 1 insertion(+), 2 deletions(-) 9 1 file changed, 1 insertion(+), 2 deletions(-)
10 10
11diff --git a/src/import/Makefile b/src/import/Makefile 11Index: git/src/import/Makefile
12index c6de11d..0e9bddb 100644 12===================================================================
13--- a/src/import/Makefile 13--- git.orig/src/import/Makefile
14+++ b/src/import/Makefile 14+++ git/src/import/Makefile
15@@ -39,8 +39,7 @@ contrib/cmd/recvtty/recvtty: $(SOURCES) 15@@ -41,7 +41,6 @@
16 $(GO) build -buildmode=pie $(EXTRA_FLAGS) -ldflags "-X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -tags "$(BUILDTAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
17 16
18 static: $(SOURCES) 17 static: $(SOURCES)
19- CGO_ENABLED=1 $(GO) build $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo cgo static_build" -installsuffix netgo -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o runc . 18 CGO_ENABLED=1 $(GO) build $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo cgo static_build" -installsuffix netgo -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o runc .
20- CGO_ENABLED=1 $(GO) build $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo cgo static_build" -installsuffix netgo -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty 19- CGO_ENABLED=1 $(GO) build $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo cgo static_build" -installsuffix netgo -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
21+ CGO_ENABLED=1 $(GO) build -tags "$(BUILDTAGS) netgo cgo static_build" -installsuffix netgo -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" $(GOBUILDFLAGS) -o runc .
22 20
23 release: 21 release:
24 script/release.sh -r release/$(VERSION) -v $(VERSION) 22 script/release.sh -r release/$(VERSION) -v $(VERSION)
25--
262.7.4
27
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index 81e5a5d4..02bda318 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -2,7 +2,7 @@ include runc.inc
2 2
3# Note: this rev is before the required protocol field, update when all components 3# Note: this rev is before the required protocol field, update when all components
4# have been updated to match. 4# have been updated to match.
5SRCREV_runc-docker = "4fc53a81fb7c994640722ac585fa9ca548971871" 5SRCREV_runc-docker = "6a2c15596845f6ff5182e2022f38a65e5dfa88eb"
6SRC_URI = "git://github.com/opencontainers/runc;nobranch=1;name=runc-docker \ 6SRC_URI = "git://github.com/opencontainers/runc;nobranch=1;name=runc-docker \
7 file://0001-runc-Add-console-socket-dev-null.patch \ 7 file://0001-runc-Add-console-socket-dev-null.patch \
8 file://0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch \ 8 file://0001-build-drop-recvtty-and-use-GOBUILDFLAGS.patch \
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index ed48abf6..eaee8efa 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -1,6 +1,6 @@
1include runc.inc 1include runc.inc
2 2
3SRCREV = "58415b4b12650291f435db8770cea48207b78afe" 3SRCREV = "6a2c15596845f6ff5182e2022f38a65e5dfa88eb"
4SRC_URI = " \ 4SRC_URI = " \
5 git://github.com/opencontainers/runc;branch=master \ 5 git://github.com/opencontainers/runc;branch=master \
6 " 6 "