summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/demo-network-config')
-rw-r--r--recipes-test/demo-network-config/network-config.inc4
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb2
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-test/demo-network-config/network-config.inc b/recipes-test/demo-network-config/network-config.inc
index b023f51..919d4ab 100644
--- a/recipes-test/demo-network-config/network-config.inc
+++ b/recipes-test/demo-network-config/network-config.inc
@@ -1,4 +1,4 @@
1SRC_URI_append = "\ 1SRC_URI:append = "\
2 file://26-${CONF_TYPE}-client.network \ 2 file://26-${CONF_TYPE}-client.network \
3 " 3 "
4 4
@@ -7,7 +7,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
8SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}" 8SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}"
9 9
10do_install_append() { 10do_install:append() {
11 bbnote "Network configuration type to be applied: ${CONF_TYPE}" 11 bbnote "Network configuration type to be applied: ${CONF_TYPE}"
12 install -d ${D}${libdir}/systemd/network 12 install -d ${D}${libdir}/systemd/network
13 install -m 0644 ${WORKDIR}/26-${CONF_TYPE}-client.network ${D}${libdir}/systemd/network/ 13 install -m 0644 ${WORKDIR}/26-${CONF_TYPE}-client.network ${D}${libdir}/systemd/network/
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 7ee873f..253bd48 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -6,7 +6,7 @@ SRC_URI = "\
6 file://27-dhcp-client-external.network \ 6 file://27-dhcp-client-external.network \
7 " 7 "
8 8
9FILES_${PN} = "${libdir}/systemd/network" 9FILES:${PN} = "${libdir}/systemd/network"
10 10
11PR = "1" 11PR = "1"
12 12
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index b268cd3..a688fdf 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -10,7 +10,7 @@ SRC_URI = "\
10 file://27-dhcp-client-external.network \ 10 file://27-dhcp-client-external.network \
11 " 11 "
12 12
13FILES_${PN} = "${libdir}/systemd/network" 13FILES:${PN} = "${libdir}/systemd/network"
14 14
15PR = "1" 15PR = "1"
16 16