summaryrefslogtreecommitdiffstats
path: root/recipes-test
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test')
-rw-r--r--recipes-test/big-update/big-update_1.0.bb2
-rw-r--r--recipes-test/big-update/big-update_2.0.bb2
-rw-r--r--recipes-test/demo-config/primary-config.bb2
-rw-r--r--recipes-test/demo-config/secondary-config.bb2
-rw-r--r--recipes-test/demo-network-config/network-config.inc4
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb2
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb2
-rw-r--r--recipes-test/images/primary-image.bb4
-rw-r--r--recipes-test/images/secondary-image.bb4
9 files changed, 12 insertions, 12 deletions
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
index dfb3a96..3bfff1f 100644
--- a/recipes-test/big-update/big-update_1.0.bb
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -3,7 +3,7 @@ LICENSE = "MPL-2.0"
3 3
4SRC_URI = "file://rand_file.py" 4SRC_URI = "file://rand_file.py"
5 5
6FILES_${PN} = "/usr/lib/big-update" 6FILES:${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 690e62c..d681034 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
4 4
5SRC_URI = "file://rand_file.py" 5SRC_URI = "file://rand_file.py"
6 6
7FILES_${PN} = "${libdir}/big-update" 7FILES:${PN} = "${libdir}/big-update"
8 8
9DEPENDS = "coreutils-native" 9DEPENDS = "coreutils-native"
10 10
diff --git a/recipes-test/demo-config/primary-config.bb b/recipes-test/demo-config/primary-config.bb
index 5c8abb5..603437a 100644
--- a/recipes-test/demo-config/primary-config.bb
+++ b/recipes-test/demo-config/primary-config.bb
@@ -63,7 +63,7 @@ do_install () {
63 sed -i "s|@CFG_FILEPATH@|$SECONDARY_CONFIG_FILEPATH_ON_IMAGE|g" ${D}${libdir}/sota/conf.d/30-secondary-config.toml 63 sed -i "s|@CFG_FILEPATH@|$SECONDARY_CONFIG_FILEPATH_ON_IMAGE|g" ${D}${libdir}/sota/conf.d/30-secondary-config.toml
64} 64}
65 65
66FILES_${PN} = " \ 66FILES:${PN} = " \
67 ${libdir}/sota/conf.d/* \ 67 ${libdir}/sota/conf.d/* \
68 ${sysconfdir}/sota/ecus/* \ 68 ${sysconfdir}/sota/ecus/* \
69 " 69 "
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb
index 638f0ae..a0e5d50 100644
--- a/recipes-test/demo-config/secondary-config.bb
+++ b/recipes-test/demo-config/secondary-config.bb
@@ -50,7 +50,7 @@ do_install () {
50 50
51} 51}
52 52
53FILES_${PN} = " \ 53FILES:${PN} = " \
54 ${libdir}/sota/conf.d \ 54 ${libdir}/sota/conf.d \
55 ${libdir}/sota/conf.d/30-pacman-config.toml \ 55 ${libdir}/sota/conf.d/30-pacman-config.toml \
56 ${libdir}/sota/conf.d/35-network-config.toml \ 56 ${libdir}/sota/conf.d/35-network-config.toml \
diff --git a/recipes-test/demo-network-config/network-config.inc b/recipes-test/demo-network-config/network-config.inc
index b023f51..919d4ab 100644
--- a/recipes-test/demo-network-config/network-config.inc
+++ b/recipes-test/demo-network-config/network-config.inc
@@ -1,4 +1,4 @@
1SRC_URI_append = "\ 1SRC_URI:append = "\
2 file://26-${CONF_TYPE}-client.network \ 2 file://26-${CONF_TYPE}-client.network \
3 " 3 "
4 4
@@ -7,7 +7,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
8SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}" 8SECONDARY_INTERFACE ?= "${@ 'eth0' if d.getVar('MACHINE') == 'raspberrypi3' else 'enp0s5'}"
9 9
10do_install_append() { 10do_install:append() {
11 bbnote "Network configuration type to be applied: ${CONF_TYPE}" 11 bbnote "Network configuration type to be applied: ${CONF_TYPE}"
12 install -d ${D}${libdir}/systemd/network 12 install -d ${D}${libdir}/systemd/network
13 install -m 0644 ${WORKDIR}/26-${CONF_TYPE}-client.network ${D}${libdir}/systemd/network/ 13 install -m 0644 ${WORKDIR}/26-${CONF_TYPE}-client.network ${D}${libdir}/systemd/network/
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 7ee873f..253bd48 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -6,7 +6,7 @@ SRC_URI = "\
6 file://27-dhcp-client-external.network \ 6 file://27-dhcp-client-external.network \
7 " 7 "
8 8
9FILES_${PN} = "${libdir}/systemd/network" 9FILES:${PN} = "${libdir}/systemd/network"
10 10
11PR = "1" 11PR = "1"
12 12
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index b268cd3..a688fdf 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -10,7 +10,7 @@ SRC_URI = "\
10 file://27-dhcp-client-external.network \ 10 file://27-dhcp-client-external.network \
11 " 11 "
12 12
13FILES_${PN} = "${libdir}/systemd/network" 13FILES:${PN} = "${libdir}/systemd/network"
14 14
15PR = "1" 15PR = "1"
16 16
diff --git a/recipes-test/images/primary-image.bb b/recipes-test/images/primary-image.bb
index e6896ea..45cf68c 100644
--- a/recipes-test/images/primary-image.bb
+++ b/recipes-test/images/primary-image.bb
@@ -4,11 +4,11 @@ SUMMARY = "A minimal Uptane Primary image running aktualizr, for testing with a
4 4
5LICENSE = "MPL-2.0" 5LICENSE = "MPL-2.0"
6 6
7IMAGE_INSTALL_remove = " \ 7IMAGE_INSTALL:remove = " \
8 network-configuration \ 8 network-configuration \
9 " 9 "
10 10
11IMAGE_INSTALL_append = " \ 11IMAGE_INSTALL:append = " \
12 primary-network-config \ 12 primary-network-config \
13 primary-config \ 13 primary-config \
14 " 14 "
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 22fb7f3..95e09cf 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -9,7 +9,7 @@ SOTA_HARDWARE_ID ?= "${MACHINE}-sndry"
9 9
10# Remove default aktualizr primary, and the provisioning configuration (which 10# Remove default aktualizr primary, and the provisioning configuration (which
11# RDEPENDS on aktualizr) 11# RDEPENDS on aktualizr)
12IMAGE_INSTALL_remove = " \ 12IMAGE_INSTALL:remove = " \
13 aktualizr \ 13 aktualizr \
14 aktualizr-shared-prov \ 14 aktualizr-shared-prov \
15 aktualizr-shared-prov-creds \ 15 aktualizr-shared-prov-creds \
@@ -19,7 +19,7 @@ IMAGE_INSTALL_remove = " \
19 network-configuration \ 19 network-configuration \
20 " 20 "
21 21
22IMAGE_INSTALL_append = " \ 22IMAGE_INSTALL:append = " \
23 aktualizr-secondary \ 23 aktualizr-secondary \
24 secondary-network-config \ 24 secondary-network-config \
25 secondary-config \ 25 secondary-config \