summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/fuse/fuse_%.bbappend4
-rw-r--r--recipes-support/slcand-start/slcand-start.bb6
-rw-r--r--recipes-support/softhsm-testtoken/softhsm-testtoken.bb8
-rw-r--r--recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb4
4 files changed, 11 insertions, 11 deletions
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend
index 85bdf50..fa8f632 100644
--- a/recipes-support/fuse/fuse_%.bbappend
+++ b/recipes-support/fuse/fuse_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND:append:sota = " native"
2 2
3PACKAGES_append_class-native_sota = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native', ' ', d)}" 3PACKAGES:append:class-native:sota = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native', ' ', d)}"
diff --git a/recipes-support/slcand-start/slcand-start.bb b/recipes-support/slcand-start/slcand-start.bb
index 566507b..5f38c39 100644
--- a/recipes-support/slcand-start/slcand-start.bb
+++ b/recipes-support/slcand-start/slcand-start.bb
@@ -4,16 +4,16 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit systemd 5inherit systemd
6 6
7RDEPENDS_${PN} = "can-utils" 7RDEPENDS:${PN} = "can-utils"
8 8
9SRC_URI = "file://slcand@.service" 9SRC_URI = "file://slcand@.service"
10 10
11SYSTEMD_SERVICE_${PN} = "slcand@.service" 11SYSTEMD_SERVICE:${PN} = "slcand@.service"
12 12
13do_install() { 13do_install() {
14 install -d ${D}${systemd_unitdir}/system 14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_unitdir}/system/slcand@.service 15 install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_unitdir}/system/slcand@.service
16} 16}
17 17
18FILES_${PN} = "${systemd_unitdir}/system/createtoken.service" 18FILES:${PN} = "${systemd_unitdir}/system/createtoken.service"
19 19
diff --git a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
index 68514b2..48fa2d1 100644
--- a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
+++ b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
@@ -4,14 +4,14 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit systemd 5inherit systemd
6 6
7RDEPENDS_${PN} = "softhsm libp11 opensc openssl-bin" 7RDEPENDS:${PN} = "softhsm libp11 opensc openssl-bin"
8DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 8DEPENDS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
9 9
10 10
11SRC_URI = "file://createtoken.service \ 11SRC_URI = "file://createtoken.service \
12 file://createtoken.sh" 12 file://createtoken.sh"
13 13
14SYSTEMD_SERVICE_${PN} = "createtoken.service" 14SYSTEMD_SERVICE:${PN} = "createtoken.service"
15 15
16do_install() { 16do_install() {
17 install -d ${D}${systemd_unitdir}/system 17 install -d ${D}${systemd_unitdir}/system
@@ -20,6 +20,6 @@ do_install() {
20 install -m 0744 ${WORKDIR}/createtoken.sh ${D}${bindir}/createtoken.sh 20 install -m 0744 ${WORKDIR}/createtoken.sh ${D}${bindir}/createtoken.sh
21} 21}
22 22
23FILES_${PN} = "${bindir}/createtoken.sh \ 23FILES:${PN} = "${bindir}/createtoken.sh \
24 ${systemd_unitdir}/system/createtoken.service" 24 ${systemd_unitdir}/system/createtoken.service"
25 25
diff --git a/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
index 1715fe1..7f2a3ae 100644
--- a/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
+++ b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7
6 6
7PACKAGE_ARCH = "${MACHINE_ARCH}" 7PACKAGE_ARCH = "${MACHINE_ARCH}"
8 8
9SRC_URI_append = " file://10-persistent-journal.conf" 9SRC_URI:append = " file://10-persistent-journal.conf"
10PR = "r1" 10PR = "r1"
11 11
12S = "${WORKDIR}" 12S = "${WORKDIR}"
13 13
14FILES_${PN} = "${systemd_unitdir}/journald.conf.d/*" 14FILES:${PN} = "${systemd_unitdir}/journald.conf.d/*"
15 15
16do_install() { 16do_install() {
17 install -d ${D}/${systemd_unitdir}/journald.conf.d 17 install -d ${D}/${systemd_unitdir}/journald.conf.d