summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatti Vacek <pattivacek@gmail.com>2021-04-06 11:19:14 +0200
committerGitHub <noreply@github.com>2021-04-06 11:19:14 +0200
commit18729ac787c1c4ba8cdee0a3bf077fc39d074107 (patch)
tree1a3d368f2cf2f1a2de9b00eecd9b59772e2da034
parenta8aaf6fa741ebce0daa54838abad933505fb325b (diff)
parent76ab8b04f25ad20a89fb28b4608ce78a8a271495 (diff)
downloadmeta-updater-18729ac787c1c4ba8cdee0a3bf077fc39d074107.tar.gz
Merge pull request #805 from shr-project/jansa/fixes
Fix big-update recipe
-rw-r--r--recipes-test/big-update/big-update_2.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 6fffbc1..690e62c 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -1,15 +1,16 @@
1DESCRIPTION = "Example Package with 12MB of random, seeded content" 1DESCRIPTION = "Example Package with 12MB of random, seeded content"
2LICENSE = "MPL-2.0" 2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
3 4
4SRC_URI = "file://rand_file.py" 5SRC_URI = "file://rand_file.py"
5 6
6FILES_${PN} = "/usr/lib/big-update" 7FILES_${PN} = "${libdir}/big-update"
7 8
8DEPENDS = "coreutils-native" 9DEPENDS = "coreutils-native"
9 10
10inherit python3native 11inherit python3native
11 12
12do_install() { 13do_install() {
13 install -d ${D}/usr/lib/big-update 14 install -d ${D}${libdir}/big-update
14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 15 python3 ${S}/../rand_file.py ${D}${libdir}/big-update/a-big-file $(numfmt --from=iec 12M)
15} 16}