summaryrefslogtreecommitdiffstats
path: root/recipes-test/big-update/big-update_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/big-update/big-update_2.0.bb')
-rw-r--r--recipes-test/big-update/big-update_2.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 6fffbc1..690e62c 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -1,15 +1,16 @@
1DESCRIPTION = "Example Package with 12MB of random, seeded content" 1DESCRIPTION = "Example Package with 12MB of random, seeded content"
2LICENSE = "MPL-2.0" 2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
3 4
4SRC_URI = "file://rand_file.py" 5SRC_URI = "file://rand_file.py"
5 6
6FILES_${PN} = "/usr/lib/big-update" 7FILES_${PN} = "${libdir}/big-update"
7 8
8DEPENDS = "coreutils-native" 9DEPENDS = "coreutils-native"
9 10
10inherit python3native 11inherit python3native
11 12
12do_install() { 13do_install() {
13 install -d ${D}/usr/lib/big-update 14 install -d ${D}${libdir}/big-update
14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 15 python3 ${S}/../rand_file.py ${D}${libdir}/big-update/a-big-file $(numfmt --from=iec 12M)
15} 16}