summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-10-25 15:21:20 -0300
committerRicardo Salveti <ricardo@foundries.io>2019-11-06 12:59:45 -0300
commit9bca3262df0c162d210ae036bb20899da3685f5d (patch)
tree4eaa6e325dc99186cacdef546014dfc82e41ead3
parenta32ce447337da7eb306e0e38effa778edd72450e (diff)
downloadmeta-updater-ostree.tar.gz
Drop ostree_git in favor of the ostree recipe from meta-oe.ostree
A newer ostree recipe is now provided via the meta-oe layer, so drop local ostree_git recipe in favor of the latest one from meta-oe. Local bbappend created to enable curl, libarchive and ostree-grub-generator, which were all enabled by default in ostree_git, besides disabling soup as that is not really needed with curl (and wasn't previously enabled). Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
-rw-r--r--recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch60
-rw-r--r--recipes-extended/ostree/ostree_%.bbappend18
-rw-r--r--recipes-sota/ostree/ostree_git.bb69
3 files changed, 78 insertions, 69 deletions
diff --git a/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch b/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
new file mode 100644
index 0000000..1f8a06b
--- /dev/null
+++ b/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch
@@ -0,0 +1,60 @@
1From de8e0765a4a54f0367999f682ce4cc53bfaa60b0 Mon Sep 17 00:00:00 2001
2From: Ricardo Salveti <ricardo@foundries.io>
3Date: Tue, 5 Nov 2019 21:16:07 -0300
4Subject: [PATCH] Makefile: declare ostree_boot_SCRIPTS and append values
5
6ostree_boot_SCRIPTS was being set on both Makefile-boot.am and
7Makefile-switchroot.am, causing the first one to be replaced by the
8other at the final Makefile, so declare as empty and append on both
9places instead.
10
11Upstream-Status: Backport
12
13Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
14---
15 Makefile-boot.am | 2 +-
16 Makefile-decls.am | 1 +
17 Makefile-switchroot.am | 2 +-
18 3 files changed, 3 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile-boot.am b/Makefile-boot.am
21index b4d4a1af..b51928f0 100644
22--- a/Makefile-boot.am
23+++ b/Makefile-boot.am
24@@ -60,7 +60,7 @@ grub2configdir = $(sysconfdir)/grub.d
25 INSTALL_DATA_HOOKS += install-grub2-config-hook
26 else
27 # We're using our internal generator
28-ostree_boot_SCRIPTS = src/boot/grub2/ostree-grub-generator
29+ostree_boot_SCRIPTS += src/boot/grub2/ostree-grub-generator
30 endif
31
32 EXTRA_DIST += src/boot/dracut/module-setup.sh \
33diff --git a/Makefile-decls.am b/Makefile-decls.am
34index 115c19fb..086ee138 100644
35--- a/Makefile-decls.am
36+++ b/Makefile-decls.am
37@@ -47,6 +47,7 @@ typelibdir = $(libdir)/girepository-1.0
38 typelib_DATA =
39 gsettings_SCHEMAS =
40 ostree_bootdir = $(prefix)/lib/ostree
41+ostree_boot_SCRIPTS =
42 ostree_boot_PROGRAMS =
43
44 # This initializes some more variables
45diff --git a/Makefile-switchroot.am b/Makefile-switchroot.am
46index ff44d4bc..b81b843f 100644
47--- a/Makefile-switchroot.am
48+++ b/Makefile-switchroot.am
49@@ -42,7 +42,7 @@ if BUILDOPT_USE_STATIC_COMPILER
50 # to get autotools to install this as an executable but without generating rules
51 # to make it itself which we have specified manually. See
52 # https://lists.gnu.org/archive/html/help-gnu-utils/2007-01/msg00007.html
53-ostree_boot_SCRIPTS = ostree-prepare-root
54+ostree_boot_SCRIPTS += ostree-prepare-root
55
56 ostree-prepare-root : $(ostree_prepare_root_SOURCES)
57 $(STATIC_COMPILER) -o $@ -static $(top_srcdir)/src/switchroot/ostree-prepare-root.c $(ostree_prepare_root_CPPFLAGS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) -DOSTREE_PREPARE_ROOT_STATIC=1
58--
592.24.0
60
diff --git a/recipes-extended/ostree/ostree_%.bbappend b/recipes-extended/ostree/ostree_%.bbappend
new file mode 100644
index 0000000..cf2f24f
--- /dev/null
+++ b/recipes-extended/ostree/ostree_%.bbappend
@@ -0,0 +1,18 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch \
5"
6
7PACKAGECONFIG_append = " curl libarchive static"
8PACKAGECONFIG_class-native_append = " curl"
9PACKAGECONFIG_remove = "soup"
10PACKAGECONFIG_class-native_remove = "soup"
11
12EXTRA_OECONF += " \
13 --with-builtin-grub2-mkconfig \
14"
15
16FILES_${PN} += " \
17 ${libdir}/ostree/ostree-grub-generator \
18"
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
deleted file mode 100644
index 93ae6e7..0000000
--- a/recipes-sota/ostree/ostree_git.bb
+++ /dev/null
@@ -1,69 +0,0 @@
1SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2HOMEPAGE = "https://ostree.readthedocs.io/en/latest/"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5
6inherit autotools pkgconfig systemd bash-completion gobject-introspection
7
8SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
9
10SRCREV = "f3eba6bcec39c163eb831c02c148ffa483292906"
11
12PV = "v2018.9"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme fuse e2fsprogs curl xz"
19DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
20RDEPENDS_${PN}-dracut = "bash"
21
22CFLAGS_append = " -Wno-error=missing-prototypes"
23EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup"
24EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
28
29# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
30# do_configure stage so we do depend on it
31SYSROOT_DIR = "${STAGING_DIR_TARGET}"
32SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
33do_configure[vardeps] += "SYSROOT_DIR"
34
35SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service ostree-finalize-staged.service"
36
37export BUILD_SYS
38export HOST_SYS
39export STAGING_INCDIR
40export STAGING_LIBDIR
41
42do_configure_prepend() {
43 unset docdir
44 NOCONFIGURE=1 "${S}/autogen.sh"
45}
46
47do_install_append_class-native() {
48 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
49}
50
51PACKAGES += " \
52 ${PN}-switchroot \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \
54"
55
56FILES_${PN} = "${bindir} \
57 ${sysconfdir}/ostree \
58 ${datadir}/ostree \
59 ${libdir}/*.so.* \
60 ${libdir}/ostree/ostree-grub-generator \
61 ${libdir}/ostree/ostree-remount \
62 ${libdir}/girepository-1.0/* \
63 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \
64 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system/*.path', '', d)} \
65 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \
66"
67FILES_${PN}-dev += " ${datadir}/gir-1.0"
68FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut"
69FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"