summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb69
1 files changed, 0 insertions, 69 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
deleted file mode 100644
index 93ae6e7..0000000
--- a/recipes-sota/ostree/ostree_git.bb
+++ /dev/null
@@ -1,69 +0,0 @@
1SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2HOMEPAGE = "https://ostree.readthedocs.io/en/latest/"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5
6inherit autotools pkgconfig systemd bash-completion gobject-introspection
7
8SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
9
10SRCREV = "f3eba6bcec39c163eb831c02c148ffa483292906"
11
12PV = "v2018.9"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme fuse e2fsprogs curl xz"
19DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
20RDEPENDS_${PN}-dracut = "bash"
21
22CFLAGS_append = " -Wno-error=missing-prototypes"
23EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup"
24EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
28
29# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
30# do_configure stage so we do depend on it
31SYSROOT_DIR = "${STAGING_DIR_TARGET}"
32SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
33do_configure[vardeps] += "SYSROOT_DIR"
34
35SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service ostree-finalize-staged.service"
36
37export BUILD_SYS
38export HOST_SYS
39export STAGING_INCDIR
40export STAGING_LIBDIR
41
42do_configure_prepend() {
43 unset docdir
44 NOCONFIGURE=1 "${S}/autogen.sh"
45}
46
47do_install_append_class-native() {
48 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
49}
50
51PACKAGES += " \
52 ${PN}-switchroot \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \
54"
55
56FILES_${PN} = "${bindir} \
57 ${sysconfdir}/ostree \
58 ${datadir}/ostree \
59 ${libdir}/*.so.* \
60 ${libdir}/ostree/ostree-grub-generator \
61 ${libdir}/ostree/ostree-remount \
62 ${libdir}/girepository-1.0/* \
63 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \
64 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system/*.path', '', d)} \
65 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \
66"
67FILES_${PN}-dev += " ${datadir}/gir-1.0"
68FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut"
69FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"