summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUbuntu <ubuntu@ip-172-31-14-192.eu-central-1.compute.internal>2018-04-11 12:35:46 +0000
committerUbuntu <ubuntu@ip-172-31-14-192.eu-central-1.compute.internal>2018-04-11 12:35:46 +0000
commit5048bf8d2b9ecd070c9ed4e584f274f8ab6cfbfa (patch)
treed9c4057eefd28db1748a6469d01d1cc78a34cf7a
downloadmeta-updater-daisy.tar.gz
Initial commit of Daisy aktualizr builddaisy
-rw-r--r--conf/layer.conf10
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb110
-rw-r--r--recipes-sota/aktualizr/files/LICENSE373
-rw-r--r--recipes-sota/aktualizr/files/aktualizr-secondary.service9
-rw-r--r--recipes-sota/aktualizr/files/aktualizr-secondary.socket6
-rw-r--r--recipes-sota/aktualizr/files/aktualizr-serialcan.service15
-rw-r--r--recipes-sota/aktualizr/files/aktualizr.service15
-rw-r--r--recipes-sota/aktualizr/files/ca.cnf10
-rw-r--r--recipes-support/asn1c/asn1c.bb17
-rw-r--r--recipes-support/asn1c/files/skeletons_dir_fix.patch44
-rw-r--r--recipes-support/boost/bjam-native_1.57.0.bb15
-rw-r--r--recipes-support/boost/boost-1.57.0.inc19
-rw-r--r--recipes-support/boost/boost.inc184
-rw-r--r--recipes-support/boost/boost/arm-intrinsics.patch55
-rw-r--r--recipes-support/boost/boost_1.57.0.bb6
-rw-r--r--recipes-support/libsodium/libsodium_1.0.11.bb12
16 files changed, 900 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..7c3d0d8
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "updater"
9BBFILE_PATTERN_updater = "^${LAYERDIR}/"
10BBFILE_PRIORITY_updater = "6"
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
new file mode 100644
index 0000000..2209031
--- /dev/null
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -0,0 +1,110 @@
1SUMMARY = "Aktualizr SOTA Client"
2DESCRIPTION = "SOTA Client application written in C++"
3HOMEPAGE = "https://github.com/advancedtelematic/aktualizr"
4SECTION = "base"
5LICENSE = "MPL-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3"
7
8DEPENDS = "boost curl openssl libarchive libsodium asn1c-native "
9DEPENDS_append_class-target = "${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'hsm', ' libp11', '', d)} "
10#DEPENDS_append_class-target = "ostree ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'hsm', ' libp11', '', d)} "
11DEPENDS_append_class-native = "glib-2.0-native "
12
13RDEPENDS_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'serialcan', ' slcand-start', '', d)} "
14
15PV = "1.0+git${SRCPV}"
16PR = "9"
17
18SRC_URI = " \
19 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH} \
20 file://aktualizr.service \
21 file://aktualizr-secondary.service \
22 file://aktualizr-secondary.socket \
23 file://aktualizr-serialcan.service \
24 "
25
26SRCREV = "${AUTOREV}"
27BRANCH ?= "feat/daisy"
28
29S = "${WORKDIR}/git"
30
31inherit cmake
32
33inherit systemd
34
35SYSTEMD_PACKAGES = "${PN} ${PN}-secondary"
36SYSTEMD_SERVICE_${PN} = "aktualizr.service"
37SYSTEMD_SERVICE_${PN}-secondary = "aktualizr-secondary.socket"
38
39BBCLASSEXTEND =+ "native"
40
41EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DAKTUALIZR_VERSION=${PV} -DBUILD_SYSTEMD=OFF "
42EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'hsm', '-DBUILD_P11=ON', '', d)} "
43EXTRA_OECMAKE_append_class-native = " -DBUILD_SOTA_TOOLS=ON "
44
45do_install_append () {
46 rm -fr ${D}${libdir}/systemd
47 rm -f ${D}${libdir}/sota/sota.toml # Only needed for the Debian package
48 install -d ${D}${libdir}/sota
49 install -m 0644 ${S}/config/sota_secondary.toml ${D}/${libdir}/sota/sota_secondary.toml
50 install -d ${D}${systemd_unitdir}/system
51 install -m 0644 ${WORKDIR}/aktualizr-secondary.socket ${D}${systemd_unitdir}/system/aktualizr-secondary.socket
52 install -m 0644 ${WORKDIR}/aktualizr-secondary.service ${D}${systemd_unitdir}/system/aktualizr-secondary.service
53}
54
55do_install_append_class-target () {
56 install -d ${D}${systemd_unitdir}/system
57 aktualizr_service=${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'serialcan', '${WORKDIR}/aktualizr-serialcan.service', '${WORKDIR}/aktualizr.service', d)}
58 install -m 0644 ${aktualizr_service} ${D}${systemd_unitdir}/system/aktualizr.service
59}
60
61do_install_append_class-native () {
62 install -d ${D}${libdir}/sota
63 install -m 0644 ${S}/config/sota_autoprov.toml ${D}/${libdir}/sota/sota_autoprov.toml
64 install -m 0644 ${S}/config/sota_autoprov_primary.toml ${D}/${libdir}/sota/sota_autoprov_primary.toml
65 install -m 0644 ${S}/config/sota_hsm_prov.toml ${D}/${libdir}/sota/sota_hsm_prov.toml
66 install -m 0644 ${S}/config/sota_implicit_prov.toml ${D}/${libdir}/sota/sota_implicit_prov.toml
67 install -m 0644 ${S}/config/sota_implicit_prov_ca.toml ${D}/${libdir}/sota/sota_implicit_prov_ca.toml
68
69 install -m 0755 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/bin/* ${D}${bindir}
70 install -m 0644 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/lib/* ${D}${libdir}
71}
72
73PACKAGES =+ " ${PN}-common ${PN}-examples ${PN}-host-tools ${PN}-secondary "
74
75FILES_${PN} = " \
76 ${bindir}/aktualizr \
77 ${bindir}/aktualizr-info \
78 ${bindir}/aktualizr-check-discovery \
79 ${systemd_unitdir}/system/aktualizr.service \
80 "
81
82FILES_${PN}-common = " \
83 ${libdir}/sota/schemas \
84 "
85
86FILES_${PN}-examples = " \
87 ${libdir}/sota/demo_secondary.json \
88 ${bindir}/example-interface \
89 ${bindir}/isotp-test-interface \
90 "
91
92FILES_${PN}-host-tools = " \
93 ${bindir}/aktualizr_cert_provider \
94 ${bindir}/aktualizr_implicit_writer \
95 ${bindir}/garage-deploy \
96 ${bindir}/garage-push \
97 "
98
99FILES_${PN}-secondary = " \
100 ${bindir}/aktualizr-secondary \
101 ${libdir}/sota/sota_secondary.toml \
102 ${systemd_unitdir}/system/aktualizr-secondary.socket \
103 ${systemd_unitdir}/system/aktualizr-secondary.service \
104 "
105
106# Both primary and secondary need the SQL Schemas
107RDEPENDS_${PN}_class-target =+ "${PN}-common"
108RDEPENDS_${PN}-secondary_class-target =+ "${PN}-common"
109
110# vim:set ts=4 sw=4 sts=4 expandtab:
diff --git a/recipes-sota/aktualizr/files/LICENSE b/recipes-sota/aktualizr/files/LICENSE
new file mode 100644
index 0000000..a612ad9
--- /dev/null
+++ b/recipes-sota/aktualizr/files/LICENSE
@@ -0,0 +1,373 @@
1Mozilla Public License Version 2.0
2==================================
3
41. Definitions
5--------------
6
71.1. "Contributor"
8 means each individual or legal entity that creates, contributes to
9 the creation of, or owns Covered Software.
10
111.2. "Contributor Version"
12 means the combination of the Contributions of others (if any) used
13 by a Contributor and that particular Contributor's Contribution.
14
151.3. "Contribution"
16 means Covered Software of a particular Contributor.
17
181.4. "Covered Software"
19 means Source Code Form to which the initial Contributor has attached
20 the notice in Exhibit A, the Executable Form of such Source Code
21 Form, and Modifications of such Source Code Form, in each case
22 including portions thereof.
23
241.5. "Incompatible With Secondary Licenses"
25 means
26
27 (a) that the initial Contributor has attached the notice described
28 in Exhibit B to the Covered Software; or
29
30 (b) that the Covered Software was made available under the terms of
31 version 1.1 or earlier of the License, but not also under the
32 terms of a Secondary License.
33
341.6. "Executable Form"
35 means any form of the work other than Source Code Form.
36
371.7. "Larger Work"
38 means a work that combines Covered Software with other material, in
39 a separate file or files, that is not Covered Software.
40
411.8. "License"
42 means this document.
43
441.9. "Licensable"
45 means having the right to grant, to the maximum extent possible,
46 whether at the time of the initial grant or subsequently, any and
47 all of the rights conveyed by this License.
48
491.10. "Modifications"
50 means any of the following:
51
52 (a) any file in Source Code Form that results from an addition to,
53 deletion from, or modification of the contents of Covered
54 Software; or
55
56 (b) any new file in Source Code Form that contains any Covered
57 Software.
58
591.11. "Patent Claims" of a Contributor
60 means any patent claim(s), including without limitation, method,
61 process, and apparatus claims, in any patent Licensable by such
62 Contributor that would be infringed, but for the grant of the
63 License, by the making, using, selling, offering for sale, having
64 made, import, or transfer of either its Contributions or its
65 Contributor Version.
66
671.12. "Secondary License"
68 means either the GNU General Public License, Version 2.0, the GNU
69 Lesser General Public License, Version 2.1, the GNU Affero General
70 Public License, Version 3.0, or any later versions of those
71 licenses.
72
731.13. "Source Code Form"
74 means the form of the work preferred for making modifications.
75
761.14. "You" (or "Your")
77 means an individual or a legal entity exercising rights under this
78 License. For legal entities, "You" includes any entity that
79 controls, is controlled by, or is under common control with You. For
80 purposes of this definition, "control" means (a) the power, direct
81 or indirect, to cause the direction or management of such entity,
82 whether by contract or otherwise, or (b) ownership of more than
83 fifty percent (50%) of the outstanding shares or beneficial
84 ownership of such entity.
85
862. License Grants and Conditions
87--------------------------------
88
892.1. Grants
90
91Each Contributor hereby grants You a world-wide, royalty-free,
92non-exclusive license:
93
94(a) under intellectual property rights (other than patent or trademark)
95 Licensable by such Contributor to use, reproduce, make available,
96 modify, display, perform, distribute, and otherwise exploit its
97 Contributions, either on an unmodified basis, with Modifications, or
98 as part of a Larger Work; and
99
100(b) under Patent Claims of such Contributor to make, use, sell, offer
101 for sale, have made, import, and otherwise transfer either its
102 Contributions or its Contributor Version.
103
1042.2. Effective Date
105
106The licenses granted in Section 2.1 with respect to any Contribution
107become effective for each Contribution on the date the Contributor first
108distributes such Contribution.
109
1102.3. Limitations on Grant Scope
111
112The licenses granted in this Section 2 are the only rights granted under
113this License. No additional rights or licenses will be implied from the
114distribution or licensing of Covered Software under this License.
115Notwithstanding Section 2.1(b) above, no patent license is granted by a
116Contributor:
117
118(a) for any code that a Contributor has removed from Covered Software;
119 or
120
121(b) for infringements caused by: (i) Your and any other third party's
122 modifications of Covered Software, or (ii) the combination of its
123 Contributions with other software (except as part of its Contributor
124 Version); or
125
126(c) under Patent Claims infringed by Covered Software in the absence of
127 its Contributions.
128
129This License does not grant any rights in the trademarks, service marks,
130or logos of any Contributor (except as may be necessary to comply with
131the notice requirements in Section 3.4).
132
1332.4. Subsequent Licenses
134
135No Contributor makes additional grants as a result of Your choice to
136distribute the Covered Software under a subsequent version of this
137License (see Section 10.2) or under the terms of a Secondary License (if
138permitted under the terms of Section 3.3).
139
1402.5. Representation
141
142Each Contributor represents that the Contributor believes its
143Contributions are its original creation(s) or it has sufficient rights
144to grant the rights to its Contributions conveyed by this License.
145
1462.6. Fair Use
147
148This License is not intended to limit any rights You have under
149applicable copyright doctrines of fair use, fair dealing, or other
150equivalents.
151
1522.7. Conditions
153
154Sections 3.1, 3.2, 3.3, and 3.4 are conditions of the licenses granted
155in Section 2.1.
156
1573. Responsibilities
158-------------------
159
1603.1. Distribution of Source Form
161
162All distribution of Covered Software in Source Code Form, including any
163Modifications that You create or to which You contribute, must be under
164the terms of this License. You must inform recipients that the Source
165Code Form of the Covered Software is governed by the terms of this
166License, and how they can obtain a copy of this License. You may not
167attempt to alter or restrict the recipients' rights in the Source Code
168Form.
169
1703.2. Distribution of Executable Form
171
172If You distribute Covered Software in Executable Form then:
173
174(a) such Covered Software must also be made available in Source Code
175 Form, as described in Section 3.1, and You must inform recipients of
176 the Executable Form how they can obtain a copy of such Source Code
177 Form by reasonable means in a timely manner, at a charge no more
178 than the cost of distribution to the recipient; and
179
180(b) You may distribute such Executable Form under the terms of this
181 License, or sublicense it under different terms, provided that the
182 license for the Executable Form does not attempt to limit or alter
183 the recipients' rights in the Source Code Form under this License.
184
1853.3. Distribution of a Larger Work
186
187You may create and distribute a Larger Work under terms of Your choice,
188provided that You also comply with the requirements of this License for
189the Covered Software. If the Larger Work is a combination of Covered
190Software with a work governed by one or more Secondary Licenses, and the
191Covered Software is not Incompatible With Secondary Licenses, this
192License permits You to additionally distribute such Covered Software
193under the terms of such Secondary License(s), so that the recipient of
194the Larger Work may, at their option, further distribute the Covered
195Software under the terms of either this License or such Secondary
196License(s).
197
1983.4. Notices
199
200You may not remove or alter the substance of any license notices
201(including copyright notices, patent notices, disclaimers of warranty,
202or limitations of liability) contained within the Source Code Form of
203the Covered Software, except that You may alter any license notices to
204the extent required to remedy known factual inaccuracies.
205
2063.5. Application of Additional Terms
207
208You may choose to offer, and to charge a fee for, warranty, support,
209indemnity or liability obligations to one or more recipients of Covered
210Software. However, You may do so only on Your own behalf, and not on
211behalf of any Contributor. You must make it absolutely clear that any
212such warranty, support, indemnity, or liability obligation is offered by
213You alone, and You hereby agree to indemnify every Contributor for any
214liability incurred by such Contributor as a result of warranty, support,
215indemnity or liability terms You offer. You may include additional
216disclaimers of warranty and limitations of liability specific to any
217jurisdiction.
218
2194. Inability to Comply Due to Statute or Regulation
220---------------------------------------------------
221
222If it is impossible for You to comply with any of the terms of this
223License with respect to some or all of the Covered Software due to
224statute, judicial order, or regulation then You must: (a) comply with
225the terms of this License to the maximum extent possible; and (b)
226describe the limitations and the code they affect. Such description must
227be placed in a text file included with all distributions of the Covered
228Software under this License. Except to the extent prohibited by statute
229or regulation, such description must be sufficiently detailed for a
230recipient of ordinary skill to be able to understand it.
231
2325. Termination
233--------------
234
2355.1. The rights granted under this License will terminate automatically
236if You fail to comply with any of its terms. However, if You become
237compliant, then the rights granted under this License from a particular
238Contributor are reinstated (a) provisionally, unless and until such
239Contributor explicitly and finally terminates Your grants, and (b) on an
240ongoing basis, if such Contributor fails to notify You of the
241non-compliance by some reasonable means prior to 60 days after You have
242come back into compliance. Moreover, Your grants from a particular
243Contributor are reinstated on an ongoing basis if such Contributor
244notifies You of the non-compliance by some reasonable means, this is the
245first time You have received notice of non-compliance with this License
246from such Contributor, and You become compliant prior to 30 days after
247Your receipt of the notice.
248
2495.2. If You initiate litigation against any entity by asserting a patent
250infringement claim (excluding declaratory judgment actions,
251counter-claims, and cross-claims) alleging that a Contributor Version
252directly or indirectly infringes any patent, then the rights granted to
253You by any and all Contributors for the Covered Software under Section
2542.1 of this License shall terminate.
255
2565.3. In the event of termination under Sections 5.1 or 5.2 above, all
257end user license agreements (excluding distributors and resellers) which
258have been validly granted by You or Your distributors under this License
259prior to termination shall survive termination.
260
261************************************************************************
262* *
263* 6. Disclaimer of Warranty *
264* ------------------------- *
265* *
266* Covered Software is provided under this License on an "as is" *
267* basis, without warranty of any kind, either expressed, implied, or *
268* statutory, including, without limitation, warranties that the *
269* Covered Software is free of defects, merchantable, fit for a *
270* particular purpose or non-infringing. The entire risk as to the *
271* quality and performance of the Covered Software is with You. *
272* Should any Covered Software prove defective in any respect, You *
273* (not any Contributor) assume the cost of any necessary servicing, *
274* repair, or correction. This disclaimer of warranty constitutes an *
275* essential part of this License. No use of any Covered Software is *
276* authorized under this License except under this disclaimer. *
277* *
278************************************************************************
279
280************************************************************************
281* *
282* 7. Limitation of Liability *
283* -------------------------- *
284* *
285* Under no circumstances and under no legal theory, whether tort *
286* (including negligence), contract, or otherwise, shall any *
287* Contributor, or anyone who distributes Covered Software as *
288* permitted above, be liable to You for any direct, indirect, *
289* special, incidental, or consequential damages of any character *
290* including, without limitation, damages for lost profits, loss of *
291* goodwill, work stoppage, computer failure or malfunction, or any *
292* and all other commercial damages or losses, even if such party *
293* shall have been informed of the possibility of such damages. This *
294* limitation of liability shall not apply to liability for death or *
295* personal injury resulting from such party's negligence to the *
296* extent applicable law prohibits such limitation. Some *
297* jurisdictions do not allow the exclusion or limitation of *
298* incidental or consequential damages, so this exclusion and *
299* limitation may not apply to You. *
300* *
301************************************************************************
302
3038. Litigation
304-------------
305
306Any litigation relating to this License may be brought only in the
307courts of a jurisdiction where the defendant maintains its principal
308place of business and such litigation shall be governed by laws of that
309jurisdiction, without reference to its conflict-of-law provisions.
310Nothing in this Section shall prevent a party's ability to bring
311cross-claims or counter-claims.
312
3139. Miscellaneous
314----------------
315
316This License represents the complete agreement concerning the subject
317matter hereof. If any provision of this License is held to be
318unenforceable, such provision shall be reformed only to the extent
319necessary to make it enforceable. Any law or regulation which provides
320that the language of a contract shall be construed against the drafter
321shall not be used to construe this License against a Contributor.
322
32310. Versions of the License
324---------------------------
325
32610.1. New Versions
327
328Mozilla Foundation is the license steward. Except as provided in Section
32910.3, no one other than the license steward has the right to modify or
330publish new versions of this License. Each version will be given a
331distinguishing version number.
332
33310.2. Effect of New Versions
334
335You may distribute the Covered Software under the terms of the version
336of the License under which You originally received the Covered Software,
337or under the terms of any subsequent version published by the license
338steward.
339
34010.3. Modified Versions
341
342If you create software not governed by this License, and you want to
343create a new license for such software, you may create and use a
344modified version of this License if you rename the license and remove
345any references to the name of the license steward (except to note that
346such modified license differs from this License).
347
34810.4. Distributing Source Code Form that is Incompatible With Secondary
349Licenses
350
351If You choose to distribute Source Code Form that is Incompatible With
352Secondary Licenses under the terms of this version of the License, the
353notice described in Exhibit B of this License must be attached.
354
355Exhibit A - Source Code Form License Notice
356-------------------------------------------
357
358 This Source Code Form is subject to the terms of the Mozilla Public
359 License, v. 2.0. If a copy of the MPL was not distributed with this
360 file, You can obtain one at http://mozilla.org/MPL/2.0/.
361
362If it is not possible or desirable to put the notice in a particular
363file, then You may include the notice in a location (such as a LICENSE
364file in a relevant directory) where a recipient would be likely to look
365for such a notice.
366
367You may add additional accurate notices of copyright ownership.
368
369Exhibit B - "Incompatible With Secondary Licenses" Notice
370---------------------------------------------------------
371
372 This Source Code Form is "Incompatible With Secondary Licenses", as
373 defined by the Mozilla Public License, v. 2.0.
diff --git a/recipes-sota/aktualizr/files/aktualizr-secondary.service b/recipes-sota/aktualizr/files/aktualizr-secondary.service
new file mode 100644
index 0000000..a1e0e1b
--- /dev/null
+++ b/recipes-sota/aktualizr/files/aktualizr-secondary.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Aktualizr SOTA Client (UPTANE Secondary)
3
4[Service]
5RestartSec=10
6Restart=always
7EnvironmentFile=-/etc/sota/sota.env
8ExecStart=/usr/bin/aktualizr-secondary --config /usr/lib/sota/sota_secondary.toml
9
diff --git a/recipes-sota/aktualizr/files/aktualizr-secondary.socket b/recipes-sota/aktualizr/files/aktualizr-secondary.socket
new file mode 100644
index 0000000..da0ee44
--- /dev/null
+++ b/recipes-sota/aktualizr/files/aktualizr-secondary.socket
@@ -0,0 +1,6 @@
1[Socket]
2ListenStream=9030
3ListenDatagram=9031
4
5[Install]
6WantedBy=sockets.target \ No newline at end of file
diff --git a/recipes-sota/aktualizr/files/aktualizr-serialcan.service b/recipes-sota/aktualizr/files/aktualizr-serialcan.service
new file mode 100644
index 0000000..b42f348
--- /dev/null
+++ b/recipes-sota/aktualizr/files/aktualizr-serialcan.service
@@ -0,0 +1,15 @@
1[Unit]
2Description=Aktualizr SOTA Client
3Wants=network-online.target slcand@ttyACM0.service
4After=network.target network-online.target slcand@ttyACM0.service
5
6Requires=network-online.target
7
8[Service]
9RestartSec=10
10Restart=always
11EnvironmentFile=/usr/lib/sota/sota.env
12ExecStart=/bin/sh -c "(ip addr | grep can0) && /usr/bin/aktualizr $AKTUALIZR_CMDLINE_PARAMETERS"
13
14[Install]
15WantedBy=multi-user.target
diff --git a/recipes-sota/aktualizr/files/aktualizr.service b/recipes-sota/aktualizr/files/aktualizr.service
new file mode 100644
index 0000000..1c2e1df
--- /dev/null
+++ b/recipes-sota/aktualizr/files/aktualizr.service
@@ -0,0 +1,15 @@
1[Unit]
2Description=Aktualizr SOTA Client
3Wants=network-online.target
4After=network.target network-online.target
5Requires=network-online.target
6
7[Service]
8RestartSec=10
9Restart=always
10EnvironmentFile=/usr/lib/sota/sota.env
11EnvironmentFile=-/etc/sota/sota.env
12ExecStart=/usr/bin/aktualizr $AKTUALIZR_CMDLINE_PARAMETERS
13
14[Install]
15WantedBy=multi-user.target
diff --git a/recipes-sota/aktualizr/files/ca.cnf b/recipes-sota/aktualizr/files/ca.cnf
new file mode 100644
index 0000000..352ec38
--- /dev/null
+++ b/recipes-sota/aktualizr/files/ca.cnf
@@ -0,0 +1,10 @@
1[req]
2req_extensions = cacert
3distinguished_name = req_distinguished_name
4
5[req_distinguished_name]
6
7[cacert]
8basicConstraints = critical,CA:true
9keyUsage = keyCertSign
10
diff --git a/recipes-support/asn1c/asn1c.bb b/recipes-support/asn1c/asn1c.bb
new file mode 100644
index 0000000..9d1517d
--- /dev/null
+++ b/recipes-support/asn1c/asn1c.bb
@@ -0,0 +1,17 @@
1SUMMARY = "ASN.1 to C compiler"
2DESCRIPTION = "Generates serialization routines from ASN.1 schemas"
3HOMEPAGE = "http://lionet.info/asn1c"
4SECTION = "base"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ee8bfaaa7d71cf3edb079475e6716d4b"
7
8inherit autotools native
9
10PV = "0.9.28"
11SRC_URI = "https://github.com/vlm/asn1c/releases/download/v${PV}/asn1c-${PV}.tar.gz \
12 file://skeletons_dir_fix.patch"
13SRC_URI[sha256sum] = "8007440b647ef2dd9fb73d931c33ac11764e6afb2437dbe638bb4e5fc82386b9"
14
15BBCLASSEXTEND = "native nativesdk"
16
17# vim:set ts=4 sw=4 sts=4 expandtab:
diff --git a/recipes-support/asn1c/files/skeletons_dir_fix.patch b/recipes-support/asn1c/files/skeletons_dir_fix.patch
new file mode 100644
index 0000000..f1caa2f
--- /dev/null
+++ b/recipes-support/asn1c/files/skeletons_dir_fix.patch
@@ -0,0 +1,44 @@
1From 1a1c2c94f700cf0f4dc5dba863950b16477fdc6d Mon Sep 17 00:00:00 2001
2From: Laurent Bonnans <laurent.bonnans@here.com>
3Date: Thu, 25 Jan 2018 09:49:41 +0100
4Subject: [PATCH] Patch the skeletons directory detection
5
6Detect `share/asn1c` from `bin/` if it exists
7---
8 asn1c/asn1c.c | 9 ++++-----
9 1 file changed, 4 insertions(+), 5 deletions(-)
10
11diff --git a/asn1c/asn1c.c b/asn1c/asn1c.c
12index eb1eff7c..dd9fc832 100644
13--- a/asn1c/asn1c.c
14+++ b/asn1c/asn1c.c
15@@ -226,22 +226,21 @@ main(int ac, char **av) {
16 if(skeletons_dir == NULL) {
17 struct stat sb;
18 skeletons_dir = DATADIR;
19- if((av[-optind][0] == '.' || av[-optind][1] == '/')
20- && stat(skeletons_dir, &sb)) {
21+ if(stat(skeletons_dir, &sb)) {
22 /*
23 * The default skeletons directory does not exist,
24 * compute it from my file name:
25- * ./asn1c/asn1c -> ./skeletons
26+ * ./asn1c/asn1c -> ./share/asn1c
27 */
28 char *p;
29 size_t len;
30
31 p = a1c_dirname(av[-optind]);
32
33- len = strlen(p) + sizeof("/../skeletons");
34+ len = strlen(p) + sizeof("/../share/asn1c");
35 skeletons_dir = malloc(len);
36 assert(skeletons_dir);
37- snprintf(skeletons_dir, len, "%s/../skeletons", p);
38+ snprintf(skeletons_dir, len, "%s/../share/asn1c", p);
39 if(stat(skeletons_dir, &sb)) {
40 fprintf(stderr,
41 "WARNING: skeletons are neither in "
42--
432.15.1
44
diff --git a/recipes-support/boost/bjam-native_1.57.0.bb b/recipes-support/boost/bjam-native_1.57.0.bb
new file mode 100644
index 0000000..d85d1a9
--- /dev/null
+++ b/recipes-support/boost/bjam-native_1.57.0.bb
@@ -0,0 +1,15 @@
1include boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8do_compile() {
9 ./bootstrap.sh --with-toolset=gcc
10}
11
12do_install() {
13 install -d ${D}${bindir}/
14 install -c -m 755 bjam ${D}${bindir}/
15}
diff --git a/recipes-support/boost/boost-1.57.0.inc b/recipes-support/boost/boost-1.57.0.inc
new file mode 100644
index 0000000..809419d
--- /dev/null
+++ b/recipes-support/boost/boost-1.57.0.inc
@@ -0,0 +1,19 @@
1# The Boost web site provides free peer-reviewed portable
2# C++ source libraries. The emphasis is on libraries which
3# work well with the C++ Standard Library. The libraries are
4# intended to be widely useful, and are in regular use by
5# thousands of programmers across a broad spectrum of applications.
6HOMEPAGE = "http://www.boost.org/"
7LICENSE = "BSL-1.0 & MIT & Python-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
9
10BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
11BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
12BOOST_P = "boost_${BOOST_VER}"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
15
16SRC_URI[md5sum] = "1be49befbdd9a5ce9def2983ba3e7b76"
17SRC_URI[sha256sum] = "910c8c022a33ccec7f088bd65d4f14b466588dda94ba2124e78b8c57db264967"
18
19S = "${WORKDIR}/${BOOST_P}"
diff --git a/recipes-support/boost/boost.inc b/recipes-support/boost/boost.inc
new file mode 100644
index 0000000..bc2dc8c
--- /dev/null
+++ b/recipes-support/boost/boost.inc
@@ -0,0 +1,184 @@
1SUMMARY = "Free peer-reviewed portable C++ source libraries"
2SECTION = "libs"
3DEPENDS = "bjam-native zlib bzip2"
4
5ARM_INSTRUCTION_SET = "arm"
6
7BOOST_LIBS = "\
8 atomic \
9 chrono \
10 date_time \
11 filesystem \
12 graph \
13 iostreams \
14 log \
15 program_options \
16 random \
17 regex \
18 serialization \
19 signals \
20 system \
21 test \
22 thread \
23 "
24
25# optional boost-python library
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[python] = ",,python"
28BOOST_LIBS += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}"
29inherit python-dir
30PYTHON_ROOT = "${STAGING_DIR_HOST}/${prefix}"
31
32# Make a package for each library, plus -dev
33PACKAGES = "${PN}-dbg ${BOOST_PACKAGES}"
34python __anonymous () {
35 packages = []
36 extras = []
37 for lib in d.getVar('BOOST_LIBS', True).split( ):
38 pkg = "boost-%s" % lib.replace("_", "-")
39 extras.append("--with-%s" % lib)
40 packages.append(pkg)
41 if not d.getVar("FILES_%s" % pkg, True):
42 d.setVar("FILES_%s" % pkg, "${libdir}/libboost_%s*.so.*" % lib)
43 d.setVar("BOOST_PACKAGES", " ".join(packages))
44 d.setVar("BJAM_EXTRA", " ".join(extras))
45}
46
47# Override the contents of specific packages
48FILES_boost-serialization = "${libdir}/libboost_serialization*.so.* \
49 ${libdir}/libboost_wserialization*.so.*"
50FILES_boost-test = "${libdir}/libboost_prg_exec_monitor*.so.* \
51 ${libdir}/libboost_unit_test_framework*.so.*"
52
53# -dev last to pick up the remaining stuff
54PACKAGES += "${PN}-dev ${PN}-staticdev"
55FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so"
56FILES_${PN}-staticdev = "${libdir}/libboost_*.a"
57
58# "boost" is a metapackage which pulls in all boost librabries
59PACKAGES += "${PN}"
60RRECOMMENDS_${PN} += "${BOOST_PACKAGES}"
61RRECOMMENDS_${PN}_class-native = ""
62ALLOW_EMPTY_${PN} = "1"
63
64# to avoid GNU_HASH QA errors added LDFLAGS to ARCH; a little bit dirty but at least it works
65TARGET_CC_ARCH += "${LDFLAGS}"
66
67# Oh yippee, a new build system, it's sooo cooool I could eat my own
68# foot. inlining=on lets the compiler choose, I think. At least this
69# stuff is documented...
70# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
71# objcopy will be invoked, and that won't work. Building debug apparently
72# requires hacking gcc-tools.jam
73#
74# Sometimes I wake up screaming. Famous figures are gathered in the nightmare,
75# Steve Bourne, Larry Wall, the whole of the ANSI C committee. They're just
76# standing there, waiting, but the truely terrifying thing is what they carry
77# in their hands. At first sight each seems to bear the same thing, but it is
78# not so for the forms in their grasp are ever so slightly different one from
79# the other. Each is twisted in some grotesque way from the other to make each
80# an unspeakable perversion impossible to perceive without the onset of madness.
81# True insanity awaits anyone who perceives all of these horrors together.
82#
83# Quotation marks, there might be an easier way to do this, but I can't find
84# it. The problem is that the user.hpp configuration file must receive a
85# pre-processor macro defined as the appropriate string - complete with "'s
86# around it. (<> is a possibility here but the danger to that is that the
87# failure case interprets the < and > as shell redirections, creating
88# random files in the source tree.)
89#
90#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
91#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
92SQD = '"'
93EQD = '\"'
94#boost.bb: "... '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
95BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
96
97BJAM_TOOLS = "--ignore-site-config \
98 '-sTOOLS=gcc' \
99 '-sGCC=${CC} '${BJAM_CONF} \
100 '-sGXX=${CXX} '${BJAM_CONF} \
101 '-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
102 '-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
103 '-sBUILD=release <optimization>space <threading>multi <inlining>on <debug-symbols>off' \
104 '-sPYTHON_VERSION=${PYTHON_BASEVERSION}' \
105 '-sPYTHON_ROOT=${PYTHON_ROOT}' \
106 '--layout=system' \
107 "
108
109# use PARALLEL_MAKE to speed up the build, but limit it by -j 64, greater paralelism causes bjam to segfault or to ignore -j
110# https://svn.boost.org/trac/boost/ticket/7634
111def get_boost_parallel_make(bb, d):
112 pm = d.getVar('PARALLEL_MAKE', True)
113 if pm:
114 # look for '-j' and throw other options (e.g. '-l') away
115 # because they might have different meaning in bjam
116 pm = pm.split()
117 while pm:
118 v = None
119 opt = pm.pop(0)
120 if opt == '-j':
121 v = pm.pop(0)
122 elif opt.startswith('-j'):
123 v = opt[2:].strip()
124 else:
125 v = None
126
127 if v:
128 v = min(64, int(v))
129 return '-j' + str(v)
130
131 return ""
132
133BOOST_PARALLEL_MAKE = "${@get_boost_parallel_make(bb, d)}"
134BJAM_OPTS = '${BOOST_PARALLEL_MAKE} \
135 ${BJAM_TOOLS} \
136 -sBOOST_BUILD_USER_CONFIG=${S}/tools/build/example/user-config.jam \
137 --builddir=${S}/${TARGET_SYS} \
138 --disable-icu \
139 ${BJAM_EXTRA}'
140
141# Native compilation of bzip2 isn't working
142BJAM_OPTS_append_class-native = ' -sNO_BZIP2=1'
143
144do_boostconfig() {
145 cp -f boost/config/platform/linux.hpp boost/config/platform/linux-gnueabi.hpp
146
147 # D2194:Fixing the failure of "error: duplicate initialization of gcc with the following parameters" during compilation.
148 sed -i "/^using gcc : 4.3.1/d" ${S}/tools/build/example/user-config.jam
149 sed -i "/^using python : ${PYTHON_BASEVERSION}"/d ${S}/tools/build/example/user-config.jam
150 echo 'using gcc : 4.3.1 : ${CXX} : <cflags>"${CFLAGS}" <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;' >> ${S}/tools/build/example/user-config.jam
151 echo "using python : ${PYTHON_BASEVERSION} : : ${STAGING_INCDIR}/python${PYTHON_BASEVERSION} ;" >> ${S}/tools/build/example/user-config.jam
152
153 CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" ./bootstrap.sh --with-bjam=bjam --with-toolset=gcc --with-python-root=${PYTHON_ROOT}
154 sed -i '/^using python/d' project-config.jam
155}
156
157addtask do_boostconfig after do_patch before do_configure
158
159do_compile() {
160 set -ex
161 bjam ${BJAM_OPTS} --prefix=${prefix} \
162 --exec-prefix=${exec_prefix} \
163 --libdir=${libdir} \
164 --includedir=${includedir}
165}
166
167do_install() {
168 set -ex
169 bjam ${BJAM_OPTS} \
170 --libdir=${D}${libdir} \
171 --includedir=${D}${includedir} \
172 install
173 for lib in ${BOOST_LIBS}; do
174 if [ -e ${D}${libdir}/libboost_${lib}.a ]; then
175 ln -s libboost_${lib}.a ${D}${libdir}/libboost_${lib}-mt.a
176 fi
177 if [ -e ${D}${libdir}/libboost_${lib}.so ]; then
178 ln -s libboost_${lib}.so ${D}${libdir}/libboost_${lib}-mt.so
179 fi
180 done
181
182}
183
184BBCLASSEXTEND = "native"
diff --git a/recipes-support/boost/boost/arm-intrinsics.patch b/recipes-support/boost/boost/arm-intrinsics.patch
new file mode 100644
index 0000000..fe85c69
--- /dev/null
+++ b/recipes-support/boost/boost/arm-intrinsics.patch
@@ -0,0 +1,55 @@
1Upstream-Status: Backport
2
38/17/2010 - rebased to 1.44 by Qing He <qing.he@intel.com>
4
5diff --git a/boost/smart_ptr/detail/atomic_count_sync.hpp b/boost/smart_ptr/detail/atomic_count_sync.hpp
6index b6359b5..78b1cc2 100644
7--- a/boost/smart_ptr/detail/atomic_count_sync.hpp
8+++ b/boost/smart_ptr/detail/atomic_count_sync.hpp
9@@ -33,17 +33,46 @@ public:
10
11 long operator++()
12 {
13+#ifdef __ARM_ARCH_7A__
14+ int v1, tmp;
15+ asm volatile ("1: \n\t"
16+ "ldrex %0, %1 \n\t"
17+ "add %0 ,%0, #1 \n\t"
18+ "strex %2, %0, %1 \n\t"
19+ "cmp %2, #0 \n\t"
20+ "bne 1b \n\t"
21+ : "=&r" (v1), "+Q"(value_), "=&r"(tmp)
22+ );
23+#else
24 return __sync_add_and_fetch( &value_, 1 );
25+#endif
26 }
27
28 long operator--()
29 {
30+#ifdef __ARM_ARCH_7A__
31+ int v1, tmp;
32+ asm volatile ("1: \n\t"
33+ "ldrex %0, %1 \n\t"
34+ "sub %0 ,%0, #1 \n\t"
35+ "strex %2, %0, %1 \n\t"
36+ "cmp %2, #0 \n\t"
37+ "bne 1b \n\t"
38+ : "=&r" (v1), "+Q"(value_), "=&r"(tmp)
39+ );
40+ return value_;
41+#else
42 return __sync_add_and_fetch( &value_, -1 );
43+#endif
44 }
45
46 operator long() const
47 {
48+#if __ARM_ARCH_7A__
49+ return value_;
50+#else
51 return __sync_fetch_and_add( &value_, 0 );
52+#endif
53 }
54
55 private:
diff --git a/recipes-support/boost/boost_1.57.0.bb b/recipes-support/boost/boost_1.57.0.bb
new file mode 100644
index 0000000..c09d5f4
--- /dev/null
+++ b/recipes-support/boost/boost_1.57.0.bb
@@ -0,0 +1,6 @@
1include boost-${PV}.inc
2include boost.inc
3
4SRC_URI += "\
5 file://arm-intrinsics.patch \
6"
diff --git a/recipes-support/libsodium/libsodium_1.0.11.bb b/recipes-support/libsodium/libsodium_1.0.11.bb
new file mode 100644
index 0000000..cbcbe96
--- /dev/null
+++ b/recipes-support/libsodium/libsodium_1.0.11.bb
@@ -0,0 +1,12 @@
1SUMMARY = "The Sodium crypto library"
2HOMEPAGE = "http://libsodium.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c9f00492f01f5610253fde01c3d2e866"
5
6SRC_URI = "https://download.libsodium.org/libsodium/releases/${BPN}-${PV}.tar.gz"
7SRC_URI[md5sum] = "b58928d035064b2a46fb564937b83540"
8SRC_URI[sha256sum] = "a14549db3c49f6ae2170cbbf4664bd48ace50681045e8dbea7c8d9fb96f9c765"
9
10inherit autotools
11
12BBCLASSEXTEND = "native nativesdk"