summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ipc-transport-srio-test_git.bb30
-rw-r--r--recipes-ti/ipc/ipc-transport-srio.inc16
-rw-r--r--recipes-ti/ipc/ipc-transport-srio_git.bb14
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-srio-test_git.bb b/recipes-ti/ipc/ipc-transport-srio-test_git.bb
new file mode 100644
index 00000000..866fc35c
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-srio-test_git.bb
@@ -0,0 +1,30 @@
1include ipc-transport-srio.inc
2
3DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc"
4
5DEVICELIST = "k2h k2k"
6
7CHOICELIST = "yes no"
8
9do_compile () {
10# Now build the test code
11 for device in ${DEVICELIST}
12 do
13 for choice in ${CHOICELIST}
14 do
15 oe_runmake tests \
16 IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
17 USEDYNAMIC_LIB="$choice" DEVICE="$device"
18 done
19 done
20}
21
22do_install () {
23
24 for device in ${DEVICELIST}
25 do
26 oe_runmake installbin \
27 INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
28 done
29
30}
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc
new file mode 100644
index 00000000..e286421f
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-srio.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport"
2LICENSE = "BSD-3-Clause"
3
4LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
5
6BRANCH="master"
7SRC_URI = "git://git.ti.com/keystone-linux/ipc-transport.git;protocol=git;branch=${BRANCH}"
8# Below commit ID corresponds to DEV.IPC-TRANSPORT.01.00.00.00
9SRCREV = "b3077467126c84b5d583dc29e13ab221064b687b"
10PV = "01.00.00.00"
11
12COMPATIBLE_MACHINE = "keystone"
13
14S = "${WORKDIR}/git/linux/srio"
15
16EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_SRIO_SRC_DIR=${S}"
diff --git a/recipes-ti/ipc/ipc-transport-srio_git.bb b/recipes-ti/ipc/ipc-transport-srio_git.bb
new file mode 100644
index 00000000..266aa4e2
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-srio_git.bb
@@ -0,0 +1,14 @@
1include ipc-transport-srio.inc
2
3DEPENDS = "ti-ipc mpm-transport"
4
5do_compile () {
6# Now build the transport
7 oe_runmake clean
8 oe_runmake lib
9}
10
11do_install () {
12 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
13 INSTALL_LIB_BASE_DIR=${D}${libdir}
14}