diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/hplib/hplib-mod_git.bb | 20 | ||||
-rw-r--r-- | recipes-bsp/hplib/hplib-test_git.bb | 30 | ||||
-rw-r--r-- | recipes-bsp/hplib/hplib.inc | 10 | ||||
-rw-r--r-- | recipes-bsp/hplib/hplib_git.bb | 30 |
4 files changed, 90 insertions, 0 deletions
diff --git a/recipes-bsp/hplib/hplib-mod_git.bb b/recipes-bsp/hplib/hplib-mod_git.bb new file mode 100644 index 00000000..acef1ce5 --- /dev/null +++ b/recipes-bsp/hplib/hplib-mod_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "TI High Performance Library kernel module" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/module/COPYING.txt;md5=c1c4d3453cddc5b7f0ce84a277e66779" | ||
4 | |||
5 | DEPENDS = "hplib" | ||
6 | |||
7 | include hplib.inc | ||
8 | |||
9 | # This package builds a kernel module, use kernel PR as base and append a local | ||
10 | MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | S ="${WORKDIR}/git/ti/runtime/hplib/module" | ||
14 | EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} PDK_INSTALL_PATH=${STAGING_INCDIR}" | ||
15 | |||
16 | inherit module | ||
17 | |||
18 | do_install () { | ||
19 | oe_runmake install INSTALL_MOD_PATH="${D}" | ||
20 | } | ||
diff --git a/recipes-bsp/hplib/hplib-test_git.bb b/recipes-bsp/hplib/hplib-test_git.bb new file mode 100644 index 00000000..574fa2a7 --- /dev/null +++ b/recipes-bsp/hplib/hplib-test_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "TI High performance library test binaries" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/src/COPYING.txt;md5=b7982a377c680ad71ca2fbb735982462" | ||
4 | |||
5 | DEPENDS = "common-csl-ip qmss-lld sa-lld pktlib hplib" | ||
6 | |||
7 | include hplib.inc | ||
8 | |||
9 | CHOICELIST = "yes no" | ||
10 | |||
11 | S = "${WORKDIR}/git/ti/runtime/hplib" | ||
12 | |||
13 | EXTRA_OEMAKE += '-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}' | ||
14 | |||
15 | do_compile () { | ||
16 | for device in ${DEVICELIST} | ||
17 | do | ||
18 | for choice in ${CHOICELIST} | ||
19 | do | ||
20 | oe_runmake tests HPLIB_SRC_DIR=${S} USEDYNAMIC_LIB=$choice DEVICE="$device" | ||
21 | done | ||
22 | done | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | for device in ${DEVICELIST} | ||
27 | do | ||
28 | oe_runmake installbin INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
29 | done | ||
30 | } | ||
diff --git a/recipes-bsp/hplib/hplib.inc b/recipes-bsp/hplib/hplib.inc new file mode 100644 index 00000000..99254d1f --- /dev/null +++ b/recipes-bsp/hplib/hplib.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | COMPATIBLE_MACHINE = "keystone" | ||
2 | |||
3 | DEVICELIST = "k2h k2k k2l k2e" | ||
4 | |||
5 | BRANCH = "master" | ||
6 | SRC_URI = "git://git.ti.com/keystone-rtos/hplib.git;protocol=git;branch=${BRANCH}" | ||
7 | |||
8 | # Below Commit ID corresponds to "DEV.HPLIB.01.01.00.04" | ||
9 | SRCREV = "89d847bb8155f5727867d82f96978f89ea0a7d13" | ||
10 | PV = "01.01.00.04" | ||
diff --git a/recipes-bsp/hplib/hplib_git.bb b/recipes-bsp/hplib/hplib_git.bb new file mode 100644 index 00000000..fbb3004c --- /dev/null +++ b/recipes-bsp/hplib/hplib_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "TI High performance libraries" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/src/COPYING.txt;md5=b7982a377c680ad71ca2fbb735982462" | ||
4 | |||
5 | DEPENDS = "common-csl-ip rm-lld qmss-lld sa-lld pktlib" | ||
6 | |||
7 | include hplib.inc | ||
8 | |||
9 | CHOICELIST = "yes no" | ||
10 | |||
11 | S = "${WORKDIR}/git/ti/runtime/hplib" | ||
12 | |||
13 | EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | ||
14 | |||
15 | do_compile () { | ||
16 | for device in ${DEVICELIST} | ||
17 | do | ||
18 | for choice in ${CHOICELIST} | ||
19 | do | ||
20 | oe_runmake lib HPLIB_SRC_DIR=${S} USEDYNAMIC_LIB=$choice DEVICE="$device" | ||
21 | done | ||
22 | done | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | for device in ${DEVICELIST} | ||
27 | do | ||
28 | oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
29 | done | ||
30 | } | ||